Welcome to the North American Subaru Impreza Owners Club Saturday December 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-27-2009, 12:01 AM   #1
decepticon
Scooby Newbie
 
Member#: 18129
Join Date: Apr 2002
Location: columbus, Ohio
Vehicle:
1999 2.5RS-T Impreza
Silverthorn metalic

Question Idle issue...

This issue has been going on for years, i've yet to find an answer. So I figured I will try here.

My problem is when my car is sitting idle at like a light or stop sign, my rpm's bounce around from 800-1200 i'd say, and about 95% of the time it will just stall out and make it look like i'm still learning to drive a manual transmission

Is it possible that this issue is due to the flywheel?

My specs:
New EJ25 Block with JE 8.5:1 pistons
Pauter Rods
Total Seal rings
T4 Turbo
Greddy (trust) GC8 FMIC
Exedy Street Clutch
Fidenza Flywheel - could this be the problem?
Vishnu WRX fuel rails
RC 440cc Injectors - getting 750's soon
Supra fuel pump
Hydra EMS ECU

If you need anymore info just let me know, thanks for your help in advance.
* Registered users of the site do not see these ads.
decepticon is offline   Reply With Quote
Old 10-27-2009, 12:44 AM   #2
ADAS1223
Scooby Specialist
 
Member#: 159853
Join Date: Sep 2007
Chapter/Region: NESIC
Location: tri-state
Vehicle:
2005 Impreza
wrb

Default

I believe your tuner should know whats up. i had the same problem, and i raised my idle so it doesnt stall, cleaned my IACV too.
ADAS1223 is offline   Reply With Quote
Old 10-27-2009, 03:43 AM   #3
impreza_GC8
Scooby Specialist
 
Member#: 123295
Join Date: Aug 2006
Chapter/Region: TXIC
Location: Midland, TX
Vehicle:
2000 2.5RS moneypit
2012 Ford Fusion 6MT (DD)

Default

First things first, try cleaning your IACV.
impreza_GC8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jumping idle issues, any ideas? Also fueling issues. roninsoldier83 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 05-20-2009 12:32 PM
weird idle issue...not average idle stuff slingshot Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 09-25-2006 05:24 PM
idle issues and boost issues jdgrimm Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 07-05-2006 10:45 PM
Idling Issues KTB Warranty Issues & SOA Problems 7 04-17-2002 09:00 PM
Long overdue update on idle issue plus website info :) Warp3 South East Region Forum 4 01-17-2001 08:38 PM


All times are GMT -4. The time now is 02:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.