Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-21-2009, 01:41 AM   #1
subystone
Scooby Specialist
 
Member#: 138598
Join Date: Jan 2007
Chapter/Region: RMIC
Location: O-Town!!!
Vehicle:
wrx impretza saloon
ralle de mundo azul

Unhappy a leak... a bad bad leak...

k so i got the intercooler in, did a bunch of work to the car, put the midpipe back in with new mounting ish, works great! for everyone that knew my car before, it rattled really, really bad. not anymore!

so i start up the car, and sure as hell is even quieter than it was before! but, there is a nasty nasty leak sound. and my boost isn't as high. so i popped the hood to find the source. it's loud as hell around my turbo (sounds like it's coming from underneath). it almost sounds like backfire is coming in the engine bay. i have a turbo xs up-pipe. still runs almost perfect. smooth except that leak i can tell is f'n with somethin...
what i'm asking is has anyone experienced this problem before and is there some type of common problem that this sounds like to anyone?
* Registered users of the site do not see these ads.
subystone is offline   Reply With Quote
Old 09-21-2009, 03:19 AM   #2
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

Its pretty common for the inlet pipe to rip by the turbo, and very well could be on the bottom side where it isn't as noticeable. You could try a smoke test...
EsubaruJ is offline   Reply With Quote
Old 09-21-2009, 07:49 AM   #3
subystone
Scooby Specialist
 
Member#: 138598
Join Date: Jan 2007
Chapter/Region: RMIC
Location: O-Town!!!
Vehicle:
wrx impretza saloon
ralle de mundo azul

Default

smoke test??? i think i grasp the idea just fine but could you explain?
subystone is offline   Reply With Quote
Old 09-21-2009, 10:55 PM   #4
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

I could really only find one good link, but its pretty simple. Just cap off the intake and blow smoke through the system and watch to see if it comes out.
http://www.iwsti.com/forums/how-inst...ak-tester.html
EsubaruJ is offline   Reply With Quote
Old 09-22-2009, 04:51 AM   #5
subystone
Scooby Specialist
 
Member#: 138598
Join Date: Jan 2007
Chapter/Region: RMIC
Location: O-Town!!!
Vehicle:
wrx impretza saloon
ralle de mundo azul

Default

just another note i didn't put above: when my car starts making boost it sounds like a supercharger. it whines really loud. sounds just like the little ecotech superchargers on the cobalt ss.

wasn't making this sound before but i did throw a check engine light, assuming it was somewhere around the intercooler (as it has been twice before) i put the larger top mount on and reset the ecu. i've gone 150 miles since then and no light yet but now this sound appears. could it be somewhere on the topmount?
subystone is offline   Reply With Quote
Old 09-23-2009, 12:03 AM   #6
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

So it wasn't making the whining noise with the old tmic? Are you using the y pipe from the old tmic on the new tmic?
EsubaruJ is offline   Reply With Quote
Old 09-24-2009, 04:57 PM   #7
subystone
Scooby Specialist
 
Member#: 138598
Join Date: Jan 2007
Chapter/Region: RMIC
Location: O-Town!!!
Vehicle:
wrx impretza saloon
ralle de mundo azul

Default

new silicone y-pipe.
it started making the leak while i was running open downpipe (while i was tending to my exhaust knocking issues). i couldn't hear the whine probably just due to the loudness. the leak was the same though when i popped the hood.
subystone is offline   Reply With Quote
Old 09-28-2009, 04:36 PM   #8
subystone
Scooby Specialist
 
Member#: 138598
Join Date: Jan 2007
Chapter/Region: RMIC
Location: O-Town!!!
Vehicle:
wrx impretza saloon
ralle de mundo azul

Default

bump???
subystone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad fuel leak problem ibanez7 Factory 2.0L Turbo Powertrain 0 09-30-2006 09:29 PM
TD04 bad oil leak from behind comp & exhaust turbine pics inside cky211 Factory 2.0L Turbo Powertrain 10 09-22-2005 08:48 PM
bad exhaust leak from where any shops in southern ny gsteclipse33 Factory 2.0L Turbo Powertrain 10 01-10-2005 01:20 AM
Bad Oil Leak. aussieben Normally Aspirated Powertrain 8 10-05-2004 07:54 PM
Help: bad oil leak after uppipe install abaxter34 Factory 2.0L Turbo Powertrain 11 04-27-2004 03:17 AM


All times are GMT -4. The time now is 09:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.