Welcome to the North American Subaru Impreza Owners Club Monday December 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-04-2009, 03:34 PM   #1
carter_wrx
Scooby Newbie
 
Member#: 225745
Join Date: Oct 2009
Chapter/Region: W. Canada
Location: Calgary
Vehicle:
2002 WRX wagon
WRB

Default rough idle, misfire, CEL funky high idle

Hey guys, new here...and having some wierd issues with my JDM 94 sube...its got the 2.0L turbo of course...117 xxxkm's

well, its intermitent, one day i came home and it had a bouncy idle and check engine light came on but when driving it drove normal. I shut it off...bought a case of beer and came out...and it ran fine...

also while running, idling fine you can hear it hicup (for lack of a better work) slightly like its misfiring.

a few weeks later i started it after work and it idled up to 2000 rpm and wouldn't go down, so i limped it home and checked hoses, conections etc. i took the maf out and it appeared to be clean. The sensor conected to the TB i beleive is the throttle possition sensor? i unplugged that and and the idle dropped to almost normal. I should add that turning the A/C on would make it drop as well.

I pulled it off to see if i could clean it...couldn't, it apears to be a sealed unit so i reinstalled it and adjusted itso it'll idle at 1000 rpm at idle. plugged it back in and works fine.

Now that the cold weather is here (around 0 celcius) it is not happy about starting, it'll have a real rough low idle for 5 seconds and then idle up to 1000 and be fine.

Recently i've also noticed when doing a hard pull it'll surge around 5000 rpm...feels like it loses boost but the boost gauge says 13 psi and doesnt move...it maybe a misfire too...

- I plan on doing a tune up (plugs, air filter, possibly coilpacks?) this weekend but, i know this wont fix my non existant high idle when cold problems...anyone have a clue of whats going on? And is there a way to check what the CEL means on these older cars? thanks guys
* Registered users of the site do not see these ads.
carter_wrx is offline   Reply With Quote
Old 10-04-2009, 03:44 PM   #2
carter_wrx
Scooby Newbie
 
Member#: 225745
Join Date: Oct 2009
Chapter/Region: W. Canada
Location: Calgary
Vehicle:
2002 WRX wagon
WRB

Default

also if i try give it a bit of throttle to help it idle up it tries to die... im able to get a video of whats happening if that would help you guys. Thanks
carter_wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle, Rough Idle? Brettweiser Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 04-10-2007 12:10 AM
Rough idle, misfire CEL, car stumbles when cold roksax Service & Maintenance 6 07-22-2006 04:53 PM
High idle, CEL, Outback EJ25, misfire, related? CirrusWRX Normally Aspirated Powertrain 10 05-01-2005 04:11 AM
Rough Idle and CEL 6Pack Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 06-25-2003 10:46 AM
Spark plug=very rough idle and CEL? Bunuel Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 07-23-2002 12:59 AM


All times are GMT -4. The time now is 07:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.