Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-04-2009, 11:43 PM   #1
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
02 WRX
PSM

Default Why are my windshield wipers retarded?

My windshield wipers have started to go too far on the windshield when wiping. About once every 100 wipes the drivers side wiper will go so far that it goes off the windshield and gets stuck on the antenna mount.

This is super annoying, and I don't even know what to do here. I tried getting an inch shorter wipers on the drivers side, but still happens.

Any suggestions from you guys?
* Registered users of the site do not see these ads.
tabrad is offline   Reply With Quote
Old 10-04-2009, 11:52 PM   #2
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

Same thing happened on my bugeye. I just put in a new wiper assembly and it worked fine after that, it seems to be pretty common with these cars. I have a full assembly from an impreza that might work...
EsubaruJ is offline   Reply With Quote
Old 10-04-2009, 11:55 PM   #3
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
02 WRX
PSM

Default

What do you by full assembly? new motor and such?
tabrad is offline   Reply With Quote
Old 10-05-2009, 12:01 AM   #4
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

Wiper linkage, arm, and motor.
EsubaruJ is offline   Reply With Quote
Old 10-05-2009, 01:00 AM   #5
ashergrey
Scooby Specialist
 
Member#: 174533
Join Date: Mar 2008
Chapter/Region: RMIC
Location: SLC, UT
Vehicle:
0694 WRXLtd/LegWagon
WRB/Pure White

Default

Have you tried just taking the arm off and reseating it?
ashergrey is offline   Reply With Quote
Old 10-05-2009, 01:24 AM   #6
toddguy
Scooby Specialist
 
Member#: 158534
Join Date: Sep 2007
Chapter/Region: RMIC
Location: Provo, Utah
Vehicle:
99 2.5 Wagon
76 280Z

Default

mine just slap back and forth... they hit the pillar and the bottom every time, and make tons of noise. suuuuuper annoying.
toddguy is offline   Reply With Quote
Old 10-05-2009, 01:25 AM   #7
fastbluewrx07
Scooby Specialist
 
Member#: 143703
Join Date: Mar 2007
Chapter/Region: RMIC
Location: SL,UT
Default

push car off cliff?





JK
Hope you get that fixed, sounds annoying.
fastbluewrx07 is offline   Reply With Quote
Old 10-05-2009, 12:15 PM   #8
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
02 WRX
PSM

Default

Quote:
Originally Posted by ashergrey View Post
Have you tried just taking the arm off and reseating it?
No I haven't but I will to see if it helps with anything
tabrad is offline   Reply With Quote
Old 10-05-2009, 12:23 PM   #9
Kentrik
Scooby Specialist
 
Member#: 125937
Join Date: Sep 2006
Chapter/Region: RMIC
Location: 4894' above sea level.
Vehicle:
03 WRX I do not
like your tweed, chap.

Default

Mine have been doing the same thing. :P


Balls.
Kentrik is offline   Reply With Quote
Old 10-05-2009, 12:51 PM   #10
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
02 WRX
PSM

Default

Quote:
Originally Posted by fastbluewrx07 View Post
push car off cliff?
Sometimes it is tempting to try to cash in on insurance
tabrad is offline   Reply With Quote
Old 10-05-2009, 01:32 PM   #11
scoobydorift
Scooby Specialist
 
Member#: 43128
Join Date: Sep 2003
Location: SLC
Vehicle:
92 RWD, 96 FWD
05 AWD

Default

As stated before, it is the wiper linkage. I doubt you will need a new motor, but you will need to replace both sides of the linkage. Its a bitch to get to and change also!

Rick
scoobydorift is offline   Reply With Quote
Old 10-05-2009, 01:34 PM   #12
tabrad
Scooby Specialist
 
Member#: 157229
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC, Utah
Vehicle:
02 WRX
PSM

Default

Quote:
Originally Posted by scoobydorift View Post
As stated before, it is the wiper linkage. I doubt you will need a new motor, but you will need to replace both sides of the linkage. Its a bitch to get to and change also!

Rick
Are you 100% sure? Because I don't want to order the parts, then have it not fix the problem. And I need both linkages?
tabrad is offline   Reply With Quote
Old 10-05-2009, 03:01 PM   #13
scoobydorift
Scooby Specialist
 
Member#: 43128
Join Date: Sep 2003
Location: SLC
Vehicle:
92 RWD, 96 FWD
05 AWD

Default

Can you grab onto the wiper arm and move it? if there is play, the linkage bushings are ****ed. You can get just the new linkage bushings, someone did a write-up using autozone bushings, but I would just buy the whole new assembly from Subaru.

You can also check the bushings by taking the motor off, which will allow you to see into the firewall and you can reach in and feel if it is messed up, there might be another inspection plate somewhere else on the firewall too...I cant remember.

And Subaru allows you to take back parts as long as they are new in box, just don't rip them out of the package until you know you are going to need it and it is going to fit.

You will love the new linkage anyway, nice smooth action of the wiper arms, makes the car feel like new again lol.

Edit. And putting the new "cups" onto the balls takes a lot more force than you think is needed, I thought I was going to break it trying to pop it on.
scoobydorift is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to get my windshield wiper blades rebuilt? jdmimpreza Southern California Impreza Club Forum -- SCIC 21 11-06-2007 06:29 PM
random q: i found an ace playing card on my under my windshield wiper...? White 2.5rs Off-Topic 45 07-03-2005 11:03 PM
My windshield wipers just don't work over 85 Sordid Philosopher General Community 18 11-20-2002 09:45 PM
Who left up my windshield wipers at Home Depot ? PKduck Bay Area Impreza Club Forum -- BAIC 2 12-27-2001 02:23 AM


All times are GMT -4. The time now is 09:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.