Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-06-2009, 06:41 PM   #1
PorterFNU
Scooby Newbie
 
Member#: 216995
Join Date: Jul 2009
Location: Monmouth County, NJ
Vehicle:
2002 WRX Wagon
Silver

Default Cel P0442

I have an '02 WRX with Cobb AP (stage 2, 93 Oct), catless Uppipe and Cobb highflow catted downpipe. Still have stock exhaust from donut gasket back. I keep getting the following CEL:
P0442 Evaporative Emission Control System Leak (small leak).
I keep resetting the code and it keeps coming back. I thought it might be that the gas cap was not on tight but I've filled it up 3 times and double check the cap each time.
Any thoughts on what might be causing it? Any ideas as to where to look for the leak?
Thanks.
* Registered users of the site do not see these ads.
PorterFNU is offline   Reply With Quote
Old 10-06-2009, 06:52 PM   #2
*DonkeyPunch*
Scooby Newbie
 
Member#: 195425
Join Date: Nov 2008
Vehicle:
2004 WRX
Red

Default

check the actual evap canister itself,to if everything is tight,if you dont know where that is its at the back of the car,passenger side,black rectangle looking guy.
*DonkeyPunch* is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL p0442 fixed- may help you WRC_Fever Factory 2.5L Turbo Powertrain 19 01-17-2014 12:30 PM
CEL P0442 stand up imma_stocker Texas Impreza Club Forum -- TXIC 6 11-04-2007 10:19 PM
CEL P0442 (evap small leak) + instable boost frederik Factory 2.0L Turbo Powertrain 4 10-20-2007 11:49 AM
Cel P0442 Rando Engine Management & Tuning 5 03-29-2006 10:14 PM
CEL P0442/P0457? (Help Needed) APSWRX1 Texas Impreza Club Forum -- TXIC 4 03-28-2006 02:16 PM


All times are GMT -4. The time now is 06:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.