Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-23-2009, 10:57 PM   #1
bstdwgn
Scooby Newbie
 
Member#: 152662
Join Date: Jun 2007
Chapter/Region: NESIC
Location: Bridgeport
Vehicle:
2004 WRX
Aspen White

Default Perrin Lightweight crank pulley... help

i just recently installed a perrin LWCP in my car with the help of a buddy and we also did the timing belt accessory belts and the thermostat.... my car runs fine and boosts no problem.. my problem is when i come to a stop my car sounds like it has a cam in it... its idling funny... any thoughts? anyone heard of this? ANY help is appreciated! thanks..
* Registered users of the site do not see these ads.
bstdwgn is offline   Reply With Quote
Old 10-23-2009, 11:07 PM   #2
spinningcain
Scooby Specialist
 
Member#: 176490
Join Date: Apr 2008
Chapter/Region: SWIC
Location: Las Vegas
Vehicle:
2005 STI
WRB

Default

I don't think it has anything to do with the pulley. I just put one on my car last week runs great. It could be you got the timing off a tooth our two
spinningcain is offline   Reply With Quote
Old 10-23-2009, 11:12 PM   #3
BONFIRE074
Scooby Specialist
 
Member#: 166936
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Canton CT
Vehicle:
2006 Unicorn
Saabaru 9-2x

Default

Check and see if the crank pulley was accidently tightened down crooked(when car is running look down at it)..that would could cause some balance issues I suppose but enough to sound like your car has a cam, I don't know
BONFIRE074 is offline   Reply With Quote
Old 10-24-2009, 12:14 AM   #4
penusai
Scooby Specialist
 
Member#: 102808
Join Date: Dec 2005
Chapter/Region: Tri-State
Location: Queens, NY
Vehicle:
2002 v8 EJ207
v7 6spd FP Green

Default

i would check timing...
penusai is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stock STi uppipe and perrin lightweight crank pulley kettsupp Private 'For Sale' Classifieds 12 06-20-2006 02:45 AM
Perrin Lightweight Crank Pulley Follow-up Mechkiller31st Normally Aspirated Powertrain 6 05-31-2006 05:34 PM
Perrin Lightweight Crank Pulley hanzo918 Private 'For Sale' Classifieds 1 09-02-2005 10:56 PM
Perrin lightweight crank pulley djerickd Private 'For Sale' Classifieds 7 07-30-2005 12:27 AM
FS CA : Perrin Lightweight Crank Pulley Seranin Private 'For Sale' Classifieds 3 11-14-2004 10:08 PM


All times are GMT -4. The time now is 01:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.