Welcome to the North American Subaru Impreza Owners Club Wednesday December 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-26-2009, 12:25 PM   #1
blackmist27
Scooby Newbie
 
Member#: 209169
Join Date: Apr 2009
Default 09 WRX Stage 2 issue

so this weekend i finally installed my Cobb stage 2. however on the drive home from the shop the car sounded like i had a duck in the motor... meaning it sounded like a gasket leak. then after a couple hard acceleration attempts the sound went away. the car doesnt feel as fast as stage 1. not really sure why but i am guessing there is a boost leak. so i open the hood and on the drivers side of the outlet of the intercooler i see a white looking pasty material spread around the hose. so i am guessing thats the leak. any one ever experience that? also if thats not it, think the dealership will fix my boost leak assuming i re-install the stock map before hand of course...?please help!
* Registered users of the site do not see these ads.
blackmist27 is offline   Reply With Quote
Old 10-26-2009, 02:51 PM   #2
binaryterror
Scooby Newbie
 
Member#: 208459
Join Date: Apr 2009
Location: Detroit, MI
Vehicle:
2008 Impreza WRX
Spark Silver

Default

Did you do the Stage 2 supporting mods or did you just flash in stage 2?
binaryterror is offline   Reply With Quote
Old 10-26-2009, 02:52 PM   #3
blackmist27
Scooby Newbie
 
Member#: 209169
Join Date: Apr 2009
Default

Quote:
Originally Posted by binaryterror View Post
Did you do the Stage 2 supporting mods or did you just flash in stage 2?
Cobb downpipe, stage 2 software
blackmist27 is offline   Reply With Quote
Old 10-26-2009, 03:35 PM   #4
binaryterror
Scooby Newbie
 
Member#: 208459
Join Date: Apr 2009
Location: Detroit, MI
Vehicle:
2008 Impreza WRX
Spark Silver

Default

Did you install new gaskets both at the turbo and the CBE donut?
binaryterror is offline   Reply With Quote
Old 10-26-2009, 03:37 PM   #5
blackmist27
Scooby Newbie
 
Member#: 209169
Join Date: Apr 2009
Default

Quote:
Originally Posted by binaryterror View Post
Did you install new gaskets both at the turbo and the CBE donut?
A local shop here in the bay did it. GST motorsports. i cant imagine they didnt use new gaskets.
blackmist27 is offline   Reply With Quote
Old 10-26-2009, 05:54 PM   #6
dlew308
Scooby Newbie
 
Member#: 82747
Join Date: Mar 2005
Location: Los Angeles
Vehicle:
2009 WRX
DGM

Default

take it back to GST?
dlew308 is offline   Reply With Quote
Old 10-26-2009, 06:02 PM   #7
blackmist27
Scooby Newbie
 
Member#: 209169
Join Date: Apr 2009
Default

Quote:
Originally Posted by dlew308 View Post
take it back to GST?
yes i am taking it back today at 5pm for them to diagnose it. hopefully its a simple fix and wont require me taking it to subaru.
blackmist27 is offline   Reply With Quote
Old 10-27-2009, 12:34 PM   #8
blackmist27
Scooby Newbie
 
Member#: 209169
Join Date: Apr 2009
Default

Update:

took the car back to GST. turns out they had to remove the intercooler in order to get to the bolts on the other side of the turbo. after doing that they didnt put it back together properly. basically they left a hose off or not tightened. so, after a few minutes that was fixed and now my car SCREAMS! i love it. thanks guys for your help!
blackmist27 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cobb 09 WRX Stage 2 Results Cobb Tuning Proven Power Bragging 214 04-08-2011 09:58 AM
09 WRX Stage 2 ISSUE!!! blackmist27 Bay Area Impreza Club Forum -- BAIC 3 10-26-2009 12:32 PM
09 WRX Stage 2 plus headers Fine Line Imports Proven Power Bragging 40 09-24-2009 03:30 PM
09 WRX Stage 2, 290 HP on 91 octane! broken4 Proven Power Bragging 107 04-11-2009 07:43 AM
09 WRX Stage 2, 290 HP on 91 octane! broken4 Proven Power Bragging 0 11-23-2008 02:41 PM


All times are GMT -4. The time now is 12:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.