Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2009, 11:59 AM   #1
Stames_wiltz
Scooby Specialist
 
Member#: 143264
Join Date: Mar 2007
Chapter/Region: RMIC
Location: Utah
Vehicle:
2006 WRX TR
Obsidian Black Pearl

Default Injector help

I have one more test I need to do and that is for the injectors. If this doesn't work then I get to ship my entire car back east. Soooo.....

Does anyone have a spare set or not yet installed Top feed injectors I could barrow for a very short amount of time?

Top feed
06+ WRX dark blue 565cc
07+ STi dark blue 565cc
Deatscwerks 650, 750, 850cc

Any help would be greatly appreciated. Thanks RMIC.
* Registered users of the site do not see these ads.
Stames_wiltz is offline   Reply With Quote
Old 11-19-2009, 12:16 PM   #2
medamullet
Scooby Guru
 
Member#: 99442
Join Date: Oct 2005
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2006 SGM STI
I'm on CORN YO!

Default

Talk to lance I think I saw a set of PE's in the shop the other day.
medamullet is offline   Reply With Quote
Old 11-19-2009, 12:22 PM   #3
AWD Ninja
Scooby Specialist
 
Member#: 181980
Join Date: Jun 2008
Chapter/Region: RMIC
Location: HATU
Vehicle:
2006 STi
OBP

Default

No joke, get 1000cc Bosch Dynamics injectors ! And just scale them to the number you need. These are THEE best injectors (imo)
(and sorry I don't know the problem, im assuming is a injector problem)

ohh and if you don't already have one, FPR is a way good idea hope you fix it !
AWD Ninja is offline   Reply With Quote
Old 11-19-2009, 12:27 PM   #4
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

he needs them for testing...not to buy new ones.
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 01:34 PM   #5
r8r4life
Scooby Specialist
 
Member#: 101464
Join Date: Nov 2005
Location: Emplyed again=Sucks
Default

Go to rallysport and get the 1000 cc deatchwerks.Then after you use them I will buy them from you for $150.
r8r4life is offline   Reply With Quote
Old 11-19-2009, 01:36 PM   #6
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

thats a good idea
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 01:40 PM   #7
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

James. I think you should look at the crank angle sensor as well.
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 02:03 PM   #8
r8r4life
Scooby Specialist
 
Member#: 101464
Join Date: Nov 2005
Location: Emplyed again=Sucks
Default

TGV flaps are probably stuck closed.That is why it runs good cold.
r8r4life is offline   Reply With Quote
Old 11-19-2009, 07:18 PM   #9
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

he doesnt have TGVs
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 09:25 PM   #10
Stames_wiltz
Scooby Specialist
 
Member#: 143264
Join Date: Mar 2007
Chapter/Region: RMIC
Location: Utah
Vehicle:
2006 WRX TR
Obsidian Black Pearl

Default

not buying new injectors. Don't have TGV's. I just want my F***ing car fixed
Stames_wiltz is offline   Reply With Quote
Old 11-20-2009, 02:13 AM   #11
DemiSlayer
Scooby Specialist
 
Member#: 120339
Join Date: Jul 2006
Chapter/Region: RMIC
Location: Utah
Vehicle:
02 WRX
Alliance Motor Sports

Default

I have some stock 420cc wrx injectors and 2 sets of side feed injectors if you want to use them. also i might be able to help diagnose the problem you are having. Pm me.
DemiSlayer is offline   Reply With Quote
Old 11-20-2009, 11:20 AM   #12
Stames_wiltz
Scooby Specialist
 
Member#: 143264
Join Date: Mar 2007
Chapter/Region: RMIC
Location: Utah
Vehicle:
2006 WRX TR
Obsidian Black Pearl

Default

Quote:
Originally Posted by DemiSlayer View Post
I have some stock 420cc wrx injectors and 2 sets of side feed injectors if you want to use them. also i might be able to help diagnose the problem you are having. Pm me.
the 420cc are too small. Side feeds won't work because I will have to change fuel rails. As for diagnosing the problem, I am pretty sure as I have been for the past couple months it is the motor. But we all know I have been wrong in the past .

DemiSlayer, do you ever go to Solid Autoworks?
Stames_wiltz is offline   Reply With Quote
Old 11-20-2009, 12:12 PM   #13
Fast_
Scooby Newbie
 
Member#: 159219
Join Date: Sep 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2001 S2000
Black

Default i have some

i have some 07 blue wrx injectors if they will work
Fast_ is offline   Reply With Quote
Old 11-20-2009, 12:15 PM   #14
medamullet
Scooby Guru
 
Member#: 99442
Join Date: Oct 2005
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2006 SGM STI
I'm on CORN YO!

Default

ya, those will work fo rhim for sure. I want to stop by and check it out. It completely puzzles me that Noah can't figure out what is going on with that car.
medamullet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
injector help...please, doing now, help asap drewwrxrogers Factory 2.0L Turbo Powertrain 7 12-10-2006 09:17 AM
Modded injectors - Help me pick which injector to install into which cyl dexterous Factory 2.5L Turbo Powertrain 13 03-21-2006 12:54 PM
injectors ? help! redline29 Normally Aspirated with bolt-on Forced Induction Powertrain 7 11-23-2002 06:34 PM
RC injector help. TaiChih Normally Aspirated with bolt-on Forced Induction Powertrain 17 03-16-2002 08:28 PM
injector help PDG Factory 2.0L Turbo Powertrain 24 02-27-2002 10:03 AM


All times are GMT -4. The time now is 05:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.