Welcome to the North American Subaru Impreza Owners Club Saturday July 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2009, 07:06 PM   #1
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default Maybe I spoke too soon. Car having issues

Well looks like the RS is having issues. Filled up gas yesterday didnt really have any issues to late last night. Here is what I am experiencing:

While accelerating at half throttle the car seems to hesitate, like its having fuel cut. Looks like someone is shaking a baby, except my car is shaking. The only way to avoid this issue is to drive at WOT. Except at WOT it feels like I have a 42r turbo or something. It has less power than it already does up until 5.5k then it goes. Any possible ideas?

Only thing I can think of is bad fuel? Just had spark plugs, fuel filter etc done 3.5k miles ago.

Thanks
* Registered users of the site do not see these ads.
godfather2112 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-19-2009, 07:14 PM   #2
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
15 WRX, 83 DR30,
93 R32 GTS-T, 93 R32 GTR

Default

hahaha ****er!
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 07:16 PM   #3
PCSkiBum_21
Scooby Specialist
 
Member#: 164437
Join Date: Nov 2007
Chapter/Region: RMIC
Location: Park City, UT
Vehicle:
EVO IX - Track Car
BRZ - Daily

Default

Quote:
Originally Posted by bhhamblin View Post
hahaha ****er!
PCSkiBum_21 is offline   Reply With Quote
Old 11-19-2009, 07:21 PM   #4
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

Quote:
Originally Posted by bhhamblin View Post
hahaha ****er!
To bad I can find a motor for 500 when your short block will cost you 5k plus.

Haha ****er
godfather2112 is offline   Reply With Quote
Old 11-19-2009, 07:27 PM   #5
snowman4us
Scooby Specialist
 
Member#: 21764
Join Date: Jul 2002
Chapter/Region: RMIC
Location: Salty Lake
Vehicle:
Some GDM V8,
JDM Flat 4 X2

Default

Head gasket?
CEL?
Loosing fluids?
Or maybe open your hood and realize that your intake is not hooked up. Sounds like a vacuum leak, is it idling normal?

Or might be the fact that you should stop beating the hell out of that poor car.
snowman4us is offline   Reply With Quote
Old 11-19-2009, 07:32 PM   #6
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

I drive that car pretty normal. its not like you get any gratification from driving it hard. Still a slow POS. Cars fluids are full, no CEL.


Maybe I can do operation 2.5 rs again. kiki i'm pretty sure you know what im talking about
godfather2112 is offline   Reply With Quote
Old 11-19-2009, 07:46 PM   #7
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
15 WRX, 83 DR30,
93 R32 GTS-T, 93 R32 GTR

Default

Quote:
Originally Posted by godfather2112 View Post
To bad I can find a motor for 500 when your short block will cost you 5k plus.

Haha ****er
shortblock i can get for 1900....install isnt another 3k.

and its under warranty. eat **** dan.
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 07:50 PM   #8
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

Um you told me they replaced you short block last time under warranty but voided any engine related issues due to having it modded.


Eat **** brody
godfather2112 is offline   Reply With Quote
Old 11-19-2009, 08:11 PM   #9
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
15 WRX, 83 DR30,
93 R32 GTS-T, 93 R32 GTR

Default

no. they only replaced a piston the first time...they didnt void my warranty.

eat **** dan
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 08:21 PM   #10
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

Hey Brody, lick lick lick on my balls. From the taint forward.
godfather2112 is offline   Reply With Quote
Old 11-19-2009, 08:23 PM   #11
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
15 WRX, 83 DR30,
93 R32 GTS-T, 93 R32 GTR

Default

pay me
bhhamblin is offline   Reply With Quote
Old 11-19-2009, 08:28 PM   #12
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

last time was free. And it wasnt that good.
godfather2112 is offline   Reply With Quote
Old 11-19-2009, 09:17 PM   #13
SXti
Scooby Newbie
 
Member#: 73692
Join Date: Nov 2004
Location: Salt Lake City
Vehicle:
2011 Forester XT
Spark Silver

Default

plugs? experienced something similar with the gf's outback
SXti is offline   Reply With Quote
Old 11-19-2009, 09:54 PM   #14
fourmicah
Scooby Specialist
 
Member#: 128760
Join Date: Oct 2006
Chapter/Region: RMIC
Location: Over there>
Vehicle:
2015 STI
Silver

Default

You've ruled out alot already, the only thing I can think of is a boost leak.
fourmicah is online now   Reply With Quote
Old 11-19-2009, 09:56 PM   #15
Kastley85891
Scooby Specialist
 
Member#: 127704
Join Date: Oct 2006
Chapter/Region: TXIC
Location: TX/Austin
Vehicle:
2015 Focus ST
PB on E30

Default

MAF ? , leak?
Kastley85891 is offline   Reply With Quote
Old 11-19-2009, 11:40 PM   #16
car_cursed
Scooby Guru
 
Member#: 85327
Join Date: Apr 2005
Chapter/Region: RMIC
Location: West Jordan, UT
Vehicle:
More projects than
you can shake a stick at.

Default

Quote:
Originally Posted by fourmicah View Post
You've ruled out alot already, the only thing I can think of is a boost leak.
not likely, he already runs 0 lbs
car_cursed is online now   Reply With Quote
Old 11-20-2009, 12:16 AM   #17
fastbluewrx07
Scooby Specialist
 
Member#: 143703
Join Date: Mar 2007
Chapter/Region: RMIC
Location: SL,UT
Default

fastbluewrx07 is offline   Reply With Quote
Old 11-20-2009, 12:31 AM   #18
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

What year is it?
bigjoshsubyfan is offline   Reply With Quote
Old 11-20-2009, 12:32 AM   #19
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

01 rs stock.
godfather2112 is offline   Reply With Quote
Old 11-20-2009, 12:45 AM   #20
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

Does it do it consistantly or just when cold or hot? Have you checked the EGR, and vaccum lines?
bigjoshsubyfan is offline   Reply With Quote
Old 11-20-2009, 12:53 AM   #21
godfather2112
Papi Chulo
Moderator
 
Member#: 53794
Join Date: Jan 2004
Chapter/Region: SCIC
Location: Katy Perry's Closet
Vehicle:
.... OT Supplement
Testing Division.

Default

All the time. Cold and at temp. Checked around briefly and everything looked in tact. Ill be taking it to solid tomorrow. Paul over there promised me a handy a while back, need to collect on that offer.
godfather2112 is offline   Reply With Quote
Old 11-20-2009, 01:16 AM   #22
bigjoshsubyfan
Scooby Newbie
 
Member#: 193332
Join Date: Nov 2008
Default

Lol good luck. Sorry i'm not much help all my issues have been with my 98. So most of what I can think of isn't even relevant.
bigjoshsubyfan is offline   Reply With Quote
Old 11-20-2009, 01:30 AM   #23
jetfan2207
Scooby Specialist
 
Member#: 61950
Join Date: May 2004
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2008 Outback
big blue wagon

Default

I'm gonna go with bad fuel as well.
jetfan2207 is offline   Reply With Quote
Old 11-20-2009, 01:41 AM   #24
azn2nr
Scooby Specialist
 
Member#: 35276
Join Date: Apr 2003
Chapter/Region: RMIC
Location: Salt Lake City, UT
Default

im goin with bad o2 sensor
azn2nr is offline   Reply With Quote
Old 11-20-2009, 02:15 AM   #25
DemiSlayer
Scooby Specialist
 
Member#: 120339
Join Date: Jul 2006
Chapter/Region: RMIC
Location: Utah
Vehicle:
02 WRX
Alliance Motor Sports

Default

If you need any help still with this i can help you diagnose it. Pm me
DemiSlayer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UK STi's have issues too! Blue Dragoon Warranty Issues & SOA Problems 0 03-25-2009 08:51 AM
How soon is too soon for new car mods - or does that matter? magillaTheGorilla Newbies & FAQs 20 02-26-2004 05:32 PM
my car is dying too soon... WS6toWRX General Community 6 12-23-2002 06:26 AM
I spoke too soon..... first gear is clicking.... GregUnd Texas Impreza Club Forum -- TXIC 19 11-13-2002 07:32 PM


All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.