Welcome to the North American Subaru Impreza Owners Club Wednesday May 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-01-2009, 09:57 PM   #1
qtr_wrx
Scooby Specialist
 
Member#: 109567
Join Date: Mar 2006
Location: Qatar
Question Got my turbo kit, need help with voltage clamp :(

Hey guys, I need help on how to wire the voltage clamp on my car? I got Ludespeed Kit and going to install it next week
also I was woundering if it's possible to run my car without the voltage clamp thing (like having a 3 bar map sensor) because I don't like the idea of cutting off wires and stuff

I plan to run 6 psi for 2010, then I will get my 550cc injectors and sti pistons/rods and shot for 15 psi

my car is 03 impreza rs
* Registered users of the site do not see these ads.
qtr_wrx is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-05-2009, 06:57 PM   #2
qtr_wrx
Scooby Specialist
 
Member#: 109567
Join Date: Mar 2006
Location: Qatar
Default

guys, I've searched every where for a clue! please help me on this issue? I need to turbo my car
qtr_wrx is offline   Reply With Quote
Old 12-06-2009, 04:11 AM   #4
qtr_wrx
Scooby Specialist
 
Member#: 109567
Join Date: Mar 2006
Location: Qatar
Default

thanks man
I'll email him
qtr_wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got my 2004 STI , need help with audio wrxited Car Audio, Video & Security 13 09-15-2004 07:14 PM
Got a Body Kit Need Help!! milla Tri-State Area Forum 17 11-12-2003 01:33 PM
Got my kit - Need help with injectors!! *PLEASE* trilap5e Normally Aspirated with bolt-on Forced Induction Powertrain 3 08-30-2003 01:06 PM
Need help removing Voltage Clamp boysetsfire Southern California Impreza Club Forum -- SCIC 2 07-24-2003 06:01 PM
I finally got my turbo kit! david2z4 North West Impreza Club Forum -- NWIC 15 06-26-2001 01:18 PM

All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.