Welcome to the North American Subaru Impreza Owners Club Monday July 25, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-19-2002, 02:28 AM   #1
brokeawd
Scooby Newbie
 
Member#: 15796
Join Date: Feb 2002
Location: East A-Town
Vehicle:
2003 Cobra [email protected]
09 Titan Crew Cab LE

Default Vids from KOOL KRUZz!!

Just got done cuttin and uploading. Everything is on there, winslow, whitewrx, kapafool etc.


www.brokezr.8k.com/images/movies/
* Registered users of the site do not see these ads.
brokeawd is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-19-2002, 02:33 AM   #2
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

nice vids....what did the yellow rex run...didn't show the time in the vid?
SQUAD_907 is offline   Reply With Quote
Old 05-19-2002, 02:59 AM   #3
RawCode
Scooby Specialist
 
Member#: 3115
Join Date: Dec 2000
Chapter/Region: AKIC
Location: Anchorage,AK USA
Vehicle:
2002 Impreza 2.5RS
Silver

Default

14.3 Winslow? Geezzz.... I thought you had turbo! Like my car could do that much better.

RawCode
RawCode is offline   Reply With Quote
Old 05-19-2002, 04:47 AM   #4
aZiator
Scooby Newbie
 
Member#: 10040
Join Date: Sep 2001
Location: Savannah GA
Vehicle:
2002 WRX Wagon
Sedona Red Pearl

Default

Why dont they run 2 at a time there? that is dumb.
Is it that way all the time or just for us imports?? the whole point of running at the track instead of the street is a safe place to run heads up. I'm confused.
aZiator is offline   Reply With Quote
Old 05-19-2002, 04:58 AM   #5
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

Quote:
Originally posted by aZiator
Why dont they run 2 at a time there? that is dumb.
Is it that way all the time or just for us imports?? the whole point of running at the track instead of the street is a safe place to run heads up. I'm confused.
it was a special type event...usually they run 2 at a time...
SQUAD_907 is offline   Reply With Quote
Old 05-19-2002, 06:47 AM   #6
Bob
Scooby Newbie
 
Member#: 16719
Join Date: Mar 2002
Location: Anchorage, Alaska
Vehicle:
1993 RX-7

Default

Quote:
Originally posted by RawCode
14.3 Winslow? Geezzz.... I thought you had turbo! Like my car could do that much better.

RawCode
He wasn't double-clutching yO!
Bob is offline   Reply With Quote
Old 05-19-2002, 08:17 AM   #7
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Kris ran a 14.4. I can't remember the details but he'll post.

Yup, I ran an embarrassing 14.3. Hell no, What's double clutching? I couldn't have asked for a worse run. I was running with some stock car advice which hurt my modded car times. A stock WRX can run out third to the quarter. I thought I had enough RPMs left to make it to the quarter but I thought wrong and hit the rev limiter. The big bog launch didn't help either.

Winslow
WRXnFX is offline   Reply With Quote
Old 05-19-2002, 01:17 PM   #8
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

Quote:
Originally posted by WRXnFX1974
Kris ran a 14.4. I can't remember the details but he'll post.

Yup, I ran an embarrassing 14.3. Hell no, What's double clutching? I couldn't have asked for a worse run. I was running with some stock car advice which hurt my modded car times. A stock WRX can run out third to the quarter. I thought I had enough RPMs left to make it to the quarter but I thought wrong and hit the rev limiter. The big bog launch didn't help either.

Winslow
oops! my bad!
SQUAD_907 is offline   Reply With Quote
Old 05-19-2002, 09:01 PM   #9
RallyX13
Scooby Specialist
 
Member#: 1543
Join Date: May 2000
Chapter/Region: AKIC
Location: Greensboro, NC USA
Vehicle:
2007 Jetta GLI
Yellow

Default

Here is the info on my run, first time getting a good launch in the WRX, so it was not too bad I guess:

60ft- 2.062
1/4 ET - 14.473
1/4 MPH - 92.02

Hopefully that will improve the next time I run, but if I had my other wing I would have ran at least 13's.

Kris

Last edited by RallyX13; 05-20-2002 at 01:20 AM.
RallyX13 is offline   Reply With Quote
Old 05-19-2002, 09:05 PM   #10
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

Quote:
Originally posted by RallyX13
Here is the info on my run, first time getting a good launch in the WRX, so it was not too bad I guess:

60ft- 2.062
1/4 ET - 14.1473
1/4 MPH - 92.02

Hopefully that will improve the next time I run, but if I had my other wing I would have ran at least 13's.

Kris
wow a 14.1? i thought u ran a 14.4? that's pretty good considering the 60' time was high and trap speed was low...
SQUAD_907 is offline   Reply With Quote
Old 05-20-2002, 01:21 AM   #11
RallyX13
Scooby Specialist
 
Member#: 1543
Join Date: May 2000
Chapter/Region: AKIC
Location: Greensboro, NC USA
Vehicle:
2007 Jetta GLI
Yellow

Default

ooppps.....my bad, I have corrected it. Damn typos, but it was a good typo as far as typos go.

Kris
RallyX13 is offline   Reply With Quote
Old 05-20-2002, 01:23 AM   #12
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Thumbs up

i saw the videos, they were pretty good. Kris' car sounds really nice, so does winslows, i didn't really hear erics car though
AK_2002_WRX is offline   Reply With Quote
Old 05-20-2002, 01:32 AM   #13
RallyX13
Scooby Specialist
 
Member#: 1543
Join Date: May 2000
Chapter/Region: AKIC
Location: Greensboro, NC USA
Vehicle:
2007 Jetta GLI
Yellow

Default

Allen,

Thanks for taking the video since my camera-man must have pressed the worng button or something.

Kris
RallyX13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kOoL kRuZz DrAgS R-RATED Alaskan Impreza Club Forum -- AKIC 15 05-20-2002 04:50 AM
Vids from this weekend (not ready yet) Will Rocky Mountains Impreza Club Forum -- RMIC 1 05-29-2001 03:41 PM
Autox Vids from Yesterday (April 1, 2001) Will Rocky Mountains Impreza Club Forum -- RMIC 8 04-02-2001 05:49 PM
Pictures & Vids from this morning in NH. webkris New England Impreza Club Forum -- NESIC 6 01-01-2001 12:59 AM
Impreza vs Lancer vid from Legend of Speed KavMan General Forum Archive 46 01-01-2001 12:03 AM

All times are GMT -4. The time now is 08:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.