Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-15-2009, 12:45 AM   #1
Stylz916
Scooby Newbie
 
Member#: 163695
Join Date: Nov 2007
Default CEL troubles codes thrown, need help plz

Hey Subi Fam, I've encountered my first issue after 3yrs of owning my '04 Sti. Today I was driving to work when I noticed a slight "sputtering", barely noticable. Then when I got on the freeway in 5th gear, i stepped on it to pass a car when all of a sudden it bogged down for a second. After that my rpms came back up but then my engine light came on along with a flashing cruise control light. So I took it easy driving to work and home. When I got home this evening, I pulled out the accessport to get the trouble codes. They are as follows, P0301, P0302, P0303, P0304 (cylinder misfires), and P0244 (Turbo wastegate selenoid "A" range/performance). I dont have many mods on my car, just a aem cai, exedy stg. 2 clutch, prodrive downpipe, turboXS tbe, and ap stage 2 map. Can somebody help me please as to what might be causing this. Thanks for any help that can be provided.
* Registered users of the site do not see these ads.
Stylz916 is offline   Reply With Quote
Old 12-15-2009, 03:41 AM   #2
elevenpoint7five
Scooby Specialist
 
Member#: 187798
Join Date: Aug 2008
Chapter/Region: MWSOC
Location: Elk Grove Village IL
Vehicle:
04 2 liters of
AWESOME!

Default

It sounds like you over boosted, could be the cold weather and you should consult your tuner. My take on CEL's is that if they pop up once and go away, ignore them until they come back again, most times with misfires, they dont. If it does, it's something worth looking into. Check your coil packs to make sure the connections are REALLY good. Also, check your plugs for any sign of being fouled and for proper gap.

Andy
elevenpoint7five is offline   Reply With Quote
Old 02-21-2010, 08:47 AM   #3
jmb8806wrx2006
Scooby Newbie
 
Member#: 238946
Join Date: Feb 2010
Default

over boosted
jmb8806wrx2006 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pulled my CEL codes.(now need help/advice) blackout801 Rocky Mountains Impreza Club Forum -- RMIC 23 06-11-2009 03:53 AM
pulled my CEL codes.(now need help/advice) blackout801 Factory 2.5L Turbo Powertrain 0 06-05-2009 08:14 PM
CEL code pulled, need help Ryan314 Factory 2.0L Turbo Powertrain 8 02-09-2007 08:04 PM
CEL Fault code 546 Please help Unreal Graphix Factory 2.0L Turbo Powertrain 8 08-06-2006 04:42 PM
WRX struts needed... help plz? LttLDGN Brakes, Steering & Suspension 5 10-30-2001 02:44 PM


All times are GMT -4. The time now is 05:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.