Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-03-2010, 01:37 PM   #1
DreamEvil
Scooby Specialist
 
Member#: 186435
Join Date: Aug 2008
Chapter/Region: Tri-State
Vehicle:
2002 Impreza WRX
Silver

Default Injector issue

So I am not sure if this is the right section for this or not...but my car in the past had injector issues, where you would smell fuel and visibly see it leaking from the injectors.

Last night as I got out of my car I smelt fuel, but when I popped the hood and searched all the injectors I saw no leak what so ever, I sniffed over each one and the one has the potent smell over it and you only really catch a smell here and there.

I called a buddy of mine who is very knowledgeable with Subaru's,he has a 02 himself,he said that subaru actually had a recall for mostly 02's and some 0'3s. Which basically said that during the winter time something in the fuel lines would get real cold and shrink causing some fuel to leak out but it wasn't enough of a leak that you could actually see it...He said I basically have two options 1. Go to subaru and see if they will replace it, or 2. just wait till it gets warmer out and it will fix its self, so basically from what he said his car does it too and he doesn't think it is a serious issue.

So I was just wondering if any one else has heard of this as well? and if you believe this to be the problem?

Thoughts and opinions appreciated!
* Registered users of the site do not see these ads.
DreamEvil is online now   Reply With Quote
Old 01-03-2010, 02:59 PM   #2
van_dutch
Scooby Specialist
 
Member#: 198633
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MA
Vehicle:
2004 WRX
Black

Default

van_dutch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible Tranny issue, grinding with no load battlewaggin Transmission (AT/MT) & Driveline 3 06-06-2010 01:02 AM
Modified Blue Injectors - Issue BlackEyeBugEye Open Source Reflashes 17 07-30-2008 10:37 PM
02 wrx hesitation/ poss fueling/injector issue? 95lwrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 04-19-2008 08:56 PM
Injector issues. Adictwrx Mid Atlantic Impreza Club -- MAIC 4 03-05-2008 08:51 PM
Sti Injector issue please help WRC WRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 03-01-2003 12:45 PM


All times are GMT -4. The time now is 07:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.