Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-08-2010, 07:07 PM   #1
drifte
Scooby Newbie
 
Member#: 209749
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
04 XT
Silver

Question 04 fxt idle/acceleration, also cruise

New to Subarus here but I've been in the DSM game for a good 10 years. Heres a few questions I have for my recently acquired forester.
1. Idle, stumbles a bit (i know its a boxer)
2. acceleration is jumpy as if its having trouble getting into boost (tune issue?)

3. Today my cruise light started flashing and cruise no longer worked...wtf?

Now I have already read about idle issues with those filters in the banjo bolts, went to remove them and someone already had. The SPT intake didnt change anything I went back and forth from stock to it and no changes. I have also read the 04's have an issue going from open loop to close loop, so am I to assume when getting into boost its struggling because of the factory tune? Is their any factory re-maps I could just go to the dealer and get a quick flash/update?

Only thing I have to to replace is the spark plugs, and Im just still researching to see what way is best to go and get a part #. It also doesnt look fun to replace them.

Any help is appreciated.

Thanks,
Colton
* Registered users of the site do not see these ads.
drifte is offline   Reply With Quote
Old 01-08-2010, 08:17 PM   #2
antigfk
Scooby Newbie
 
Member#: 122242
Join Date: Aug 2006
Location: Down the Bayou
Vehicle:
2006 WRX LTD
Aspen White

Default

Read the FAQ's, and go get a tune of some kind. Just a off the shelf Cobb tune made my car run 10 times smoother. A protune made it even better.

Not sure about your cruise control issue.
antigfk is offline   Reply With Quote
Old 01-08-2010, 09:49 PM   #3
theotherguy
Scooby Specialist
 
Member#: 191514
Join Date: Oct 2008
Chapter/Region: NWIC
Location: teh bremerton
Vehicle:
'05 FXT 6spd, 98
Fozzy lifted,'01 RS 6spd

Default

Did your check engine light come on with the flashing cruise? Sounds like you threw a code, which might explain a lot of your other issues.
theotherguy is offline   Reply With Quote
Old 01-08-2010, 11:26 PM   #4
drifte
Scooby Newbie
 
Member#: 209749
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
04 XT
Silver

Default

No codes or CEL and only code found in the history was for abs relay. I read the faq's but I dont want to spend much money on getting a baseline tune when the car is basically stock. A friend of mine has the Cobb tuning device, but it seems it just pre determines what it thinks is the best map you can't actually adjust it, but it costs something like $500?

I'll continue reading and see what I can find. I may go ahead and get another AEM UEGO for this car and then I can atleast see whats going on.

I am getting more interested in the tactrix cable and maybe running ecuflash.

thanks
Colton
drifte is offline   Reply With Quote
Old 01-09-2010, 12:16 AM   #5
theotherguy
Scooby Specialist
 
Member#: 191514
Join Date: Oct 2008
Chapter/Region: NWIC
Location: teh bremerton
Vehicle:
'05 FXT 6spd, 98
Fozzy lifted,'01 RS 6spd

Default

Did the cruise light go out after you turned the car off and restarted it?

Cruise control indicator light

The cruise control indicator light illuminates when the ignition switch is turned to the “ON” position and turns off after approximately 3 seconds. This light illuminates when the “CRUISE” main switch is pressed.

If you press the main switch button while turning the ignition switch “ON”, the cruise control function is deactivated and the “CRUISE” indicator light flashes. To reactivate the cruise control function, turn the ignition switch back to the “Acc” or “LOCK” position, and then turn it again to the “ON” position.

If it did go out after restart then you may have deactivated the cruise and reactivated it. If not, its going to to be tough to narrow it down with no codes.
theotherguy is offline   Reply With Quote
Old 01-09-2010, 03:02 PM   #6
drifte
Scooby Newbie
 
Member#: 209749
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
04 XT
Silver

Default

Thats weird I'll give the full story from using cruise to cruise flashing.

Cruise set at 70mph I touched the brakes preparing for an off ramp cruise stops. I accelerate around the clover leaf on ramp (snowy, icy FUN) i spin through 3rd and hold it steady and shift to 4th, then 5th. About when I shifted to 4th I noticed a flash, looked back down and cruise was flashing. When I came to my next off ramp roughly 3 miles down i shut the car off and turned it back on and cruise light quit flashing. Haven't tested since to see if it works.

on another note, Utec seems like a great option but even at my cost it sure isn't cheap.
drifte is offline   Reply With Quote
Old 01-09-2010, 03:55 PM   #7
theotherguy
Scooby Specialist
 
Member#: 191514
Join Date: Oct 2008
Chapter/Region: NWIC
Location: teh bremerton
Vehicle:
'05 FXT 6spd, 98
Fozzy lifted,'01 RS 6spd

Default

Sounds like it reset itself.

I run ecuflash via a tactrix cable on my Forester and WRX. If you can borrow one, it is extremely inexpensive to get a good tune from one of the many e-tuners out there. An e-tune is a custom tune for your car by sending logs from romraider thru email. I've used a tuner from SoCal and had great service.
theotherguy is offline   Reply With Quote
Old 01-13-2010, 10:57 PM   #8
drifte
Scooby Newbie
 
Member#: 209749
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
04 XT
Silver

Default

This will sound strange and although myself, my boss and my friends shop are all capable of a tune; how do you determine who will tune for you online? Is their a list of qualified tuners somewhere?...
drifte is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 STI doorcards & also 04 WRX doorcards KB'izzle SCIC Private Classifieds 3 08-25-2009 01:26 PM
Need help...rough idle...acceleration stumbling..... zzzzzzzz Legacy Forum 39 08-19-2007 10:36 AM
idle/acceleration problem rotarypower8 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 2 07-12-2005 12:33 AM
Google Web Accelerator also an anonymizer? RR Off-Topic 17 05-06-2005 01:23 PM
Irratic FXT idle wadejg Forester Forum 8 03-17-2004 10:23 AM


All times are GMT -4. The time now is 02:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.