Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-24-2002, 03:33 PM   #1
brokeawd
Scooby Newbie
 
Member#: 15796
Join Date: Feb 2002
Location: East A-Town
Vehicle:
2003 Cobra 10.40@135
09 Titan Crew Cab LE

Default New motor Pic

Got done building the next candidate to break in my car. This motor I am going to attempt 25-28psi if all goes good. Im waiting on some parts i.e flywheel and clutch and the motor will go in sometime today in my drive, and with any luck be on the road sometime mid next week.

* Registered users of the site do not see these ads.
brokeawd is offline   Reply With Quote
Old 05-24-2002, 03:36 PM   #2
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Where are you doing this work?

Winslow
WRXnFX is offline   Reply With Quote
Old 05-24-2002, 03:38 PM   #3
brokeawd
Scooby Newbie
 
Member#: 15796
Join Date: Feb 2002
Location: East A-Town
Vehicle:
2003 Cobra 10.40@135
09 Titan Crew Cab LE

Default

At my house, built the motor in the garage and the car is setting out front. I have engine hoist e, air compressor etc.
brokeawd is offline   Reply With Quote
Old 05-24-2002, 03:41 PM   #4
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

I need to buy an air compressor. Need more tools! If you need help, I'm available.

Winslow
WRXnFX is offline   Reply With Quote
Old 05-24-2002, 03:47 PM   #5
00CamaroSS
Scooby Newbie
 
Member#: 16279
Join Date: Mar 2002
Location: Audi RS4, Broke A$$ SS
Default

Sweet! Can't wait to see the thing run with the FMIC.

Scott
00CamaroSS is offline   Reply With Quote
Old 05-24-2002, 04:30 PM   #6
brokeawd
Scooby Newbie
 
Member#: 15796
Join Date: Feb 2002
Location: East A-Town
Vehicle:
2003 Cobra 10.40@135
09 Titan Crew Cab LE

Default

Scott: I just want it to run, could care if its fast right now. But if its fast in the process that'll make me happy hahhha
brokeawd is offline   Reply With Quote
Old 05-24-2002, 06:08 PM   #7
psylas
Scooby Specialist
 
Member#: 19109
Join Date: May 2002
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2010 Toyota Tundra
Silver

Default

thats pretty sick man nice work
psylas is offline   Reply With Quote
Old 05-24-2002, 06:44 PM   #8
BlackNight
Scooby Newbie
 
Member#: 16285
Join Date: Mar 2002
Location: Anchorage, Alaska
Vehicle:
2004 VW .:R32
Tornado Red

Default

oh ya TOYS
BlackNight is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
new motor...safe to use old tune for motor break in???tuner advice needed!! JT's06sti AccessPort 2 02-21-2009 06:15 PM
Do I need new motor mounts? Pics inside NavyBlueSubaru Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 03-20-2006 06:58 PM
New Motor Pics / Video Biaxin Member's Car Gallery 57 04-27-2005 08:41 PM
Help! Brother has blown 1997 Legacy Outback motor - help me find a new motor? CirrusWRX Tri-State Area Forum 8 11-20-2004 09:48 PM
New pics of my car: Advans, Carbon Trunk, New motor, UK Spec seats, HKS, Defi, STI adamsrs Member's Car Gallery 122 07-03-2002 11:19 AM


All times are GMT -4. The time now is 07:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.