Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-03-2010, 04:19 PM   #1
scoobynoobEMT
Scooby Specialist
 
Member#: 199206
Join Date: Jan 2009
Chapter/Region: South East
Location: Ft Stewart, GA
Vehicle:
2002 WRX wagon EJ257
PSM

Default cruise control lights dont turn on.

In my 2002 WRX, the cruise control lights, (the one in the cluster, and the orange one on the button) don't work.

Setting the cruise control, while driving, I hit the button and it turns orange.

I hit the set lever, cruise control initiates, however, the button doesn't turn green and the lights in the gauge cluster don't turn on..

Does anyone have any ideas on what the problem could be?
* Registered users of the site do not see these ads.
scoobynoobEMT is offline   Reply With Quote
Old 02-04-2010, 02:36 AM   #2
ProdriveDreams
Scooby Specialist
 
Member#: 146819
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Boston / Ipswich, MA
Vehicle:
'02 WRB VF-39'd WRX
W/06 STi Drivetrain swap

Default

far as i know... they don't do any of these things. It's just on when it's on, and the light on the switch is just on when the system is armed and that's it.
ProdriveDreams is offline   Reply With Quote
Old 02-04-2010, 09:21 AM   #3
scoobynoobEMT
Scooby Specialist
 
Member#: 199206
Join Date: Jan 2009
Chapter/Region: South East
Location: Ft Stewart, GA
Vehicle:
2002 WRX wagon EJ257
PSM

Default

That's what I'm asking.. When I'm USING my cruise control the button doesn't turn green, and the light on my gauge cluster doesn't turn on.

Trying to figure out why.
scoobynoobEMT is offline   Reply With Quote
Old 02-04-2010, 10:12 AM   #4
ProdriveDreams
Scooby Specialist
 
Member#: 146819
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Boston / Ipswich, MA
Vehicle:
'02 WRB VF-39'd WRX
W/06 STi Drivetrain swap

Default

no that's my point. the button doesn't change and there is no light on the cluster.

Just looked at the service manual and there is no such light on the cluster, and if you've ever opened up the switch you know that there is only two lights: the switch illumination light, and the indicator light.
ProdriveDreams is offline   Reply With Quote
Old 02-04-2010, 10:58 AM   #5
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Check the switch adjustments on the brake and clutch pedals for the CC system. They are a common trouble source for CC problems.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
Reverse lights dont turn on MJBrowny21 Transmission (AT/MT) & Driveline 6 03-22-2010 05:25 PM
HELP! Check Engine light on & Cruise Control Light Blinking STiURBO Southern California Impreza Club Forum -- SCIC 21 03-15-2007 01:54 AM
Reverse Lights Dont Turn On - Help michyous Legacy Forum 5 04-16-2005 10:54 PM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain 6 01-23-2005 02:04 PM


All times are GMT -4. The time now is 07:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.