Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-15-2002, 05:22 PM   #1
BlazingRS
Scooby Newbie
 
Member#: 16443
Join Date: Mar 2002
Location: SF bay area
Vehicle:
01 2.5 RS
blue ridge pearl

Question whats up with this CE light

The time has come to do something about that darn "check engine" light!
After just recently doing the 15k service, I had the CE light reset. Only 200 mi later it came back on again. I know for a fact that the cause is the ganzflow intake. Basically I just want the light OFF! Is there a plug that I can pull or something?

*I know this was surely posted before, however, as you know the search is down
* Registered users of the site do not see these ads.
BlazingRS is offline   Reply With Quote
Old 05-15-2002, 05:34 PM   #2
KillerTHC
Scooby Specialist
 
Member#: 4942
Join Date: Mar 2001
Chapter/Region: BAIC
Location: Palo Alto, CA USA
Vehicle:
01 SRP 2.5 RS-T
Ludespeed Stage 3 Link'd

Default

umm... the ganz won't throw a CEL... there is a plug but i don't know what it is since the search is down
KillerTHC is offline   Reply With Quote
Old 05-15-2002, 07:31 PM   #3
aigburth
Scooby Newbie
 
Member#: 8619
Join Date: Jul 2001
Location: Jamlando
Vehicle:
1996 RHD GC '96
http://spookyempire.com

Default

Cycle your key 3 times,this will get the light to go off,but the code will still be stored.
Alan
aigburth is offline   Reply With Quote
Old 05-15-2002, 07:47 PM   #4
akcel
Scooby Specialist
 
Member#: 10268
Join Date: Sep 2001
Chapter/Region: SCIC
Location: San Diego
Vehicle:
gc8 I ride ride 24s
with the top down low.

Default

cycle the key 3 times? what the?
akcel is offline   Reply With Quote
Old 05-15-2002, 07:56 PM   #5
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default

Quote:
Originally posted by akcel
cycle the key 3 times? what the?
I think thats when you turn the key but don't crank the engine.
obyone is offline   Reply With Quote
Old 05-15-2002, 08:09 PM   #6
akcel
Scooby Specialist
 
Member#: 10268
Join Date: Sep 2001
Chapter/Region: SCIC
Location: San Diego
Vehicle:
gc8 I ride ride 24s
with the top down low.

Default

and this turns the cel off? i've NEVER heard of that...i've heard of resetting the ecu to get it off but hmmm
akcel is offline   Reply With Quote
Old 05-15-2002, 08:13 PM   #7
aigburth
Scooby Newbie
 
Member#: 8619
Join Date: Jul 2001
Location: Jamlando
Vehicle:
1996 RHD GC '96
http://spookyempire.com

Default

Trust me try it,turn your key to power on 3 times in a row.
Alan
aigburth is offline   Reply With Quote
Old 05-16-2002, 12:06 AM   #8
BlazingRS
Scooby Newbie
 
Member#: 16443
Join Date: Mar 2002
Location: SF bay area
Vehicle:
01 2.5 RS
blue ridge pearl

Default

I just got back from trying the key trick , but no luck! Is there something I did wrong? Another solution perhaps.... gosh, that darn light
BlazingRS is offline   Reply With Quote
Old 05-16-2002, 02:54 AM   #9
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by BlazingRS
I just got back from trying the key trick , but no luck! Is there something I did wrong? Another solution perhaps.... gosh, that darn light
FWIW it's NOT 3 key cycles...it is 3 DRIVE cycles to get the light to go off. and it's not from your ganzflow.

what the hell code are you throwing??

jeremy
HndaTch627 is offline   Reply With Quote
Old 05-16-2002, 02:57 AM   #10
Andrew
Scooby Specialist
 
Member#: 1170
Join Date: Mar 2000
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2005 STi
White

Default

the hell is a drive cycle
Andrew is offline   Reply With Quote
Old 05-16-2002, 04:55 AM   #11
akcel
Scooby Specialist
 
Member#: 10268
Join Date: Sep 2001
Chapter/Region: SCIC
Location: San Diego
Vehicle:
gc8 I ride ride 24s
with the top down low.

Default

umm i've driven my car more than 3 times...and i still have a cel
akcel is offline   Reply With Quote
Old 05-16-2002, 10:50 AM   #12
Ethan
NASIOC Supporter
 
Member#: 246
Join Date: Sep 1999
Default

well why don't you put the stock airbox on and take it to the dealer. Sounds like you only have about 15,200 miles on it so its still covered under warrenty.
Ethan is online now   Reply With Quote
Old 05-16-2002, 11:14 AM   #13
RallyNavvie
Scooby Specialist
 
Member#: 7113
Join Date: Jun 2001
Chapter/Region: TXIC
Location: Minnesotan in Texas
Vehicle:
2008 Spec B
DGM

Default

Is this an AFI question? If it is (and it should be to be posted in here) than take apart the dash and unplug the bulb for the light. Mine has been disconnected for as long as I can remember. I, for one, am getting sick of AFI people complaining about CELs. You're obviously going to throw codes on an AFI system unless you got lucky somehow. If you don't want to just unplug the bulb then get a new ECU.

I swear, 5% of the posts in here are regarding CELs

~Garrett
RallyNavvie is offline   Reply With Quote
Old 05-16-2002, 12:50 PM   #14
Aphex
Scooby Specialist
 
Member#: 146
Join Date: Aug 1999
Location: Wahcheeta, KS
Vehicle:
'05 Legacy GT
Silver

Default

heh heh, the worst is WRX guys, they think that every mod they do to their car should not throw a CEL light, if it does nobody else will buy the product and something must seriously be wrong, ha ha ha ha.

but this seems like an N/A question to me, since he's got the ganzflow intake.
Aphex is offline   Reply With Quote
Old 05-16-2002, 01:35 PM   #15
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

a DRIVE cycle is not just driving the car, it's starting the car and driving where all 6 monitors run and pass, no one knows how long it takes to complete a drive cycle and what the necessary parameters are except the manufacturer.

Jeremy
HndaTch627 is offline   Reply With Quote
Old 05-16-2002, 04:12 PM   #16
akcel
Scooby Specialist
 
Member#: 10268
Join Date: Sep 2001
Chapter/Region: SCIC
Location: San Diego
Vehicle:
gc8 I ride ride 24s
with the top down low.

Default

Quote:
Originally posted by HndaTch627
a DRIVE cycle is not just driving the car, it's starting the car and driving where all 6 monitors run and pass, no one knows how long it takes to complete a drive cycle and what the necessary parameters are except the manufacturer.

Jeremy
weak :P

-akcel
akcel is offline   Reply With Quote
Old 05-22-2002, 09:39 PM   #17
BlazingRS
Scooby Newbie
 
Member#: 16443
Join Date: Mar 2002
Location: SF bay area
Vehicle:
01 2.5 RS
blue ridge pearl

Default

Ok people, could anyone possibly explain then what exactly is a drive cycle so I can do this? I really want to get this light off badly! Still, other options are welcome.... thanks
BlazingRS is offline   Reply With Quote
Old 05-23-2002, 12:51 AM   #18
RallyNavvie
Scooby Specialist
 
Member#: 7113
Join Date: Jun 2001
Chapter/Region: TXIC
Location: Minnesotan in Texas
Vehicle:
2008 Spec B
DGM

Default

What mods are on the car?

~G
RallyNavvie is offline   Reply With Quote
Old 05-24-2002, 02:17 AM   #19
BlazingRS
Scooby Newbie
 
Member#: 16443
Join Date: Mar 2002
Location: SF bay area
Vehicle:
01 2.5 RS
blue ridge pearl

Default

THe only mod I've done is the intake (ganzflow). Is it true that this wouldn't be the cause for the CEL?
BlazingRS is offline   Reply With Quote
Old 05-24-2002, 02:20 AM   #20
LVSUBARU
Scooby Specialist
 
Member#: 4520
Join Date: Feb 2001
Location: LAS VEGAS
Vehicle:
93 STi V.4 RA
www.flat4lv.com

Default

There is one sure fire way to turn off the CEL...........Take the bulb out!!!!!!
That works or me!!!!
LVSUBARU is offline   Reply With Quote
Old 05-24-2002, 02:25 AM   #21
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by LVSUBARU
There is one sure fire way to turn off the CEL...........Take the bulb out!!!!!!
That works or me!!!!
sorry i don't like jail cells...but hey whatever floats your boat...sounds like you have a bad o2 sensor or a bad catalyst...why not fuggin take the thing to the dealer and GET IT CHECKED!
HndaTch627 is offline   Reply With Quote
Old 05-24-2002, 02:37 AM   #22
LVSUBARU
Scooby Specialist
 
Member#: 4520
Join Date: Feb 2001
Location: LAS VEGAS
Vehicle:
93 STi V.4 RA
www.flat4lv.com

Default

I am a dealer!!!!!
I don't live in CA so it isn't illegal. I was geting codes for the rear O2S. I've replaced it since. My CEL probally isn't even on anymore!
LVSUBARU is offline   Reply With Quote
Old 05-24-2002, 11:21 AM   #23
RallyNavvie
Scooby Specialist
 
Member#: 7113
Join Date: Jun 2001
Chapter/Region: TXIC
Location: Minnesotan in Texas
Vehicle:
2008 Spec B
DGM

Default

The point I was trying to make is it doesn't really belong in the AFI forum. Leave the NA jockeys to help you figure this one out. On this side of the performance coin we just take the damn bulb off because all it is to us AFI folks is a reminder we have a turbo/SC under the hood.

~Garrett
RallyNavvie is offline   Reply With Quote
Old 05-24-2002, 02:09 PM   #24
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by LVSUBARU
I am a dealer!!!!!
I don't live in CA so it isn't illegal. I was geting codes for the rear O2S. I've replaced it since. My CEL probally isn't even on anymore!
ummm FYI it's a federal offense to tamper w/ the CE light as well as remove a working catalyst.

jeremy
HndaTch627 is offline   Reply With Quote
Old 05-24-2002, 09:14 PM   #25
LVSUBARU
Scooby Specialist
 
Member#: 4520
Join Date: Feb 2001
Location: LAS VEGAS
Vehicle:
93 STi V.4 RA
www.flat4lv.com

Default

Shhhhhhh!
Just don't tell the FBI and I'll be OK!
LVSUBARU is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dude whats up with this!? Sleepy Wagon. Factory 2.0L Turbo Powertrain 8 12-29-2006 11:16 AM
whats up with this 98subyrezaRS Normally Aspirated Powertrain 4 01-01-2006 10:52 AM
whats up with this???? notyet227 Texas Impreza Club Forum -- TXIC 4 09-11-2005 11:11 AM
Ok...so whats up with this WRteXmeX Texas Impreza Club Forum -- TXIC 1 10-23-2002 10:17 AM
whats up with the security light? GeoT100 Service & Maintenance 2 04-11-2002 11:18 AM


All times are GMT -4. The time now is 02:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.