Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-15-2010, 11:46 PM   #1
BallzToTheWallz
Scooby Specialist
 
Member#: 128949
Join Date: Oct 2006
Chapter/Region: NESIC
Location: Fairfield County, Connecticut
Vehicle:
2004 VF22 WRX hybrid
JBP 306 whp 366wtq

Default Need help!! Car wont start!! 1997 subaru legacy 2.5 GT

I have a 1997 Subaru Legacy Gt and i bought the car not to long ago. I dont know to much about the car but the guy before me told me he had put a new motor in the car which i later found out wasnt the original 2.5 liter motor but a 2.2 liter instead now idk if theres a difference in the ECU's on the car but let me break down a list of the symptoms the car had before the breaking down and after.

Before:
- Car had the engine light on when i bought it. I scanned it before i bought it and i found the light to be on for a speed sensor a misfire on all 4 cylinders and a engine light for a front oxygen sensor (circuit low)
- I fixed the speed sensor because i couldnt deal with anymore speding tickets on my record.
- Last week i put a front oxygen sensor in the car (for a 2.2l) and before that i just drove with it unplugged for a good month or so because the car ran all sorts of funky (bogging and like sputtering)
- after i replaced the oxygen sensor i noticed it ran okay but it would intermittently feel like it was fuelcutting while i was driving under a light load almost at a coast.

After:
- So i went to go pick up take out on Valentines day and i noticed as i was driving it was cutting out and sputtering a little more then usual but i didnt think anything of it just thinking it was a misfire.
- Then when i got to the resturant and parked it i went to go turn the key and befiore i did the car died. not like a sputtering die like a just shut off die all at once. almost as if i had turned the key.
- I figured it was the fuel pump because i turned it over alot and checked to see how the exhaust smelt and there wasnt any gas smell what so ever.
- I had it towed to my work (pep boys) today and i igured out it has to spark coming from the coil pack but there was a signal at the connector so i replaced the coil. still nothing.
- I then went to check if there were any new codes and i plugged in the DLC and there wasnt any power to it and if i remember correctly there werent any dash lights.
- the car turns over very strong and ran rather well for a while and now it wont even think about starting as i turn it over.

Any input on this would be appreciated as i need to get this car back on the road tomorrow because i cant afford to break out the race car in the middle of winter. Please any input would be helpful. Thank you for your time and if you have any questions at all please feel free to shoot.

Thank you
John
-
* Registered users of the site do not see these ads.
BallzToTheWallz is offline   Reply With Quote
Old 02-16-2010, 12:20 PM   #2
snoopyone8
Scooby Newbie
 
Member#: 42970
Join Date: Sep 2003
Chapter/Region: NESIC
Location: Connecticut USA
Vehicle:
1998 2.5RS BlkDmdPrl
2000 2.5RS SilverthornMet

Default

Basics...
Spark...you said you have this, right?
Fuel...do you hear the pump prime when you turn the key on? I dont know if the 2.2 has a schrader valve on a fuel rail but this is the ideal place to check fuel pressure if it does.
Air...this shouldnt be a problem unless your airbox has a critter living in it.

Check all the basics first. Rule out the easy stuff. Then...

Check your grounds. Make sure the engine grounds are good, the fuel pump and sending unit grounds, ECU ground to chassis...
Check your plugs...if you ran without an O2 sensor, the plugs could be fouled- up bad do to the computer reverting to a "safe" rich condition--(O2 code, misfire code.)
Check the timing belt...it could have jumped a tooth or it could have broken--(misfire code).

Just my 2 cents,
-adam
snoopyone8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS- AZ 1997 Subaru Legacy 2.5 GT *must see* FATgc8 Private Vehicle 'For Sale' Classifieds 8 04-26-2009 07:38 PM
WTB: 1997-1999 Legacy 2.5 GT 5MT ECU winston856 Private 'Wanted' Classifieds 4 11-08-2008 08:07 PM
1997 SUBARU LEGACY 2.5 GT 5 speed (MIDNIGHT BLUE) FOR SALE $4300 gagegregory Legacy Specific Parts 6 01-13-2008 03:05 PM
1997 subaru legacy 2.5 gt? dracatero Subaru Conversions 3 12-03-2007 08:36 PM
NEED HELP! car wont start after deck installation! yeng Car Audio, Video & Security 7 04-28-2003 06:53 PM


All times are GMT -4. The time now is 08:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.