Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-19-2010, 03:18 AM   #1
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default Alcoolaid's New 2010 Build

2009 Build Details: http://forums.nasioc.com/forums/show....php?t=1749917

Last motor was basically a built bottom end with a turbo kit and stock heads running on the stock ecu and using a Cobb APV2 for engine management. Got it tuned by Dominic @ Maxwell Power and made 511whp/444wtq with 28psi boost on 94 octane and 70/30 meth/water injection.

Ever since the tune I've always wanted to run a standalone ecu just to have better drivability since the MAF was so big it wasn't that great for daily driving. Also, a lot of people kept bugging me to build the heads since obviously this was hindering my top end power.

So, after picking up a Vi-Pec V88 standalone ECU and purchasing some built heads from a close friend, I decided it was time to quickly pull the motor out again before the track season season starts in March.

Ever since my tune in October I've put about 5,000 hard miles on the car and everything is still great!

Heads are currently at Maxwell Power getting cleaned up so once I get those back I'll assemble the motor back up and wait for my new clutch disk to arrive before I drop it back in. Then it's back down to Maxwell to let Dom work his magic Can't wait to see the top-end gains @ the same boost level. Also it should be fun playing with the anti-lag

Engine specifications:
EJ257 703 Casting
CP Pistons 99.75mm w/ Ceramic Crown and Molybdenum Disulfide Skirt Coating
Carrillo Forged H-Beam Rods
Engine Fully Balanced
Stock STI Crank – Lightened a little bit
Calico Coated ACL Race Bearings
OEM Head Gaskets
ARP Head studs
11mm Oil Pump w/2 shims

B25 Heads
Kelford 276/272 AVCS Cams
5-Angle Intake Valve Job
3-Angle & Radiused Exhaust Valve Job
Supertech +1mm IN/EX Valves
Valves Lapped
Supertech Dual Valve Springs
Titanium Retainers

Other stuff:
Gates Racing Timing Belt
TGV Port and Delete
Ported Intake Manifold
BW S300sx 83-75 0.91AR
Custom TS-T4 header/up-pipe
Dual Tial 38mm MV-S WG’s
Mocal 25 Row Oil Cooler
Mocal Sandwich Adapter w/ Thermostat
MAC 3 Port Boost Solenoid
AEM/Zeitronix 3.5Bar MAP Sensor
APS DR725 FMIC with Custom Upper Pipes
GrimmSpeed 8mm Phenolic Spacers
Walbro 255LPH Fuel Pump Intank
Bosch 044 External Fuel Pump
Canton Racing 8 micron Fuel Filter
Covert Performance Fuel Surge tank
-8AN Feed and -6AN Return Fuel Lines
Injector Dynamics Bosch 1000cc Injectors
Aeromotive Top Feed Fuel Rails
Aeromotive A1000-6 FPR
Aquamist HFS-5 Meth Injection System 2x 1.0mm nozzles
Spec C STI 12L Intercooler Spray Tank
Vi-Pec V88 Standalone ECU
ACT Xtreme 6 Puck Sprung Clutch
ACPT Carbon Fiber Driveshaft
* Registered users of the site do not see these ads.

Last edited by alcoolaid; 02-19-2010 at 03:26 AM.
alcoolaid is offline   Reply With Quote
Old 02-19-2010, 03:23 AM   #2
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Some pictures of the motor pull and ECU wiring :S
















Last edited by alcoolaid; 02-19-2010 at 03:37 AM.
alcoolaid is offline   Reply With Quote
Old 02-19-2010, 07:26 AM   #3
CKxx
Scooby Specialist
 
Member#: 33458
Join Date: Feb 2003
Chapter/Region: Tri-State
Location: PA
Vehicle:
Your BOV sounds lame
93 RX7+09 Forester

Default

That harness pic gave me a headache!

It will be cool to see the gains from the headwork.
CKxx is offline   Reply With Quote
Old 02-19-2010, 08:30 AM   #4
GHK
Scooby Specialist
 
Member#: 103886
Join Date: Dec 2005
Chapter/Region: NESIC
Location: Westford, MA
Vehicle:
2005 WRX
OBP

Default

Hope you have a great success on this project!
GHK is offline   Reply With Quote
Old 02-19-2010, 11:12 AM   #5
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Quote:
Originally Posted by CKxx View Post
That harness pic gave me a headache!

It will be cool to see the gains from the headwork.
Me too. I'm going to have to have the dyno plots put together on the same sheet. Hope my power doesn't shift too far to the right....
alcoolaid is offline   Reply With Quote
Old 02-19-2010, 11:24 AM   #6
modaddict
Scooby Guru
 
Member#: 95840
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Pasco, WA
Vehicle:
sold to a good bud
awaiting next car

Default

holy turbo.

I love it.
modaddict is offline   Reply With Quote
Old 02-19-2010, 04:11 PM   #7
dmross
Scooby Specialist
 
Member#: 2818
Join Date: Nov 2000
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2000 2.5RS

Default

Awesome! Good luck with the ViPEC!

Are those dual-avcs heads that you picked up?
dmross is offline   Reply With Quote
Old 02-19-2010, 04:37 PM   #8
rexworx
Scooby Guru
 
Member#: 103232
Join Date: Dec 2005
Chapter/Region: Tri-State
Location: EWG3071KelfordCams276/272
Vehicle:
MY05 GDA,MY04FXT6spd
2.5ltr,PPG,Front LSD,4.44

Default

Wow looks fun... Your only changing the heads, correct?
rexworx is offline   Reply With Quote
Old 02-19-2010, 05:29 PM   #9
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Quote:
Originally Posted by dmross View Post
Awesome! Good luck with the ViPEC!

Are those dual-avcs heads that you picked up?
I'm sending you a pm right now regarding the ecu!

And nope, intake AVCS only.

Quote:
Originally Posted by rexworx View Post
Wow looks fun... Your only changing the heads, correct?
Yup, heads only. New clutch disk too
alcoolaid is offline   Reply With Quote
Old 02-19-2010, 06:17 PM   #10
hustleshark206
Scooby Specialist
 
Member#: 182227
Join Date: Jun 2008
Chapter/Region: NWIC
Location: seattle, WA/ Jackson WY
Vehicle:
2000 MPS Built RS
1991 Leggy Turbo EJ22t

Default

I saw you at MPS on saturday while I was working on my car. I am interested to see the gains from your built heads.

Good Luck
hustleshark206 is offline   Reply With Quote
Old 02-19-2010, 07:06 PM   #11
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 7670 TS

Default

Why is the firewall all black?

Have you had any exhaust leaks any where?

"Supertech Dual Valve Springs" you going for 9k rpm?

Last edited by Bariga; 02-19-2010 at 09:11 PM.
Bariga is offline   Reply With Quote
Old 02-24-2010, 12:11 AM   #12
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Quote:
Originally Posted by hustleshark206 View Post
I saw you at MPS on saturday while I was working on my car. I am interested to see the gains from your built heads.

Good Luck
When is your car done? I see it's still there.

Quote:
Originally Posted by Bariga View Post
Why is the firewall all black?

Have you had any exhaust leaks any where?

"Supertech Dual Valve Springs" you going for 9k rpm?
The turbo -> dp v-band was leaking and was too lazy to fix it for a while so it got black. All is good now

Probably going to have soft cut at 8000 and hard-cut at 8200.
alcoolaid is offline   Reply With Quote
Old 02-24-2010, 12:11 AM   #13
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Some photos for you guys. Swapped the heads. Got it all timed up. Just have to take the flywheel off, get it resurfaced, change the rear main seal, put the oil pan back on, put the turbo stuff on, intake manifold stuff and wiring harness then put the motor back in.

Also finally got the Vi-Pec working... 2 wires were mis-labeled on their wiring diagram so the DBW throttle plate wouldn't calibrate properly...

















alcoolaid is offline   Reply With Quote
Old 02-24-2010, 10:45 AM   #14
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

Nice job as usual. I know it may be too late now but did you refresh the engine bearings while you had the motor out? 5000 miles at your power level is hard on the bearings so I was wondering if you inspected them?
mick_the_ginge is offline   Reply With Quote
Old 02-24-2010, 12:50 PM   #15
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Quote:
Originally Posted by mick_the_ginge View Post
Nice job as usual. I know it may be too late now but did you refresh the engine bearings while you had the motor out? 5000 miles at your power level is hard on the bearings so I was wondering if you inspected them?
I was kind of lazy and don't have much free time left once the Olympics are over so I didn't feel like splitting the case.

I'm sure they should be fine but just wore as usual.... oh well!
alcoolaid is offline   Reply With Quote
Old 02-26-2010, 07:58 AM   #16
alcoolaid
Scooby Guru
 
Member#: 134949
Join Date: Dec 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
'07 SWP STi
Instagram | arthurlam89

Default

Video > pictures.

A friend of mine did a quick time-lapse of me dropping the motor in a few days ago.

Here it is!


Last edited by alcoolaid; 04-23-2010 at 06:17 AM.
alcoolaid is offline   Reply With Quote
Old 02-26-2010, 08:41 AM   #17
jsnm
Scooby Specialist
 
Member#: 186356
Join Date: Aug 2008
Chapter/Region: MAIC
Location: Delaware
Vehicle:
2006 WRX-pte6262
CTS-V,& 05 RS

Default

cool vid,thats awesome to watch.
good luck with the rest of the build
jsnm is offline   Reply With Quote
Old 02-26-2010, 10:45 AM   #18
MartinSTi05
Scooby Specialist
 
Member#: 145145
Join Date: Apr 2007
Chapter/Region: MWSOC
Location: Rockford, Il
Vehicle:
2006 wrx STi

Default

Good vid, Good work, Oontz Oontz...
MartinSTi05 is offline   Reply With Quote
Old 02-26-2010, 07:28 PM   #19
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

i run a ViPEC ECU. you will love it... easy to tune, and awesome for daily driving...

-=Suberdave=-
suberdave is offline   Reply With Quote
Old 02-26-2010, 08:47 PM   #20
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

hey I just noticed looking at your pics of the empty engine bay---what the hell is all over the paasenger side firewall? is your exhaust leaking at the v-band or was there a fire back there on the track?
john 1badSTI is offline   Reply With Quote
Old 02-26-2010, 09:07 PM   #21
sense of nature
Scooby Guru
 
Member#: 112759
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: In the V hole!
Vehicle:
?? pending....
sale....

Default

Maybe no dump tube for the waste gates ?
sense of nature is offline   Reply With Quote
Old 02-26-2010, 09:25 PM   #22
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

no with the motor hanging on the engine hoist you can see the dump tubes on the wg's.I was just wondering if v-bands on dp's usually leak or not.
john 1badSTI is offline   Reply With Quote
Old 02-26-2010, 09:35 PM   #23
morrocco88
Scooby Specialist
 
Member#: 104098
Join Date: Jan 2006
Chapter/Region: NWIC
Location: Eastern WA
Vehicle:
97' LGT 2.3 Dstroke
Rotated BW S256 6speed

Default

Quote:
Originally Posted by john 1badSTI View Post
hey I just noticed looking at your pics of the empty engine bay---what the hell is all over the paasenger side firewall? is your exhaust leaking at the v-band or was there a fire back there on the track?
Quote:
Originally Posted by alcoolaid View Post
The turbo -> dp v-band was leaking and was too lazy to fix it for a while so it got black. All is good now
Did you guys read the thread?
morrocco88 is offline   Reply With Quote
Old 02-26-2010, 09:36 PM   #24
Wintershredder
Scooby Specialist
 
Member#: 160089
Join Date: Sep 2007
Chapter/Region: RMIC
Location: Denver
Vehicle:
2004 STi,330xi,328xi
WRB, Black, White

Default

Read the damn thread... its all there



Quote:
Originally Posted by alcoolaid View Post
When is your car done? I see it's still there.


The turbo -> dp v-band was leaking and was too lazy to fix it for a while so it got black. All is good now

Probably going to have soft cut at 8000 and hard-cut at 8200.
Wintershredder is offline   Reply With Quote
Old 02-26-2010, 09:55 PM   #25
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

Quote:
Originally Posted by morrocco88 View Post
Did you guys read the thread?
hey hey hey guys my bad I missed it----no reason to get all jumpy about missing a little info.I read the thread cause I respect the work that dom does.
john 1badSTI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alcoolaid's Build thread alcoolaid Vancouver Impreza Club Forum -- VIC 467 10-14-2013 03:03 PM
SP00L's 2006 Impreza WRX. 2010 Build/Update Thread!! Sp00L Member's Car Gallery 169 05-31-2012 08:31 PM
Register for the 2010 Build The Track! Motorsports Show! June 19th, 2010! ArchangelX Hawaii Impreza Club Forum -- HIIC 4 07-09-2010 07:47 PM
New Member, New 2010 WRX, First Subaru hieu1004 Newbies & FAQs 11 03-14-2010 10:51 PM
Porsche unveils new 2010 GT3RS AKA I need a new pair of pants PitwrkzZ1 Off-Topic 64 08-19-2009 12:34 PM


All times are GMT -4. The time now is 10:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.