Welcome to the North American Subaru Impreza Owners Club Sunday February 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-01-2010, 07:21 PM   #1
minnk1
Scooby Newbie
 
Member#: 239877
Join Date: Mar 2010
Location: slovakia
Default engine heating

Hi guys,

I just bought my 99 subie turbo a month ago and about a week ago i encountered this engine heating problem. The weird thing is, the temperature only starts to rise to the very top of the engine temp gauge when im driving it on a snowy track going sideways a lot, or sometimes on a deeper snow and this happened 3 times already. First time i saw that, it took only about a minute of slow straight line driving and the temperature once again was fine. I guess there wasnt enough air taken through scoop on the bonnet. Note: im not having this problem while driving as i usually do in public streets, or while having a lil drag race or w/e. I thought head gasket, but it seems weird that the engine only starts to heat up when im really "stepping on it" in a track or tryin to do some basic sliding on a wet parking lot or w/e. btw, i had some fun on snowy public roads before and everything worked as a charm, no problem with the heating at all.

thanks in advance
* Registered users of the site do not see these ads.
minnk1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed engine coolant...engine heats up stxwrx69 Newbies & FAQs 7 12-30-2006 11:40 PM
engine heat 03outbacksport Newbies & FAQs 9 08-04-2006 02:42 PM
Engine Heats Faster Without Cats sandwi54 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 01-01-2006 06:43 PM
Engine heat shield dress up... Jsunn Interior & Exterior Modification 3 05-21-2005 01:49 PM


All times are GMT -4. The time now is 01:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.