Welcome to the North American Subaru Impreza Owners Club Tuesday December 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Closed Thread
Thread Tools Display Modes
Old 02-26-2010, 08:33 PM   #1
Scooby Specialist
Member#: 218199
Join Date: Jul 2009
Location: New York
2004 WRX

Default need help clutch / gears / tranny question

sooo i was having some fun (knowing) my clutch was going..and i was driftin around a parking lot, switched to second gear then boom...no more fun. i cant shift it into first at all clutch in or out its like shifting into a wall. it doesnt even go into first to try and drive., all the other gears work perfect. i dont know if i messed up the gears or the clutch or what...anyone else ever have this problem? its an 04 wrx
* Registered users of the site do not see these ads.
Nuveosif is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-26-2010, 08:36 PM   #2
Scooby Newbie
Member#: 99375
Join Date: Oct 2005
Chapter/Region: MWSOC
Location: Waterford, MI
2002 Subaru WRX
World Rally Blue


wrong thread entry, buddy. But to answer your question, it might be your syncros. If you're still able to drive in other gears and not feel your clutch slip, then it's a possible chance you blew your syncro or blew out first gear.
02_blue_u_away is offline  
Old 02-26-2010, 08:48 PM   #3
Big Ron
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
on car parts so PM
me b4 j00 buy


1. Wrong forum
2. You blew up your transmission, you need to seek professional, NOT internet help.
Unabomber is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Synchro, clutch, gear warranty questions STIDoctor Warranty Issues & SOA Problems 11 03-02-2008 03:32 AM
clutch and tranny questions CpnNeeda Service & Maintenance 3 06-17-2005 11:43 PM
any one need a clutch or tranny? farrell Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 12-28-2004 05:13 PM
Need help re. gear grinding since trans./diff. fluid change, info please! Longitude Southern California Impreza Club Forum -- SCIC 9 08-09-2004 06:21 PM
Need help with gears in tranny SpeedyBoy Bay Area Impreza Club Forum -- BAIC 5 06-25-2003 10:12 AM

All times are GMT -4. The time now is 07:26 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.