Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-18-2011, 12:11 AM   #376
smeerone
Scooby Specialist
 
Member#: 249068
Join Date: Jun 2010
Chapter/Region: South East
Location: Miami, Fl.
Vehicle:
2010 WRX
DGM Phatbotti Tuned

Default

Siiick...
* Registered users of the site do not see these ads.
smeerone is offline   Reply With Quote
Old 04-18-2011, 01:27 AM   #377
mmfullen
Scooby Specialist
 
Member#: 236685
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Hampton, VA
Vehicle:
2006 Legacy GT
OBP

Default

i'm jealous of the non-turbo hatch...THAT'S CLEAN!
mmfullen is offline   Reply With Quote
Old 04-18-2011, 02:25 AM   #378
prem205
Scooby Newbie
 
Member#: 233877
Join Date: Dec 2009
Chapter/Region: SCIC
Vehicle:
08 Impreza 2.5i
SSM

Default

Quote:
Originally Posted by suby_dude View Post
Wheels: 18x9.5 +30 Linea Corse Lemans in Hyper Silver with Polished Lip
Tires: 235/40/18 Bridgestone Adrenalin RE001
Suspension: Bc Racing Coilovers
Camber: -2.4F/-2.6R
Running aftermarket front camber bolts?
By any chance...do you rub the rear bumper corner?

Im on 18x9.5+34 w/ -3 rear camber and i still rub my rear bumper...
prem205 is offline   Reply With Quote
Old 04-18-2011, 11:00 AM   #379
cmrd18
Scooby Newbie
 
Member#: 199734
Join Date: Jan 2009
Location: Manila, Philippines
Vehicle:
2003 JDM STI
White

Default

Quote:
Originally Posted by mmfullen View Post
i'm jealous of the non-turbo hatch...THAT'S CLEAN!
Quote:
Originally Posted by prem205 View Post
Running aftermarket front camber bolts?
By any chance...do you rub the rear bumper corner?

Im on 18x9.5+34 w/ -3 rear camber and i still rub my rear bumper...
Hi, that's my car. Yes im running H&R front camber bolts. And yes i do rub but it happens rarely and only on huge bumps on the road. Are you on coilovers? try stiffening up the suspension. That might help.
cmrd18 is offline   Reply With Quote
Old 04-18-2011, 11:46 AM   #380
WhtRexGrl
Scooby Specialist
 
Member#: 230272
Join Date: Nov 2009
Chapter/Region: NESIC
Location: Reppin the 508 & 941
Vehicle:
10 WrX HaTch
suuuuuuuuper WhiTe

Default

^ I'm looking for some tips on how to make these work. I'm running BC's and trying to fit 18x9.5 +44 with 235/40/18's. Advice please - these are the test fits not even a 1/4" front. The camber hasn't been adjusted yet - just looking for suggestions on how to make these work on our 09 wrx sdn


WhtRexGrl is offline   Reply With Quote
Old 04-18-2011, 01:35 PM   #381
prem205
Scooby Newbie
 
Member#: 233877
Join Date: Dec 2009
Chapter/Region: SCIC
Vehicle:
08 Impreza 2.5i
SSM

Default

Quote:
Originally Posted by cmrd18 View Post
Hi, that's my car. Yes im running H&R front camber bolts. And yes i do rub but it happens rarely and only on huge bumps on the road. Are you on coilovers? try stiffening up the suspension. That might help.
Thats my problem, i dont like my ride that stiff hahaha.
prem205 is offline   Reply With Quote
Old 04-18-2011, 06:13 PM   #382
xxbodkinxx
Scooby Newbie
 
Member#: 155502
Join Date: Aug 2007
Default

Quote:
Originally Posted by WHTREXGRL
^ I'm looking for some tips on how to make these work. I'm running BC's and trying to fit 18x9.5 +44 with 235/40/18's. Advice please - these are the test fits not even a 1/4" front. The camber hasn't been adjusted yet - just looking for suggestions on how to make these work on our 09 wrx sdn
I'm running the same setup, factory camber bolts all the way negative, coilover bolts all the way negative. Stiffness on coilover about 20 clicks. I rub when turning into parking lots etc and it drives me nuts. Gonna raise it a bit cause i can't stand it. I'm tucking a little tire up front so I should raise it a bit anyways.
xxbodkinxx is offline   Reply With Quote
Old 04-18-2011, 07:03 PM   #383
cmrd18
Scooby Newbie
 
Member#: 199734
Join Date: Jan 2009
Location: Manila, Philippines
Vehicle:
2003 JDM STI
White

Default

Quote:
Originally Posted by WHTREXGRL View Post
^ I'm looking for some tips on how to make these work. I'm running BC's and trying to fit 18x9.5 +44 with 235/40/18's. Advice please - these are the test fits not even a 1/4" front. The camber hasn't been adjusted yet - just looking for suggestions on how to make these work on our 09 wrx sdn
Those Federals look really meaty. I had a lot of stretch on my Bridgestone tires. Does it clear the rear struts? Looks like you'll be needing 3mm spacers if you're on stock struts plus a rear fender roll.

Quote:
Originally Posted by prem205 View Post
Thats my problem, i dont like my ride that stiff hahaha.
you gain some, you lose some. lol.

Quote:
Originally Posted by xxbodkinxx View Post
I'm running the same setup, factory camber bolts all the way negative, coilover bolts all the way negative. Stiffness on coilover about 20 clicks. I rub when turning into parking lots etc and it drives me nuts. Gonna raise it a bit cause i can't stand it. I'm tucking a little tire up front so I should raise it a bit anyways.
I already rolled my front fenders. So far no rubbing up front even when the steering wheel is turned all the way.
cmrd18 is offline   Reply With Quote
Old 04-18-2011, 08:10 PM   #384
WhtRexGrl
Scooby Specialist
 
Member#: 230272
Join Date: Nov 2009
Chapter/Region: NESIC
Location: Reppin the 508 & 941
Vehicle:
10 WrX HaTch
suuuuuuuuper WhiTe

Default

[quote=cmrd18;33890948]Those Federals look really meaty. I had a lot of stretch on my Bridgestone tires. Does it clear the rear struts? Looks like you'll be needing 3mm spacers if you're on stock struts plus a rear fender roll.

I know, I have a set of 18x9 +40 with 225/40/18's for my hatch and I wish I went with a bigger stretch with these 18x9.5 but we need to have some tire under us around here.
I'm running BC's - it looks like it clears in the rear just seems to need a camber adj and a fender roll.
It's the front that appears to be the biggest problem at this point.
WhtRexGrl is offline   Reply With Quote
Old 04-19-2011, 01:13 AM   #385
prem205
Scooby Newbie
 
Member#: 233877
Join Date: Dec 2009
Chapter/Region: SCIC
Vehicle:
08 Impreza 2.5i
SSM

Default

Quote:
Originally Posted by cmrd18 View Post
Those Federals look really meaty. I had a lot of stretch on my Bridgestone tires. Does it clear the rear struts? Looks like you'll be needing 3mm spacers if you're on stock struts plus a rear fender roll.


you gain some, you lose some. lol.


I already rolled my front fenders. So far no rubbing up front even when the steering wheel is turned all the way.
Really...?
Are you tucking front tire at all?

My front rubbing when turning drives me nuts too. Maybe ill try more camber up front to see if that helps.
prem205 is offline   Reply With Quote
Old 04-19-2011, 02:28 AM   #386
soysosrex
Scooby Newbie
 
Member#: 265095
Join Date: Nov 2010
Default

Quote:
Originally Posted by suby_dude View Post
Wheels: 18x9.5 +30 Linea Corse Lemans in Hyper Silver with Polished Lip
Tires: 235/40/18 Bridgestone Adrenalin RE001
Suspension: Bc Racing Coilovers
Camber: -2.4F/-2.6R




how good of a setup is that for daily driving? i really want WIDE wheels, but all that camber and tire stretching is troubling me
soysosrex is offline   Reply With Quote
Old 04-19-2011, 04:15 AM   #387
cmrd18
Scooby Newbie
 
Member#: 199734
Join Date: Jan 2009
Location: Manila, Philippines
Vehicle:
2003 JDM STI
White

Default

Quote:
Originally Posted by prem205 View Post
Really...?
Are you tucking front tire at all?

My front rubbing when turning drives me nuts too. Maybe ill try more camber up front to see if that helps.
Yes. No fender gap but im not tucking. I have a good amount of camber. Here's the front of my car:


Quote:
Originally Posted by soysosrex View Post
how good of a setup is that for daily driving? i really want WIDE wheels, but all that camber and tire stretching is troubling me
It depends on where you go on your daily drives. My tires lasts pretty long. I just made sure toe is set at 0.
cmrd18 is offline   Reply With Quote
Old 04-19-2011, 12:01 PM   #388
Wrx_FoSho
Scooby Newbie
 
Member#: 277108
Join Date: Mar 2011
Location: Illinois
Vehicle:
09 Wrx Hatch
Grey

Default

^^ hands down. Dopest Subaru Hatch ever!
Wrx_FoSho is offline   Reply With Quote
Old 04-19-2011, 01:45 PM   #389
prem205
Scooby Newbie
 
Member#: 233877
Join Date: Dec 2009
Chapter/Region: SCIC
Vehicle:
08 Impreza 2.5i
SSM

Default

Quote:
Originally Posted by cmrd18 View Post
Yes. No fender gap but im not tucking. I have a good amount of camber. Here's the front of my car:
Wow...look so clean lol.

Where did you get the siddeskirts, rear spats, etc from?
And please dont tell me canada sport package...lol
prem205 is offline   Reply With Quote
Old 04-19-2011, 07:26 PM   #390
LS6 Tommy
Scooby Newbie
 
Member#: 268720
Join Date: Dec 2010
Default New wheels, dirty car

My summer setup- Stock 235/45 R 17 Dunlop Sport SP 01s on TSW Nurburgring machined face/Gunmetal Black, 17" x 8" 45mm offset:








Tommy
LS6 Tommy is offline   Reply With Quote
Old 04-19-2011, 09:17 PM   #391
xxbodkinxx
Scooby Newbie
 
Member#: 155502
Join Date: Aug 2007
Default

Raised mine about 1/2 inch and no more rubbing wohoo. I was tucking tire in the front so I guess thats why I was rubbing. Going to take some picks this weekend of my new setup. I love being aggressive glad i went with 9.5's
xxbodkinxx is offline   Reply With Quote
Old 04-21-2011, 01:37 AM   #392
soysosrex
Scooby Newbie
 
Member#: 265095
Join Date: Nov 2010
Default

Quote:
Originally Posted by cmrd18 View Post
Yes. No fender gap but im not tucking. I have a good amount of camber. Here's the front of my car:



It depends on where you go on your daily drives. My tires lasts pretty long. I just made sure toe is set at 0.
do you know if the 8.5 half iinch wide lemans have that big of a lip?
soysosrex is offline   Reply With Quote
Old 04-21-2011, 10:44 AM   #393
Breezio
Scooby Specialist
 
Member#: 234357
Join Date: Jan 2010
Location: Forest Grove, OR
Vehicle:
2009 WRX
Sportwagen zum einbauen!

Default

Quote:
Originally Posted by soysosrex View Post
do you know if the 8.5 half iinch wide lemans have that big of a lip?
From the looks of it, it's a little smaller. Though I think it's mainly due to the offset.
The 8.5 I found is +45mm
His 9.5's are +30

18x8.5 Linea Corse Lemans +45

Breezio is offline   Reply With Quote
Old 04-23-2011, 07:00 PM   #394
Wrx_FoSho
Scooby Newbie
 
Member#: 277108
Join Date: Mar 2011
Location: Illinois
Vehicle:
09 Wrx Hatch
Grey

Default

do you guys do anything about the tire pressure sensors? Do you put new ones on?or dont even bother using them?
Wrx_FoSho is offline   Reply With Quote
Old 04-23-2011, 08:44 PM   #395
cianuro
Scooby Newbie
 
Member#: 235475
Join Date: Jan 2010
Chapter/Region: PRSIC
Location: Puerto Rico
Vehicle:
2008 WRX
Silver

Default

Quote:
Originally Posted by Wrx_FoSho
do you guys do anything about the tire pressure sensors? Do you put new ones on?or dont even bother using them?
I took mine out of the stockers and placed them in the new rims. I bought the stems separately so I could leave the stockers available to use. Weird thing was that I ran on the stockers w/o the sensors for a few days afterwards and the light never came on.

I read somewhere that the light will only be triggered if the sensors read below 26 psi. I assume since mine were not installed, there was never a low psi signal sent to the module, therefore the light never went on. But, that's my case in particular, so I don't know if others will behave the same.

I started a thread about this but didn't get an answer.
cianuro is offline   Reply With Quote
Old 04-24-2011, 02:29 AM   #396
Wrx_FoSho
Scooby Newbie
 
Member#: 277108
Join Date: Mar 2011
Location: Illinois
Vehicle:
09 Wrx Hatch
Grey

Default

Quote:
Originally Posted by cianuro View Post
I took mine out of the stockers and placed them in the new rims. I bought the stems separately so I could leave the stockers available to use. Weird thing was that I ran on the stockers w/o the sensors for a few days afterwards and the light never came on.

I read somewhere that the light will only be triggered if the sensors read below 26 psi. I assume since mine were not installed, there was never a low psi signal sent to the module, therefore the light never went on. But, that's my case in particular, so I don't know if others will behave the same.

I started a thread about this but didn't get an answer.
Thanks. Some people put their stock ones on,some buy new ones, some drive with the light on, and some just take the light out.

Basically up to you I guess. I personally would get new ones but yea. Was just asking how you guys go about it.
Wrx_FoSho is offline   Reply With Quote
Old 04-24-2011, 09:24 AM   #397
tonyturbo13
Scooby Newbie
 
Member#: 226525
Join Date: Oct 2009
Chapter/Region: NWIC
Location: WA
Vehicle:
2009 Impreza WRX
World Rally Blue

Default

Car - 2009 WRX
Wheels - XXR 522 / 18x8.5
Suspension - Tein S tech springs

I'll try to snap some better daytime pics when I get a chance

tonyturbo13 is offline   Reply With Quote
Old 04-24-2011, 11:16 AM   #398
stoker68
Scooby Newbie
 
Member#: 208185
Join Date: Apr 2009
Chapter/Region: NESIC
Location: Mass.
Vehicle:
2009 WRX 5-door
Dark Gray Metallic

Default

Quote:
Originally Posted by LS6 Tommy View Post
My summer setup- Stock 235/45 R 17 Dunlop Sport SP 01s on TSW Nurburgring machined face/Gunmetal Black, 17" x 8" 45mm offset:





Tommy
Tommy, car and wheels look awesome! Where did you pick the rims up? I was thinking about going with the same set for mine.
stoker68 is offline   Reply With Quote
Old 04-24-2011, 07:46 PM   #399
johnnyb
Scooby Specialist
 
Member#: 57593
Join Date: Mar 2004
Chapter/Region: SCIC
Location: Stay Classy, CA
Vehicle:
2008 WRX Hatch
WRB

Default

Prodrive GTR1's 18X7.5 48 offset (thanks to Billy at Broken Motorsports for the great deal on these) wrapped in Continental KDW all season 225/40/18 on stock suspension. RCE yellows and Bilstein combo coming soon.








Last edited by johnnyb; 04-24-2011 at 07:59 PM.
johnnyb is offline   Reply With Quote
Old 04-27-2011, 05:54 PM   #400
Landin2010
Scooby Newbie
 
Member#: 231674
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2010 Impreza WRX
Obsidian Black Pearl

Default

i just bought a set of rpf1's for my 2010 obp hatch theyre 17x8.5 +40 all the way around
Landin2010 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.