Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-14-2012, 11:27 PM   #51
Power6
NASIOC Supporter
 
Member#: 72730
Join Date: Oct 2004
Chapter/Region: NESIC
Location: Wayland, MA
Vehicle:
2001 Lexus ES300,
2005 Outback XT

Default

Quote:
Originally Posted by Pearldrummer7 View Post
I think that's everyone's agreed guess on it, thought I'm not sure if anyone has reported back saying they are/aren't.

If you find out, definitely let us know! I'm interested in doing this to my '12 Premium (even if I need to wire it myself; I'm a Electrical Engy so it shouldn't be much if an issue!)
The 08-10 cars were hit and miss, they all have the wiring into the door for the signal but the WRX 11-12 (and probably '13) have always had the signal wires "live" in my experience, you could just plug a signal mirror in or tap the wires.

Quote:
Originally Posted by SGMSTI View Post
I see everyone is putting these on the premium wrx what about the base wrx will it be the same
Base should be the same yes, it has an 8-pin connector going to the mirror instead of the 10-pin, the missing wires are the heat wires, signal wires are still there.

Quote:
Originally Posted by BoDacious View Post
Would it be plug and play for a 2011 wrx if i just purchased the harness for the mirrors? I want to avoid tapping into any other wires.
You can't buy the mirror wiring, the part is serviced (mostly) as a unit by Subaru and they don't sell wiring repair parts.

I certainly understand the pain of having to rig it up, I am actually trying to source the wiring to put together a "signal kit" the jury is still out on that.
* Registered users of the site do not see these ads.
Power6 is offline   Reply With Quote
Old 03-11-2013, 06:59 PM   #52
sdramsey24
Scooby Newbie
 
Member#: 306076
Join Date: Jan 2012
Default

Fantastic mod! I was thinking just yesterday that I'd really like signal indicators on my '11 WRX Limited. Sounds like it would literally be plug and play for me.

How difficult is it to take off the mirrors? Door panels have to come off? I'll do some searching /lazy
sdramsey24 is offline   Reply With Quote
Old 06-02-2013, 01:01 AM   #53
mattesonb
Scooby Specialist
 
Member#: 139607
Join Date: Feb 2007
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2011 WRX
DGM Wrapped Satin Black

Default

i can confirm that the base model WRX does not have the compatible harness to be plug and play.

i installed 2011 sti heated mirrors today and the sti plug is wider than the harness in the door from the factory on the base WRX.

i ended up matching the wires in the harness for the mirror motors but i had to add the ground and run a wire through the door same as the first poster
mattesonb is offline   Reply With Quote
Old 06-03-2013, 10:25 AM   #54
bratte88
*** Banned ***
 
Member#: 325949
Join Date: Jul 2012
Chapter/Region: NESIC
Location: CT
Default

Quote:
Originally Posted by mattesonb View Post
i can confirm that the base model WRX does not have the compatible harness to be plug and play.

i installed 2011 sti heated mirrors today and the sti plug is wider than the harness in the door from the factory on the base WRX.

i ended up matching the wires in the harness for the mirror motors but i had to add the ground and run a wire through the door same as the first poster
He said above you need to buy 08-10 STi as they are the 8pin that the base wrx has for 11-13. You bought the wrong mirrors.
bratte88 is offline   Reply With Quote
Old 06-04-2013, 01:08 AM   #55
jinstwrx
Scooby Newbie
 
Member#: 338623
Join Date: Nov 2012
Chapter/Region: SCIC
Location: Westminster, CA
Vehicle:
2011 Subaru WRX
red

Default

*bookmarking this for future use*
jinstwrx is offline   Reply With Quote
Old 06-04-2013, 01:51 PM   #56
bratte88
*** Banned ***
 
Member#: 325949
Join Date: Jul 2012
Chapter/Region: NESIC
Location: CT
Default

Quote:
Originally Posted by Power6 View Post
The 08-10 cars were hit and miss, they all have the wiring into the door for the signal but the WRX 11-12 (and probably '13) have always had the signal wires "live" in my experience, you could just plug a signal mirror in or tap the wires.



Base should be the same yes, it has an 8-pin connector going to the mirror instead of the 10-pin, the missing wires are the heat wires, signal wires are still there.



You can't buy the mirror wiring, the part is serviced (mostly) as a unit by Subaru and they don't sell wiring repair parts.

I certainly understand the pain of having to rig it up, I am actually trying to source the wiring to put together a "signal kit" the jury is still out on that.


Judging by your two posts..a 08-10 STi parts will fit/work with 11+ WRX BASE? is this correct?
bratte88 is offline   Reply With Quote
Old 06-04-2013, 04:38 PM   #57
sc00by4life
Scooby Guru
 
Member#: 97135
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Bothell
Default

Quote:
Originally Posted by bratte88 View Post

Judging by your two posts..a 08-10 STi parts will fit/work with 11+ WRX BASE? is this correct?
Typically, yes.
sc00by4life is online now   Reply With Quote
Old 06-05-2013, 10:01 AM   #58
Power6
NASIOC Supporter
 
Member#: 72730
Join Date: Oct 2004
Chapter/Region: NESIC
Location: Wayland, MA
Vehicle:
2001 Lexus ES300,
2005 Outback XT

Default

Quote:
Originally Posted by bratte88 View Post
Judging by your two posts..a 08-10 STi parts will fit/work with 11+ WRX BASE? is this correct?
Yeah you want to match your unheated mirror with an unheated mirror.

unheated=8-pin
heated=10-pin

All US STI 11+ have heated mirrors and all 08-10 STI have unheated mirrors (Canada all STI have heated mirrors)

Now it is not a big deal to pull the pins from a 10-pin connector and snap them in an 8-pin housing (leave the heat wires free) you take from your stock mirrors, so you can swap between easily if you aren't concerned with reselling your stock mirrors.
Power6 is offline   Reply With Quote
Old 06-05-2013, 10:07 AM   #59
Power6
NASIOC Supporter
 
Member#: 72730
Join Date: Oct 2004
Chapter/Region: NESIC
Location: Wayland, MA
Vehicle:
2001 Lexus ES300,
2005 Outback XT

Default

Quote:
Originally Posted by mattesonb View Post
i can confirm that the base model WRX does not have the compatible harness to be plug and play.

i ended up matching the wires in the harness for the mirror motors but i had to add the ground and run a wire through the door same as the first poster
As mentioned above the heated mirror car will have a 10-pin plug, your unheated WRX will use an 8-pin.

Did you test the signal wires before install? One will be grounded (its joined inside the door harness to a common ground) and one should be the signal (+). I haven't seen anyone with a 11+ WRX yet that doesn't have live signal wires. The 08-10 were spotty some did some didn't. Nothing wrong with running your own wires though.

WRBear wrote the DIY long before we figured out that the signal wires are already there in the harness.
Power6 is offline   Reply With Quote
Old 06-20-2013, 06:30 PM   #60
KillJoy25
Scooby Specialist
 
Member#: 174741
Join Date: Mar 2008
Chapter/Region: MAIC
Location: Norfolk, Virginia/Lorain, Ohio
Vehicle:
2008 Impreza WRX
Black

Default

I'm having an issue with this. Currently none of my turn signals are working. Here's what I've got so far: both led signals are installed and side mirror covers on. Wire from the passenger side has stopped at the door for now and grounded. The driver side is grounded, ran through the grommet and is connected to the gray wire. I had nothing from the driver side led, so I sanded down the ground some more, checked all of the connections to make sure none fell off. After this had happened, none of my turn signals are working. I even changed out the fuse. Please help, my state inspection is due by the end of the month and won't pass if these signals aren't working.
KillJoy25 is offline   Reply With Quote
Old 06-26-2013, 03:23 PM   #61
bratte88
*** Banned ***
 
Member#: 325949
Join Date: Jul 2012
Chapter/Region: NESIC
Location: CT
Default

Quote:
Originally Posted by KillJoy25 View Post
I'm having an issue with this. Currently none of my turn signals are working. Here's what I've got so far: both led signals are installed and side mirror covers on. Wire from the passenger side has stopped at the door for now and grounded. The driver side is grounded, ran through the grommet and is connected to the gray wire. I had nothing from the driver side led, so I sanded down the ground some more, checked all of the connections to make sure none fell off. After this had happened, none of my turn signals are working. I even changed out the fuse. Please help, my state inspection is due by the end of the month and won't pass if these signals aren't working.
What year setup do you have
bratte88 is offline   Reply With Quote
Old 06-26-2013, 07:23 PM   #62
KillJoy25
Scooby Specialist
 
Member#: 174741
Join Date: Mar 2008
Chapter/Region: MAIC
Location: Norfolk, Virginia/Lorain, Ohio
Vehicle:
2008 Impreza WRX
Black

Default

2008 WRX. After I crimped into the gray wire, I turned on the car to test and I got nothing. None of my turn signals are working.
KillJoy25 is offline   Reply With Quote
Old 06-26-2013, 07:30 PM   #63
WRBear
Scooby Specialist
 
Member#: 207171
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Fairfield County
Vehicle:
2009 Pain in my ass
World Rally Bruised

Default

Quote:
Originally Posted by KillJoy25 View Post
2008 WRX. After I crimped into the gray wire, I turned on the car to test and I got nothing. None of my turn signals are working.
Can you uncrimp and see if it works again?
WRBear is offline   Reply With Quote
Old 06-27-2013, 07:33 PM   #64
KillJoy25
Scooby Specialist
 
Member#: 174741
Join Date: Mar 2008
Chapter/Region: MAIC
Location: Norfolk, Virginia/Lorain, Ohio
Vehicle:
2008 Impreza WRX
Black

Default

Yea, it's blowing the fuse. When I uncrimp and put in a new fuse the turn signals work.
KillJoy25 is offline   Reply With Quote
Old 07-01-2013, 09:32 AM   #65
max6spd
Scooby Specialist
 
Member#: 151670
Join Date: Jun 2007
Chapter/Region: Tri-State
Vehicle:
2009 Forester
Satin White Pearl

Default

Hey there. I was hoping you can address some questions I had in regards to installing heated and signaled STi side view mirrors on my Forester. The Forester and WRX share practically everything for the most part. The mirror may even mount up without having to swap bases, but I won't know that until I can get some time to take apart the doors after the holiday weekend. I've read all 25 pages on 3gwrx.com, but I still have some questions. I'm more of a visual person, so reading what people wrote is different than seeing pics for everything.

My Forester has the 8-pin plugs, but the mirrors have the 10-pin plugs. So, I know I have to remove the 8-pin plug from the mirrors ends of my Forester mirrors and swap them onto the STi mirrors. Right now, it appears to only use three wires which I guess is to control the mirrors. I'm assuming two wires for the signal and two wires for heat for a total of 7. I believe there are 5 wires on the door side harness. What would be the best way to wire these up and make use of all functionality? Wire the signals into the harness and run separate wires through the door grommets for heat? Or the other way around and wire the heated mirrors into the harness and run separate wires for the signals? Ideally, I'd like to plug everything into the harness, but I think I would need the correct terminals to plug into the harnesses on both ends and still have to run wires through the door, correct? Are the terminals the same for the stereo? Can I can buy a aftermarket stereo harness and pull the terminals from that?

Thanks.
max6spd is offline   Reply With Quote
Old 07-01-2013, 01:22 PM   #66
max6spd
Scooby Specialist
 
Member#: 151670
Join Date: Jun 2007
Chapter/Region: Tri-State
Vehicle:
2009 Forester
Satin White Pearl

Default

Conceivably, since I have an extra two wires at the door harness, I can use them for the heat and signal + wires and just ground the heat and signal - wires using a ring terminal attached to one of the mounting bolts?
max6spd is offline   Reply With Quote
Old 07-01-2013, 09:40 PM   #67
Power6
NASIOC Supporter
 
Member#: 72730
Join Date: Oct 2004
Chapter/Region: NESIC
Location: Wayland, MA
Vehicle:
2001 Lexus ES300,
2005 Outback XT

Default

max6spd, you can conceivably do what you are saying. There are a lot of variables but I can help you through. If you have 5 wires on the door side mirror plug can you post a pic or tell me which pins are populated? Use the "base" map below for pinout numbers, that is looking into the terminals of the mirror plug on the door harness.



That helps us figure out what those wires support. This is important because not every wire goes all the way through to the door, for example if it is the signal wires, the ground for that is tied inside the harness to other ground wires, it is not a wire that goes all the way through you can use for any function.

Based on your report of 5 wires the Forester is different from the Impreza which would have 7 wires to support JDM folding on a base (no heat) car.

Are you looking to put the smaller Impreza/STI mirrors on your Forester? I don't believe that is going to work, the "triangle" base mount is almost surely different, and the interface to the mirror is definitely not the same, you can't bolt the STI mirror unit to it. All you can use is the wiring and signal units from the STI mirror. You'd have to get new/used Forester mirror covers with the cutout for the signal.
Power6 is offline   Reply With Quote
Old 07-02-2013, 10:38 AM   #68
max6spd
Scooby Specialist
 
Member#: 151670
Join Date: Jun 2007
Chapter/Region: Tri-State
Vehicle:
2009 Forester
Satin White Pearl

Default

Ugh, don't say that. I was hoping that wouldn't be the case. I had hoped they would bolt up, and if they didn't, I could swap the STi mirrors onto the Forester bases. I guess I can resell them and get signals and Forester specific covers.

In any case, I'll take pics just so we can document them.
max6spd is offline   Reply With Quote
Old 08-21-2013, 07:11 PM   #69
dan2510
Scooby Newbie
 
Member#: 305615
Join Date: Jan 2012
Location: IL
Vehicle:
2013 WRX Limited Sdn
SWP

Default

I want to do this ASAP on my car. I have a 2013 WRX Limited with heated mirrors...so do I just need the mirror caps and signals as mentioned in post 1 of this thread? Or do I need to buy the entire mirror assy from subaru and the mirror caps?
dan2510 is offline   Reply With Quote
Old 08-22-2013, 05:28 PM   #70
Nukem
Scooby Newbie
 
Member#: 303705
Join Date: Dec 2011
Chapter/Region: MAIC
Location: Norfolk
Default

I have a set of painted sti mirror caps and leds I will sell for cheap if anyone's interested.
Nukem is offline   Reply With Quote
Old 08-22-2013, 05:37 PM   #71
KreparAZ
Scooby Newbie
 
Member#: 326853
Join Date: Jul 2012
Chapter/Region: SWIC
Vehicle:
2012 WRX
Satin White Pearl

Default

What color caps?
KreparAZ is offline   Reply With Quote
Old 08-22-2013, 10:32 PM   #72
GSXpress
Scooby Newbie
 
Member#: 95825
Join Date: Sep 2005
Chapter/Region: BAIC
Location: NoVA
Vehicle:
2011 WRX Hatch
SWP

Default

Quote:
Originally Posted by KreparAZ View Post
What color caps?
He replied in a PM that they were WRB.
GSXpress is offline   Reply With Quote
Old 08-24-2013, 02:04 AM   #73
impreza_pnw
Scooby Newbie
 
Member#: 333742
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2010 Impreza 2.5i
Newport Blue Pearl

Default works for 2.5i premium too

I got around to installing turn signal lamps into my 2010 2.5i Premium mirrors a few weeks ago. Thanks for all the info, it made everything super easy. My door harnesses were pre-wired for turn signals so I only had to touch the mirrors. The cheapest quote I got to have the mirror caps painted was $100, but I paid $125 at a body shop in my neighborhood because they had better service. I took a quick picture, it was too dark though.



I also found two places to buy the sealed connectors that plug into the lamps (84401AG052, 84401AG042). Each came with the connector, two terminals, and two plugs to seal the connector. I bought mine from auc-hi-1000 because they also had terminals that worked in the door harness connectors. Shipping was really fast (less than a week from Japan to Seattle) and everything came individually bagged. I'm happy everything is basically OEM and I won't have to worry about loose connections or terminal corrosion.

Sumitomo MT at Eastern Beaver, second one down

Sumitomo MT at auc-hi-1000 shop on Rakuten

Door harness terminals at auc-hi-1000 shop on Rakuten


Last edited by impreza_pnw; 08-24-2013 at 02:14 AM.
impreza_pnw is offline   Reply With Quote
Old 08-26-2013, 06:20 PM   #74
m71owner
Scooby Newbie
 
Member#: 332321
Join Date: Sep 2012
Location: grand rapids mi
Vehicle:
1998 2.5rs
wrb

Default

ok im thinking about doing this but if i do i want to switch my non heated wrx mirrors to a heated sti mirror with the turn signals. ive read through these post and got the jist of everything but i dont think any one has done this yet. what all would i have to do to make this happen aside from buying the equipment? thanks everyone.
m71owner is online now   Reply With Quote
Old 08-26-2013, 07:28 PM   #75
Nukem
Scooby Newbie
 
Member#: 303705
Join Date: Dec 2011
Chapter/Region: MAIC
Location: Norfolk
Default

Sorry for not replying on here. My mirror caps are still for sale with the LEDs. They are WRB. I Can have them painted for cheap, too. LET ME KNOW just trying to help out some fellow enthusiasts. Don't mean to promote too much of my for sale stuff.
Nukem is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 sti sway bars on a 03 wrx??? cibon7 Brakes, Steering & Suspension 1 01-17-2010 02:17 PM
08+ STi mirrors on WRX and base model. No_Brakes23 Interior & Exterior Modification 2 08-07-2009 09:17 PM
08 STI suspension fit on 08 WRX? Caobay Brakes, Steering & Suspension 5 04-17-2009 08:08 AM
08 sti mirrors on 08 WRX??? digital-monk1 Impreza Forum 3 09-14-2008 07:34 AM
08 sti mirrors on 08 WRX??? digital-monk1 Interior & Exterior Modification 2 08-21-2008 05:24 PM


All times are GMT -4. The time now is 10:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.