Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-22-2010, 10:27 AM   #1
MJBrowny21
Scooby Newbie
 
Member#: 48000
Join Date: Nov 2003
Chapter/Region: Tri-State
Location: Rochester, Ny
Vehicle:
2002 Impreza WRX
WRB

Default Reverse lights dont turn on

so I noticed my reverse lights dont turn on when I'm in reverse. By looking at threads I'm assuming this looks like it can be solved by replacing the reverse light switch. Anybody ever done this before themselves? Easy install?

Thanks,
Mike
* Registered users of the site do not see these ads.
MJBrowny21 is offline   Reply With Quote
Old 03-22-2010, 11:51 AM   #2
kpluiten
Scooby Guru
 
Member#: 120273
Join Date: Jul 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
06 WRBWRXWGN
Now with 100% more Spec-C

Default

Quote:
Originally Posted by MJBrowny21 View Post
so I noticed my reverse lights dont turn on when I'm in reverse. By looking at threads I'm assuming this looks like it can be solved by replacing the reverse light switch. Anybody ever done this before themselves? Easy install?

Thanks,
Mike

First think I'd do is get the 2002 WRX wiring manual (service manual) and use it to check the reverse position sensor signal at the connector by the pitch stop mount. If it's faulty, you know it's a defect either on the harness on the trans or with the sensor its self. From there move down and look for any thing obvious (broken wires or disconnected plug). Next, test the signal at the connector between the sensor and the trans harness.

I can't remember if it shows open or closed when the car is in reverse. Eitherway, you should see a change in state when the car is in 1 thru 5 or neutral vs reverse. The service manual tells you what it's supposed to read.

I've had one of these sensors fail. It really is easy to replace on the 5MT (the 6MT is pretty easy too). It is literally as simmple as disconnecting a connector and then using a single wrench to uncrew the sensor from the case. Remove, replace, job done.
kpluiten is offline   Reply With Quote
Old 03-22-2010, 11:53 AM   #3
gingertooth
Scooby Guru
 
Member#: 82242
Join Date: Mar 2005
Chapter/Region: Tri-State
Location: west milford, NJ
Vehicle:
2005 wrx wagon
wooh wooh!!!!!

Default

did you mess with the switches prior to this happening or anything else?
gingertooth is offline   Reply With Quote
Old 03-22-2010, 12:26 PM   #4
ProdriveDreams
Scooby Specialist
 
Member#: 146819
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Boston / Ipswich, MA
Vehicle:
'02 WRB VF-39'd WRX
W/06 STi Drivetrain swap

Default

did you check to make sure the bulbs didn't just die??

Before you get more intense do that because it's easy and common
ProdriveDreams is offline   Reply With Quote
Old 03-22-2010, 01:09 PM   #5
MJBrowny21
Scooby Newbie
 
Member#: 48000
Join Date: Nov 2003
Chapter/Region: Tri-State
Location: Rochester, Ny
Vehicle:
2002 Impreza WRX
WRB

Default

Thanks for the input. I have not messed with any wires prior to this. I didnt test the bulbs either thinking what are the chances that both went out.
MJBrowny21 is offline   Reply With Quote
Old 03-22-2010, 05:14 PM   #6
scoobdude
Scooby Specialist
 
Member#: 50699
Join Date: Dec 2003
Chapter/Region: TXIC
Location: austin
Vehicle:
2004 WRX
Platinum Silver

Default

Quote:
Originally Posted by MJBrowny21 View Post
Thanks for the input. I have not messed with any wires prior to this. I didnt test the bulbs either thinking what are the chances that both went out.
I had all 4 brake lights go out on an older car. Parking lights still worked though. Do no doubt. And follow the cheapest path first
scoobdude is offline   Reply With Quote
Old 03-22-2010, 05:25 PM   #7
jeksone
Scooby Newbie
 
Member#: 241915
Join Date: Mar 2010
Default

Quote:
Originally Posted by MJBrowny21 View Post
so I noticed my reverse lights dont turn on when I'm in reverse. By looking at threads I'm assuming this looks like it can be solved by replacing the reverse light switch. Anybody ever done this before themselves? Easy install?

Thanks,
Mike

I'm sure its been said but, bulbs go out.
also if you put the bulbs in backwards.
An maybe just maybe racer x came by in his evo and stipped a wire just to mess with you.

^_^
jeksone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control lights dont turn on. scoobynoobEMT Electrical & Lighting 4 02-04-2010 10:58 AM
Reverse Lights Not Turning On...Fuse is Fine. XanRules Electrical & Lighting 3 05-18-2009 12:24 AM
Reverse light dont work and CEL's Twiztidunreal Electrical & Lighting 1 08-06-2008 12:50 PM
reverse lights won't turn off. asherbo Vancouver Impreza Club Forum -- VIC 8 02-24-2007 02:07 PM
Reverse Lights Dont Turn On - Help michyous Legacy Forum 5 04-16-2005 10:54 PM


All times are GMT -4. The time now is 10:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.