Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-22-2010, 07:19 PM   #1
speedymaker
Scooby Specialist
 
Member#: 162070
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Evansville, IN
Vehicle:
2005 VF48 wrx wagon
WRB

Default Fuel pump continously priming on swap

So I swapped a 2005 wrx engine into my 05 rs....car runs fine, even just upgraded to a bigger turbo, only one problem

The fuel pump always primes, it should prime for a few seconds then shut off, so something is wrong. I put in a wahlbro 255 pump so I know its strong enough to get fuel pressure. Is this a big deal, because Im sure is shortening the life of the pump. I wired in the fuel pump controller following the FSM so it should be correct. Not throwing any codes whatsoever, so who can help?
* Registered users of the site do not see these ads.
speedymaker is offline   Reply With Quote
Old 03-22-2010, 08:20 PM   #2
davis10
Scooby Specialist
 
Member#: 70011
Join Date: Sep 2004
Chapter/Region: NESIC
Location: Bozeman, MT
Default

You should double check the wiring to the fuel pump controller.
davis10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Wont Start... Fuel Pump Not Priming... Any Ideas? dug-e-fresh Factory 2.0L Turbo Powertrain 10 08-09-2011 03:35 PM
Fuel Pump not coming on... SikSilvrSuby Factory 2.0L Turbo Powertrain 8 08-17-2010 06:27 PM
Fuel Pump wont prime!! 02ej257 Factory 2.0L Turbo Powertrain 2 12-08-2006 03:45 PM
Fuel Pump not priming ** prodriveuk Newbies & FAQs 3 04-15-2006 01:13 PM
fuel pump not priming/ecu not on? attitude Engine Management & Tuning 16 06-24-2005 12:16 PM


All times are GMT -4. The time now is 07:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.