Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-25-2010, 07:08 PM   #1
felya589
Scooby Newbie
 
Member#: 201073
Join Date: Jan 2009
Chapter/Region: Tri-State
Vehicle:
2012 WRX STI

Default 09-10 wrx abs,traction,hill assist lights

For anyone that has had these three lights come on it's 99.99% the brake light switch. I read about another 10 wrx on nasioc having the same issue.

My story:

I took it once to the dealer and they cleared some codes. Also said to come back if the lights came back on. I took it to the dealer again today since the lights came back on Monday, they diagnosed the problem as a brake light switch and said they'll call me when the part came in. I leave the dealership and something about the brakes seems funny to me as though they are really stiff. I realize 2 min into the drive home that the brake pedal isn't coming up and the brakes are locked, meaning I'm riding my brakes. I stop the car and try to get it moving but i can't because it's like the e-brake is pulled only all four brakes. the tech drives over fixes w/e he broke(claims he didn't put the senor/switch in correctly so the computer didn't to let the brakes go. I come home and realize my brake lights aren't turning off. Car is at the dealer now should get fixed tomorrow he said. Stupid Dealership, i told them the first time it was a brake sensor or switch and they seemed to brush what i said off and said it was nothing.
* Registered users of the site do not see these ads.
felya589 is offline   Reply With Quote
Old 03-25-2010, 08:32 PM   #2
etothen
Scooby Specialist
 
Member#: 221885
Join Date: Aug 2009
Chapter/Region: NWIC
Location: Portland
Vehicle:
09 Ivory Tower
Ivory...duh

Default

be suspicious of their fix, at this point it is possible you will need rotors and pads too, cant be sure from here, but entirely possible.
etothen is offline   Reply With Quote
Old 03-25-2010, 10:57 PM   #3
charlokim
Scooby Newbie
 
Member#: 227018
Join Date: Oct 2009
Chapter/Region: Tri-State
Location: POK, NY
Vehicle:
2008 WRX Stage 1
pearl white

Default

Mine started 5 hours after I got my car (it was used). I'm not sure if its the same problem but all of those things were affected. Turns out it was a huge number of issues with the sensors and the ABS hydraulic system and controller were out of sync. It took the dealer around 2 months to fix. They had absolutely NO idea what it was. They had a mechanic from Japan come and look at it. If you wanna find out call up MidHudson Subaru in upstate NY and mention Charles and his 2008 WRX Hatch to see if its the same problem.

They know me.................and this problem.....................g'luck to you. Let me know if I can help.
charlokim is offline   Reply With Quote
Old 03-26-2010, 06:53 PM   #4
felya589
Scooby Newbie
 
Member#: 201073
Join Date: Jan 2009
Chapter/Region: Tri-State
Vehicle:
2012 WRX STI

Default

thanks, I'm getting her back today. Hopefully everything is OK, but if not I'll be giving Midhudson a call and seeing if they can give me more info, Thanks
felya589 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
09 WRX-VDC, ABS, and Hill Assist Warning Lights Subirex09 Warranty Issues & SOA Problems 44 06-19-2013 04:53 PM
WTB 08-10 sti springs or 09-10 wrx springs TwinRider MWSOC Private Classifieds 0 05-14-2010 08:31 PM
FS:(Irvine) Invidia Catted Downpipe 08/09/10 WRX/STI's and 05-09 Legecy GT's ntbass SCIC Private Classifieds 0 11-05-2009 02:40 PM
FS: 08/09/10 WRX (LGT and 09+FXT) Perrin Recirc (BOV) Black, $100 shipped method Engine/Power/Exhaust 4 09-18-2009 11:50 AM
DCCD flashing, VDC & Hill assist lights on?!?! Suberman Transmission (AT/MT) & Driveline 13 01-21-2009 04:46 PM


All times are GMT -4. The time now is 08:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.