Welcome to the North American Subaru Impreza Owners Club Sunday February 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-31-2010, 05:45 PM   #1
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default rain causing cel and maf problem

At first it just became a problem when i went thru a carwash but now it occurs when it rains as well. I have a fender liner so now i had to find out where the water is coming in and getting my filter wet thus creating a problem under boost. So here are some pics. The holes are not big but i hope after using some safe silicone to seal them off the problem will not come back.

Ok how do i upload pics without using an url...you know upload them from my pc?
* Registered users of the site do not see these ads.
djc1827 is offline   Reply With Quote
Old 03-31-2010, 07:11 PM   #2
oguitar
Scooby Specialist
 
Member#: 206720
Join Date: Mar 2009
Chapter/Region: SWIC
Location: Albuquerque NM
Vehicle:
2002 WRX Wagon
Silver

Default

You can't directly upload from your CPU. You need to upload to a website like photobucket. Once you have uploaded your image there you can copy and paste its image code.

What filter is getting wet? Your air filter is what I am guessing. Is it a stock airbox or CAI/SRI?
oguitar is offline   Reply With Quote
Old 03-31-2010, 09:42 PM   #3
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default

ks tech cold air, it goes down in the wheel well but there are a few holes around it about 1/2 inch where water is dripping down onto the filter. I bought some foam sealer stuff i think im gonna fill in the gaps, wont look pretty but will do the job. You know the stuff that expands like 30%. I cant believe you have to load pics that way...pretty lame. I am not gonna sign up for photo bucket. What does nasioc have a contract with them? Wouldnt surprise me
djc1827 is offline   Reply With Quote
Old 04-01-2010, 12:48 AM   #4
oguitar
Scooby Specialist
 
Member#: 206720
Join Date: Mar 2009
Chapter/Region: SWIC
Location: Albuquerque NM
Vehicle:
2002 WRX Wagon
Silver

Default

There are other sites you can use. I just mentioned photo bucket because that is what I use. Don't try to fight the system here. Just go with the flow. Stick to the newbie forums until you get the feel of how this site works. IMHO.
oguitar is offline   Reply With Quote
Old 04-01-2010, 11:20 AM   #5
Pearl04
Scooby Newbie
 
Member#: 178913
Join Date: May 2008
Chapter/Region: RMIC
Location: Logan, UT
Vehicle:
06 STI
WRB

Default

You should get black silecone. I don't know how to spell that. It's simple and would make less of a mess in my opinion. You could make it look pretty nice.

I'm about to put an intake in my fender and would like to see some pics of yours where it's leaking. Go sign up for photobucket. When you sell stuff it makes it easy to post in multiple forums, plus when you are away from home you can still access your pics. Do it.
Pearl04 is offline   Reply With Quote
Old 04-01-2010, 09:57 PM   #6
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default

djc1827 is offline   Reply With Quote
Old 04-01-2010, 09:58 PM   #7
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default

Im guessing some water is dripping thru this hole



djc1827 is offline   Reply With Quote
Old 04-02-2010, 12:00 AM   #8
scby rex
Scooby Guru
 
Member#: 104878
Join Date: Jan 2006
Chapter/Region: TXIC
Location: copperas cove
Vehicle:
02 wrxbastardchild
aw, MPS 2.34 breaking in

Default

change the filter to a k&n, you dont think water gets in between the hood and fender and that huge hole in your hood?
scby rex is offline   Reply With Quote
Old 04-02-2010, 12:02 AM   #9
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default

I bought the aem filter because the k&n must be cleaned with oil and that oil can cause maf problems as well. I will just block off all possibilities of water seeping thru and problem solved
djc1827 is offline   Reply With Quote
Old 04-02-2010, 12:21 AM   #10
xBroncox
Scooby Newbie
 
Member#: 236790
Join Date: Jan 2010
Chapter/Region: NESIC
Location: CT.
Vehicle:
2003 wrx
yellow

Default

I has simular problems with my wrx thought that a coil pack was cracked or bad wire connection.It only had problem in rain mostly boost issues the car came to me with a aem shorty took it out just because it was not tuned for it and now my rain problem is no longer.i started to think it was a general humidity problem mixed with untuned intake but the aem was fine when it was dry out just seemed to cause uneven idle.now i am happy again car runs much better with stock intake
xBroncox is offline   Reply With Quote
Old 04-03-2010, 06:08 PM   #11
djc1827
Scooby Specialist
 
Member#: 238618
Join Date: Feb 2010
Location: 11.82 on vf52 w street tires
Vehicle:
2011 WRX
455whp/480tq 2.5xt-r

Default

Nothing a little water proof tape didnt take care of.....lol
djc1827 is offline   Reply With Quote
Old 04-04-2010, 11:56 AM   #12
scby rex
Scooby Guru
 
Member#: 104878
Join Date: Jan 2006
Chapter/Region: TXIC
Location: copperas cove
Vehicle:
02 wrxbastardchild
aw, MPS 2.34 breaking in

Default

Quote:
Originally Posted by djc1827 View Post
I bought the aem filter because the k&n must be cleaned with oil and that oil can cause maf problems as well. I will just block off all possibilities of water seeping thru and problem solved
your oiling it way to much then. it takes very little oil. So your going to make a air tight box for your air intake? water can get almost anywhere air can so you going back to the stock air box?
scby rex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 06-05-2010 08:26 PM
1999 Subaru CEL and Stalling Problem vancarlson Service & Maintenance 1 10-24-2006 04:11 PM
02-03 Brake Differences Causing Me and AndrewTech Problems HELP plz theziggurat Brakes, Steering & Suspension 1 08-02-2005 11:53 AM
Maf problem...Cels car wont start... bottlediger Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 9 06-27-2005 09:37 PM
Catted downpipe and 3rd cat eliminator pipe cause cel? dman918 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 02-13-2002 03:39 AM


All times are GMT -4. The time now is 03:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.