Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-11-2010, 07:26 PM   #451
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

* Registered users of the site do not see these ads.
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 07:52 PM   #452
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

Is the turbo oil cooled only? Just wondering why you kept the upper coolant reservoir?
jasv11 is offline   Reply With Quote
Old 08-11-2010, 08:08 PM   #453
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

Quote:
Originally Posted by jasv11 View Post
Is the turbo oil cooled only? Just wondering why you kept the upper coolant reservoir?
Correct only oil cooled we chose not
To remove it..
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 08:16 PM   #454
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

wow I can not believe you guys cheaped out and did not put t-clamps on the intercooler piping especially on the throttle body.Thats just a blow off waiting to happen.
john 1badSTI is offline   Reply With Quote
Old 08-11-2010, 08:20 PM   #455
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

Quote:
Originally Posted by OVeRBOOSTn View Post
Correct only oil cooled we chose not
To remove it..
OK cool I though you might of had another reason for keeping it that I didnt think of.
jasv11 is offline   Reply With Quote
Old 08-11-2010, 08:22 PM   #456
jasv11
Scooby Specialist
 
Member#: 117862
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: INNOVATIVE TUNING
Vehicle:
2006 STi 10.85@129.4
96 impreza 9.55e.t.146mph

Default

Quote:
Originally Posted by john 1badSTI View Post
wow I can not believe you guys cheaped out and did not put t-clamps on the intercooler piping especially on the throttle body.Thats just a blow off waiting to happen.
My UR kit came with screw clamps and have been holding great for 3 years(only 28psi of boost though)
jasv11 is offline   Reply With Quote
Old 08-11-2010, 08:29 PM   #457
Precision Tuning
Former Vendor
 
Member#: 38696
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: Lakewood, NJ
Vehicle:
2002 WRX
White

Default

Looking good Stu. Congrats. Can't wait to see it run.

Rich
Precision Tuning is offline   Reply With Quote
Old 08-11-2010, 08:29 PM   #458
Junior2JZ
Scooby Guru
 
Member#: 64908
Join Date: Jun 2004
Chapter/Region: Tri-State
Location: Tuning 8/9sec Subies @ P&L
Vehicle:
10.8 XT+10.0@143 GR+
2x9.0@170mph GTRs

Default

Quote:
Originally Posted by john 1badSTI View Post
wow I can not believe you guys cheaped out and did not put t-clamps on the intercooler piping especially on the throttle body.Thats just a blow off waiting to happen.
Only time we use Tbolts is on SS piping, cast Aluminum (compressor housing) or very tight bends were we cant make a proper bead on the pipe. We never run Tbolts on aluminum IC pipes, especially when you make nice bead rolls on them. T-Bolts + aluminum IC pipes = it just bends pipes and makes more boost leaks. To put in in perspective we run about 65psi with a 42r and run those same clamps.. They are also not normal ghetto clamps.

Jr
Junior2JZ is offline   Reply With Quote
Old 08-11-2010, 08:49 PM   #459
xdrian
Scooby Specialist
 
Member#: 104200
Join Date: Jan 2006
Chapter/Region: Tri-State
Location: Metuchen NJ
Vehicle:
828 WHP BUGEYE
Street Proven Performance

Default

Quote:
Originally Posted by john 1badSTI View Post
wow I can not believe you guys cheaped out and did not put t-clamps on the intercooler piping especially on the throttle body.Thats just a blow off waiting to happen.
those are porsche style clamps
xdrian is offline   Reply With Quote
Old 08-11-2010, 08:52 PM   #460
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

cool I always have ran t-clamps and have never bent or deformed a pipe or had a boost leak but if those clamps work for you guys thats fine.
john 1badSTI is offline   Reply With Quote
Old 08-11-2010, 08:59 PM   #461
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

Quote:
Originally Posted by Junior2JZ View Post
Only time we use Tbolts is on SS piping, cast Aluminum (compressor housing) or very tight bends were we cant make a proper bead on the pipe. We never run Tbolts on aluminum IC pipes, especially when you make nice bead rolls on them. T-Bolts + aluminum IC pipes = it just bends pipes and makes more boost leaks. To put in in perspective we run about 65psi with a 42r and run those same clamps.. They are also not normal ghetto clamps.

Jr
oh and I tried to call you today jr and got sent to your voicemail but could not leave a message because you box is full. j schroeck
john 1badSTI is offline   Reply With Quote
Old 08-11-2010, 09:17 PM   #462
Junior2JZ
Scooby Guru
 
Member#: 64908
Join Date: Jun 2004
Chapter/Region: Tri-State
Location: Tuning 8/9sec Subies @ P&L
Vehicle:
10.8 XT+10.0@143 GR+
2x9.0@170mph GTRs

Default

Quote:
Originally Posted by john 1badSTI View Post
oh and I tried to call you today jr and got sent to your voicemail but could not leave a message because you box is full. j schroeck

Funny story, I did my Droid 2.2 Legit upgrade today and it bricked my phone... Thanks Verizon!! They couldnt fix it and had none in stock so they "ordered" me one. Lucky for me Xdrian is not only a master tech, but the mofo can do some serious cell phone programming! Fixed my phone and got me on a sick 2.2 "aftermarket" software.. Kid is talented.. and he is a model

Jr
Junior2JZ is offline   Reply With Quote
Old 08-11-2010, 09:19 PM   #463
john 1badSTI
Scooby Specialist
 
Member#: 77470
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: grove city ohio
Vehicle:
04 sti 10.51@138.5
on e85@ 30psi--spinning

Default

thats funny I will try to call you tomorrow ok.
john 1badSTI is offline   Reply With Quote
Old 08-11-2010, 09:37 PM   #464
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

some guy with a lexus is-F just called me out to race him for 2 grand...
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 09:40 PM   #465
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

Quote:
Originally Posted by Precision Tuning View Post
Looking good Stu. Congrats. Can't wait to see it run.

Rich

Thanks Rich, i got to swing by one day and hang out. WE NEED ANOTHER TRACK RENTAL!

-Stu
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 10:05 PM   #466
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default


video 642whp@23psi pull w. the fuel pump going bad..
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 10:46 PM   #467
CKxx
Scooby Specialist
 
Member#: 33458
Join Date: Feb 2003
Chapter/Region: Tri-State
Location: PA
Vehicle:
Your BOV sounds lame
93 RX7+09 Forester

Default

Quote:
Originally Posted by OVeRBOOSTn View Post
YouTube- OVeRBooSTn's DRAG STi DYNO PULL

video 642whp@23psi pull w. the fuel pump going bad..
CKxx is offline   Reply With Quote
Old 08-11-2010, 10:53 PM   #468
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

lol well correction 25psi tappering to 23psi
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 11:19 PM   #469
maxpowr
Scooby Guru
 
Member#: 159243
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: medford nj 08055
Vehicle:
sg3 Turbo Tek Tuned
Hakt Ecu e85 30r 6spd

Default

sharing is caring, stu!
maxpowr is offline   Reply With Quote
Old 08-11-2010, 11:44 PM   #470
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

Quote:
Originally Posted by maxpowr View Post
sharing is caring, stu!
Lol you can borrow some hp 520whp was alot for the street I cracked this thing once in 2nd gear and I'll never do it again on stock bald potenzas lmfaooo
OVeRBOOSTn is offline   Reply With Quote
Old 08-11-2010, 11:45 PM   #471
02WRX2.5
Scooby Specialist
 
Member#: 63192
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Portland, Or
Vehicle:
02 wrx
157mph trap

Default

How many Miles on this motor? Looks as tho your rings have not seated yet, quite a bit of smoke. Turbo sounds great.
02WRX2.5 is offline   Reply With Quote
Old 08-11-2010, 11:52 PM   #472
maxpowr
Scooby Guru
 
Member#: 159243
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: medford nj 08055
Vehicle:
sg3 Turbo Tek Tuned
Hakt Ecu e85 30r 6spd

Default

i'm going for 400/400 and i am skeerred at that. 340whp was pretty fast to me...well from red light to red light. i haven't sold myself short, i may see 500/500 someday...with a proper intake like you got!

be careful with that thing! things come up fast while sidways.
maxpowr is offline   Reply With Quote
Old 08-12-2010, 01:46 AM   #473
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

Quote:
Originally Posted by 02WRX2.5 View Post
How many Miles on this motor? Looks as tho your rings have not seated yet, quite a bit of smoke. Turbo sounds great.

miles on the motor were umm idling for an hour and then on the dyno lol.. actually it stopped smoking now after about 100miles
OVeRBOOSTn is offline   Reply With Quote
Old 08-12-2010, 01:48 AM   #474
OVeRBOOSTn
Scooby Specialist
 
Member#: 192514
Join Date: Oct 2008
Chapter/Region: Tri-State
Location: TURBOTRIX Racing
Vehicle:
04 STi PTE6765
10.1@138mph / JR Tuned

Default

Quote:
Originally Posted by maxpowr View Post
i'm going for 400/400 and i am skeerred at that. 340whp was pretty fast to me...well from red light to red light. i haven't sold myself short, i may see 500/500 someday...with a proper intake like you got!

be careful with that thing! things come up fast while sidways.
yeah dude 400whp is plenty i loved my car at 475whp it was prob the most i enjoyed the car.. although at 500whp it was even better lol.. once i hit 520whp it was a lil redonkulous lol
OVeRBOOSTn is offline   Reply With Quote
Old 08-12-2010, 10:17 AM   #475
maxpowr
Scooby Guru
 
Member#: 159243
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: medford nj 08055
Vehicle:
sg3 Turbo Tek Tuned
Hakt Ecu e85 30r 6spd

Default

i'm amazed you can still feel a difference between 475 and 520. wow. good stuff. again congrats to you and your crew.

my build blew up on start up...i was so close. i'm now at the mercy of the headshop and a beater.

more hdvideo! get some xdrian!
maxpowr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JR Tuned / THESHOPCT Built - OVeRBOOSTn's 500whp PUMPGAS STi! OVeRBOOSTn Proven Power Bragging 185 09-01-2011 05:18 PM
BUILTSTI... JR tuned, built motor, VF39 set to kill on 100 octane + METH BUILTSTI Proven Power Bragging 172 11-02-2009 11:56 PM
The SHOP + JR TUNE 2006 STI + HTA86 goes 10.43 @ 135.86 Junior2JZ Proven Power Bragging 210 10-31-2009 05:05 PM
THE SHOP built JR TUNED 06 STI 11.4@122 Pumpgas Junior2JZ Proven Power Bragging 14 05-02-2008 12:12 PM
05 STi tuned at TurboTrix Racing Timmy Burns Proven Power Bragging 41 11-11-2005 06:38 PM


All times are GMT -4. The time now is 06:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.