Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-12-2010, 02:39 AM   #1
Alpental
Scooby Newbie
 
Member#: 226044
Join Date: Oct 2009
Chapter/Region: NWIC
Location: Issaquah, WA
Vehicle:
2004 WRX
Aspen White

Default 98 Impreza Wagon Can anyone help me diagnose Check Engine Code P103 Bank 1 Sensor 2

My check engine light has been on, finally got a code out of it, P103 Sensor Malfunction, Bank 1 Sensor 2. All I can find by Google is Oxygen sensor. The motor acts weird but still drives. Between 2,300-2,500 RPM's it cuts out a bit then kicks back in normal above 2,500 r's. Do you know if this can cause damage in driving the car until I am able to repair it, hope not gotta go to work - daily driver. Does anybody know how difficult it would be to fix this or if this is a common problem. Motor has 158k, please share if you will. Thanks
* Registered users of the site do not see these ads.
Alpental is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light code P0137 o2 sensor circuit low voltage bank 1 sensor 2 duque Engine Management & Tuning 1 05-09-2010 01:43 AM
Can anyone help me diagnose? damonmlime Normally Aspirated with bolt-on Forced Induction Powertrain 3 08-25-2006 12:26 PM
can anyone help me with these CEL codes? maddbmxjumper Subaru Conversions 1 06-09-2006 11:19 PM
Can anyone help me pull a CEL CODE?? Ill treat you to dinner and candy!! Silver on Blacks Southern California Impreza Club Forum -- SCIC 10 10-31-2005 06:55 PM
Help me diagnose my engine problem! imprezive one Factory 2.0L Turbo Powertrain 3 08-27-2003 10:42 AM


All times are GMT -4. The time now is 01:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.