Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-13-2010, 08:51 PM   #1
Nathan Explosion
Scooby Newbie
 
Member#: 215525
Join Date: Jun 2009
Vehicle:
2006 WRX Wagon
WRB

Default Slight smoke on idle with AC on

In about the last week or so my car has started slightly smoking at idle, but only when the AC compressor is on, and only after sitting for a while (5 or more minutes). I've read this is most likely a sign of failing seals in my TD04, but wanted some more opinions. The smoke is thin enough that it's hard to get a good gauge on the color, but I would lean more towards burning coolant than oil. The car is a 2006 WRX with 67000 miles, the last 2000 or so have been with an Invidia V3 and a Perrin "Stage 2" e-tune on my AP, the last 500 or so with a ebay giant TMIC, and probably about 8k before that with a Perrin "Stage 1" e-tune.

I plan on getting a compression and leakdown test done tomorrow to verify it's not the motor, is there anything else wise to rule out before I start looking for a VF series? Also planning on pulling the DP and looking for obvious signs of leakage within the turbo itself.
* Registered users of the site do not see these ads.
Nathan Explosion is offline   Reply With Quote
Old 04-13-2010, 09:22 PM   #2
hammyt
Scooby Specialist
 
Member#: 92585
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Chicagoland
Vehicle:
2005 Saab 9-2x Aero
13.6@100 EJ205 VF48 93Oct

Default

Check the TMIC for oil as well. Sounds like you are going a this properly.
hammyt is offline   Reply With Quote
Old 04-13-2010, 11:03 PM   #3
ktmrider
Scooby Specialist
 
Member#: 125687
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2005 Legacy GT - 6MT
Black

Default

Seen a bad PCV do that, how old is yours?
BTW if not aware get an OEM one if replacing, Framinators WILL fail and make a mess of your intake tract.
ktmrider is offline   Reply With Quote
Old 04-13-2010, 11:06 PM   #4
Nathan Explosion
Scooby Newbie
 
Member#: 215525
Join Date: Jun 2009
Vehicle:
2006 WRX Wagon
WRB

Default

Quote:
Originally Posted by ktmrider View Post
Seen a bad PCV do that, how old is yours?
BTW if not aware get an OEM one if replacing, Framinators WILL fail and make a mess of your intake tract.
It may still be original. I've only lived in a place where I can do my own work to the car for about six months, so everything was dealer scheduled maintenance before that. I'll definitely look into it when I get in there tomorrow.

Edit: was replaced at ~36k miles. Found the receipt. Will test/replace tomorrow.

Last edited by Nathan Explosion; 04-13-2010 at 11:12 PM.
Nathan Explosion is offline   Reply With Quote
Old 04-14-2010, 10:37 AM   #5
rockhound76
Scooby Newbie
 
Member#: 147103
Join Date: Apr 2007
Chapter/Region: TXIC
Location: Conroe, Texas
Vehicle:
2007 STI
Blue Pearl

Default

My wife's 08 Audi did that and it was crankcase ventilation. They seem to go out quickly these days.

I hope that is your problem. You are thinking about it in the right way.
rockhound76 is offline   Reply With Quote
Old 04-14-2010, 08:38 PM   #6
Nathan Explosion
Scooby Newbie
 
Member#: 215525
Join Date: Jun 2009
Vehicle:
2006 WRX Wagon
WRB

Default

After playing with the car a bit today, I got a good look at the smoke under proper light, and it looks alot bluer than I thought. Thinking it's probably a failed turbo seal based on tests, data, and a few outside opinions I got today.

Thanks for the help guys, I'll keep this thread updated with the exact solution when I find it.
Nathan Explosion is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hiccup @ idle w/ AC on... Kev5n24 Baja Forum 17 07-09-2007 12:13 PM
Surging/pulsing idle with AC on? Slalom RS Normally Aspirated Powertrain 8 09-11-2006 02:57 PM
Screeching with AC on trojan9x Normally Aspirated Powertrain 6 04-20-2002 12:21 PM
Humming noise with AC on. kkozma Legacy Forum 5 09-18-2001 03:59 PM


All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.