Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-14-2010, 05:59 PM   #1
d-ta
Scooby Specialist
 
Member#: 131302
Join Date: Nov 2006
Chapter/Region: SCIC
Location: 714
Vehicle:
02 WRX Wagon
WRBlue myself

Unhappy A/C is out. Need shop recommendations.

Hi everyone,

I'm a long-time lurker/first-time poster and in need of some recommendations for a shop to take a look at my a/c since summer is coming up. Here's the background on the situation:

- Bought the car in August of 08 and the a/c was working fine.
- By the beginning of 09, the a/c had stopped blowing cold, but I didn't really look into it at the time due to the weather still being cold.
- Come late spring, I checked the refrigerant level and it was low so I recharged it and it was blowing cold air again.
- About 2-3 months later, the a/c wasn't cold anymore so I re-checked the levels and it was low so I refilled it and went on my way. This recharge lasted a few days and went out on me.
- I attempted to recharge the system last October when I was moving back to Phoenix, but even after the recharge it would not blow cold.

The problem is when I push the a/c button, the light turns green and the clutch on the compressor engages, but there's no cold air. After checking the refrigerant level about a week ago, there is still refrigerant in the system (from the last recharge in October of 09), but it's not completely full. I'm pretty sure there's a small leak somewhere, but there are no major signs of a leak in the engine bay (oil on any of the a/c lines). At this point I'm pretty stumped and figure it's better off having a shop take a look at it so if you guys have any recommendations on where to take it, I'd really appreciate it.

Thanks!
* Registered users of the site do not see these ads.
d-ta is online now   Reply With Quote
Old 04-14-2010, 07:08 PM   #2
BoostInc
Scooby Newbie
 
Member#: 176520
Join Date: Apr 2008
Chapter/Region: SWIC
Location: NM
Vehicle:
1994 Legacy SS
black and mud

Default

Damaso at AZ air auto and tire in tempe. Greg from here use to work there. Dom knows quite a bit about AC and will take car of you.
BoostInc is offline   Reply With Quote
Old 04-15-2010, 01:03 AM   #3
thegreg
Scooby Specialist
 
Member#: 105429
Join Date: Jan 2006
Chapter/Region: SWIC
Location: az
Vehicle:
2004 WRX STi
PSM

Default

I am now at Arizona Auto Care 5235 S Kyrene #42. Just down the street from the old shop I was at. (not trying to steal business from my old shop, or Don)
480.820.2693
thegreg is offline   Reply With Quote
Old 04-15-2010, 02:52 AM   #4
dan az
Scooby Specialist
 
Member#: 120355
Join Date: Jul 2006
Chapter/Region: SWIC
Location: prescott valley, az
Vehicle:
2004 wrx wagon 2.5
20g-xt, super slow

Default

sounds like front seals on the compressor, im ase and macs certified if you need it fixed, only thing i dont have is a leak sniffer, usually dont need one anyway.
dan az is offline   Reply With Quote
Old 04-15-2010, 11:18 AM   #5
jdmstuff
Scooby Specialist
 
Member#: 56343
Join Date: Mar 2004
Chapter/Region: SWIC
Location: Dont Taze me Bro!
Vehicle:
02 S202 Really!
blue

Thumbs up

Quote:
Originally Posted by thegreg View Post
I am now at Arizona Auto Care 5235 S Kyrene #42. Just down the street from the old shop I was at. (not trying to steal business from my old shop, or Don)
480.820.2693
Let the guys at Az auto care fix it they know subarus and have great prices.
jdmstuff is offline   Reply With Quote
Old 04-15-2010, 11:52 AM   #6
sinisterex
Scooby Newbie
 
Member#: 74248
Join Date: Nov 2004
Default

thegreg took great care of me for a smokin price last summer when my AC took a dump!
sinisterex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Central Oregonians...need shop recommendation NatCh North West Impreza Club Forum -- NWIC 20 06-05-2008 03:17 PM
Got hit, need shop recommendation Kelvin622 Vancouver Impreza Club Forum -- VIC 7 11-20-2007 08:16 AM
Need shop recommendation in San Jose Area jonluude Bay Area Impreza Club Forum -- BAIC 7 06-02-2007 08:46 PM
Need shop recommendation RS_noob North West Impreza Club Forum -- NWIC 0 07-24-2006 10:16 PM
exhaust or intake leak help needed - shop recommendations? NETWRX Southern California Impreza Club Forum -- SCIC 3 06-02-2004 09:50 PM


All times are GMT -4. The time now is 12:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.