Welcome to the North American Subaru Impreza Owners Club Thursday January 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-23-2015, 04:38 PM   #1
AgentJ17
Scooby Newbie
 
Member#: 306411
Join Date: Jan 2012
Chapter/Region: VIC
Location: Duncan, BC
Vehicle:
1995 STi RA
very eg33 such braap

Default Looking for a spot to repair a car (Aldergrove)

Just thought I'd ask if there's someone on here living around the Aldergrove area that would let me get a car towed to their place so I can change waterpumps in the next few weeks. I found a car I want to pick up, to bring back to the island, that allegedly needs one and I'm gathering the guy doesn't want it repaired in his driveway. It really wouldn't take that much time between my friend and I. We would be gone the same day, if not, then the next.

Thanks!
* Registered users of the site do not see these ads.
AgentJ17 is offline   Reply With Quote
Old 01-23-2015, 06:03 PM   #2
yoall
Scooby Newbie
 
Member#: 227062
Join Date: Oct 2009
Location: Vancouver
Default

you looking at that white type RA?
yoall is offline   Reply With Quote
Old 01-23-2015, 10:42 PM   #3
AgentJ17
Scooby Newbie
 
Member#: 306411
Join Date: Jan 2012
Chapter/Region: VIC
Location: Duncan, BC
Vehicle:
1995 STi RA
very eg33 such braap

Default

Yeah. Someone messaged me on facebook about using the owner's shop after all. Not sure if that's you or not.
AgentJ17 is offline   Reply With Quote
Old 01-24-2015, 03:56 AM   #4
Mr_Furious
Scooby Newbie
 
Member#: 298713
Join Date: Oct 2011
Location: Vancouver, Canada
Vehicle:
1997 Impreza, Wagon
Blue

Default

I might be able to help if no one closer is available depending on which day your thinking about, but I'm in Mission.
but I saw this ad and I bet it's a stuck thermostat. Waterpumps don't really stop working unless the impeller fell off of the shaft. Usually a bad water pump leaks so I'd check the thermostat first. It might be the quickest / easiest repair you can do and probably do it at the guys house. and it that doesn't work tow it somewhere and change the waterpump
Mr_Furious is offline   Reply With Quote
Old 01-24-2015, 12:34 PM   #5
yoall
Scooby Newbie
 
Member#: 227062
Join Date: Oct 2009
Location: Vancouver
Default

Not me. I drove out to look at the car. I wanted it. But after driving it. The clutch felt like it needed to be replaced. So I passed. Good luck. Really good looking car for that price.

His friend also offered to tow it back to Vancouver for me for a gsr money.

Sent from my SGH-T889 using NASIOC mobile app
yoall is offline   Reply With Quote
Old 01-24-2015, 01:23 PM   #6
AgentJ17
Scooby Newbie
 
Member#: 306411
Join Date: Jan 2012
Chapter/Region: VIC
Location: Duncan, BC
Vehicle:
1995 STi RA
very eg33 such braap

Default

Quote:
Originally Posted by Mr_Furious View Post
I might be able to help if no one closer is available depending on which day your thinking about, but I'm in Mission.
but I saw this ad and I bet it's a stuck thermostat. Waterpumps don't really stop working unless the impeller fell off of the shaft. Usually a bad water pump leaks so I'd check the thermostat first. It might be the quickest / easiest repair you can do and probably do it at the guys house. and it that doesn't work tow it somewhere and change the waterpump
I have a feeling the waterpump was replaced with a Gates unit and I've been hearing about them failing recently (Impeller snaps off of shaft). I have a spare t-stat and water pump, so I'll try both things at once. Although the WP should be fairly obvious when I pull it. But if you have experience with this, I'd gladly appreciate the help. I'll post here again when I plan on coming over. The owner's friend contacted me and we've worked out a place to work on it.

Quote:
Originally Posted by yoall View Post
Not me. I drove out to look at the car. I wanted it. But after driving it. The clutch felt like it needed to be replaced. So I passed. Good luck. Really good looking car for that price.

His friend also offered to tow it back to Vancouver for me for a gsr money.

Sent from my SGH-T889 using NASIOC mobile app
Meh, a clutch doesn't really faze me. Thanks for the heads up though.
AgentJ17 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.