Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-16-2010, 03:06 PM   #1
toflaherty
Scooby Specialist
 
Member#: 212765
Join Date: May 2009
Chapter/Region: E. Canada
Location: Windsor, ON / Detroit, MI
Vehicle:
2003 WRX
PSM

Default 03 WRX bad cold start idle in closed loop / rich open loop fuelling

Hey everyone, I just built and installed a new ej205 in my 03 wrx and have some strange behaviour during the start, I was wondering if maybe someone could help me out.

First, all relevant engine mods..

BC +1mm intake/exhaust valves
Ported intake/exhaust ports
Shimless buckets
USDM STi TMIC
Hose Techniques TMIC hoses/t-bolt clamps
Gimmick Motorsports crank pulley
SPT Catback
Custom Shorty DP (stock 3rd cat, w/b in rear o2 position)
Grimmspeed Ceramic Uppipe
Ported exhaust manifolds
Ported crossover pipe
TGV deletes (including harness mod)
Walbro GSS342 255lph fuel pump
Perrin V2 fuel rails
Gimmick Motorsports turbo inlet hose
Gimmick Motorsports after MAF hose
Intake silencer snorkus delete
GM BCS

Engine is stock compression, stock turbo for now, stock airbox, stock injectors, i think that about covers it..

Anyway, car starts fine on the stock tune, but then proceeds to idle poorly the instant it goes closed loop, with wildly fluctuating AFR (aem w/b o2) from 10 to 18.4 (clipped out of range), and corresponding huge negative and huge positive a/f correction, and wildly fluctuating engine speed in tune with the AFR. After idling for a while the a/f learning #1 was maxed out at -14.99%. After the car is fully warmed up, the AFR is rock solid around 14.7-14.8 and the idle is perfect too.

Since I noticed the start was stable, but rich, until going closed loop, I unplugged the o2 sensor and did a cold start yesterday and the idle and AFR was rock solid, although very rich (around 11:1 AFR), so i think the o2 sensor is probably the cause, so i ordered another one. Hopefully that will arrive early next week and I can confirm that it is the reason of the fluctuating afr and engine speed when switching to closed loop on a cold start.

Also, the open loop fuelling is extremely rich in comparison to target afr. One thing I noticed is that stock injector scaling is 420 cc/min, but i had my injectors cleaned by deatschwerks and they also flowtested them to around 450 cc/min at 43.5 psi, so should i go ahead and make this change? That would help lean it out a little but probably not enough, so the only thing left after that would be MAF scaling.

Should i just keep increasing the injector scaling above the 450, if needed, to get the a/f learning near 0% at idle? not sure which to change, injector or maf, since they are both stock for the most part..

Any help would be appreciated, I couldn't seem to find any old threads with this specific problem, most of them are +15% a/f learning from a leak, but mine is negative, too rich...

-Tim
* Registered users of the site do not see these ads.
toflaherty is offline   Reply With Quote
Old 04-16-2010, 06:35 PM   #2
toflaherty
Scooby Specialist
 
Member#: 212765
Join Date: May 2009
Chapter/Region: E. Canada
Location: Windsor, ON / Detroit, MI
Vehicle:
2003 WRX
PSM

Default

here's a learning view screen shot to show what i'm talking about.. i'm quite sure there's a ton of false knock at low load/rpm also.. so it's very rich, maxed out negative learning at low load, and also either false knocking or lightly knocking due to the huge lean spikes..

Last edited by toflaherty; 11-05-2011 at 07:36 PM.
toflaherty is offline   Reply With Quote
Old 04-17-2010, 09:06 AM   #3
arghx7
Scooby Specialist
 
Member#: 232940
Join Date: Dec 2009
Location: cold
Default

you pulled out the TGV's. That's not helping.
arghx7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Close loop to Open loop and vice versa Walker Lam Open Source Reflashes 8 01-30-2009 10:51 AM
Closed Loop to Open Loop Transition, when? NavyBlueSubaru UTEC 19 03-03-2006 10:30 PM
What exactly is closed loop vs. open loop fuel control? Neek Engine Management & Tuning 5 03-09-2005 12:50 AM
My thoughts for closed-loop to open-loop with link. Chav Normally Aspirated with bolt-on Forced Induction Powertrain 0 06-28-2002 02:10 PM
Cold Start Idle goobie Normally Aspirated Powertrain 9 11-02-2001 01:02 PM


All times are GMT -4. The time now is 12:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.