Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-18-2010, 09:00 PM   #1
Bsudrummer
Scooby Newbie
 
Member#: 234772
Join Date: Jan 2010
Chapter/Region: RMIC
Location: Boise, ID
Vehicle:
2003 Impreza WRX
Subaru blue

Default I'm a stupid noob with a stupid question...

Ok my radiator just blew and I replaced it with a new one I got from the dealership, here's my question. My old radiator didn't have the yellow cap that you're not supposed to remove when hot on the actual radiator but th new one does. Is there a problem with just capping off the overflow spiggot on the new radiator or what should I do?
* Registered users of the site do not see these ads.
Bsudrummer is offline   Reply With Quote
Old 04-18-2010, 09:03 PM   #2
emsmap
Scooby Guru
 
Member#: 159334
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
02 WRX, 99RS, 96L
UTEC,PPG,FMIC, Big turbo

Default

I had the same problem a couple days ago when I installed a new Mishimoto radiator. I made a second overflow out of a catchcan. You can either cap it off or run it to another overflow
emsmap is offline   Reply With Quote
Old 04-18-2010, 09:49 PM   #3
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2007 Lotus Elise
(From General)

Default

You can also run a Y connection on the overflow line and run both into the overflow tank. I actually use a 1 way valve Y connection on my Cobra kit car, which has a cap (16 pound) on the upper rad hose to have it as the highest point in the system, then the rad has a 22 pound cap. Vacuum line Y's and valves will work. The valve in my car is setup so that 22 Pound can't pull back into it.
Jack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Noob With A Soob Question (2.5i) BeachZone Newbies & FAQs 0 03-12-2010 03:04 PM
I'm such a noob with wheels Jubert69 Newbies & FAQs 6 09-18-2008 06:14 PM
I'm back with another stupid question Sylon Newbies & FAQs 2 05-21-2007 10:42 PM
noob with a tranny question...help please autocannon05 Newbies & FAQs 2 03-11-2007 08:10 PM
Help an audio noob with an amp question. Deuce_04RS Car Audio, Video & Security 15 03-07-2006 12:56 AM


All times are GMT -4. The time now is 10:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.