Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-23-2010, 10:15 PM   #1
last lemming alive
Scooby Specialist
 
Member#: 139465
Join Date: Feb 2007
Location: Lafayette, Louisiana
Vehicle:
2011 STi Limited
Satin White Pearl

Default Do I have the right engine mounts for my 09 - help, under my car now

I purchased the Group N engine mounts for my WRX. The subaru performance catalog says is is for all models and WRX. However, my stock one are round and these are square - do I have the wrong ones?
* Registered users of the site do not see these ads.
last lemming alive is offline   Reply With Quote
Old 04-23-2010, 10:25 PM   #2
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

The regular Group-N engine mounts are square.

Your OEM mounts may be simply a different style or liquid-filled.

TiC will probably kill me for linking to their server, but:


Also, take notice of the passenger's side mounting plate that the mounts are attached. I know that on my 2006 WRX the mounting plate has a built-in heat-shield to protect the mount from the uppipe. If yours is the same, reuse the [metal] mounting plate.
Big-E is offline   Reply With Quote
Old 04-24-2010, 09:15 PM   #3
OrbitalEllipses
Scooby Guru
 
Member#: 178811
Join Date: Apr 2008
Chapter/Region: MAIC
Location: MoCo
Vehicle:
2013 WRB BRZ
:banana:

Default

Dude, just save that picture and host it on imageshack. Don't kill TiC's server!
OrbitalEllipses is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I have the right Groupe N top mounts? Jeff B Brakes, Steering & Suspension 7 05-26-2006 11:11 AM
Do I have the right oil filter for '05 RS? SCI530009 Airboy Service & Maintenance 15 03-27-2006 01:07 AM
Do I have the right filter for '05 RS? SCI530009 Airboy Canada Region Forum 1 01-09-2005 02:49 PM
Do I have a broken engine mount?? SoLiDbReAkZ Service & Maintenance 2 07-08-2002 07:17 PM
Do I have too soft engine mounts? tonytiger Normally Aspirated Powertrain 5 05-14-2002 01:12 AM


All times are GMT -4. The time now is 09:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.