Welcome to the North American Subaru Impreza Owners Club Sunday April 19, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-27-2010, 11:03 PM   #1
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default 98 - rear windshield fluid leak

Hey guys, I just picked up a 1998 legacy outback, and I noticed the rear fluid doesn't work. So I'm squirting it and I hear this liquid trickling sound. It's running down the inside of the car and exiting out near the rear bumper. Does anyone know how that line is routed and how to replace it?

Thanks!
teb
* Registered users of the site do not see these ads.
tebriel is offline   Reply With Quote
Old 04-28-2010, 09:54 AM   #2
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

also are there any fixes for the rear latch being picky on when it wants to open?
tebriel is offline   Reply With Quote
Old 04-28-2010, 02:15 PM   #3
britimp
Scooby Newbie
 
Member#: 132328
Join Date: Nov 2006
Chapter/Region: NESIC
Location: S.Deefield MA
Vehicle:
1997 Impreza OBS
1999 Legacy Wagon

Default

My 99 legacy is fine but this happened to my 97 impreza, the tube that carries the fluid to the nozzle that squirts it onto the windshield was busted right where is enters the rear hatch.

There is a black rubbery outer tube I think on the left side of the hatch near the hinge, pull that back and you will see the busted thinner PVC tube. Hopefully you can find both ends of this tube and splice some new PVC tube into it - I used aquarium tube and connectors and so far it has been a good fix.

I think the thin tube gets crimped when the hatch closes and this eventually causes it to fail - I also think the original is too short.

Also, squirt WD40 or liquid wrench all around the rear hatch handle just above the license plate but under the plastic lip - they get really rusty and sticky under there. Work it loose and spray again - it should work better if you keep at it. Also spray into the lock barrel itself.

Good luck.

Last edited by britimp; 04-28-2010 at 02:19 PM. Reason: Extra information
britimp is offline   Reply With Quote
Old 04-28-2010, 03:08 PM   #4
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

yeah the handle is really rusty. can you replace it do you know?
tebriel is offline   Reply With Quote
Old 04-29-2010, 11:19 AM   #5
jey
Scooby Specialist
 
Member#: 32503
Join Date: Feb 2003
Chapter/Region: TXIC
Location: Johnson City, TX
Vehicle:
2011 Tribeca
1995 Legacy Wagon

Default

Yes..
jey is offline   Reply With Quote
Old 04-29-2010, 06:50 PM   #6
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

k I just mean do they make a new part for it, or do i have to go to the junkyard and find an equally rusty one :P
tebriel is offline   Reply With Quote
Old 04-29-2010, 10:59 PM   #7
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

k i fixed the leak, the hose was completely chewed away, probably from vibration near where it goes up to the hatch. i cut out the busted hose then reconnected it back together using some slack. it works now! it was pouring down on the little hitch controller though, so hopefully that still works.
-teb
tebriel is offline   Reply With Quote
Old 04-30-2010, 12:25 PM   #8
britimp
Scooby Newbie
 
Member#: 132328
Join Date: Nov 2006
Chapter/Region: NESIC
Location: S.Deefield MA
Vehicle:
1997 Impreza OBS
1999 Legacy Wagon

Default

You could get a new part from a dealer but I would rather take it all apart and clean, rust treat, paint it and put it back together. It seems to happen to most wagons and the rusty bracket looks nasty but you can keep everything working by lubing it once in a while - too much lube and it runs down onto the license plate and makes a mess of the rear hatch.

As long as the hatch opens and you can still get to the license plate lamps then I would leave it be.
britimp is offline   Reply With Quote
Old 05-02-2010, 11:29 AM   #9
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

so i took off the back interior panel to look at the latch mechanism. i can see why it's not working quite right but not how to fix it. however i kind of flexed some pieces in there, and now it's worked 100% lol. so who knows.
tebriel is offline   Reply With Quote
Old 05-04-2010, 09:52 PM   #10
josh18
Scooby Newbie
 
Member#: 245734
Join Date: May 2010
Chapter/Region: Tri-State
Location: Delaware
Vehicle:
1997 Legacy
White

Default

You Can fix it
josh18 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does your rear wiper fluid leak too? geoffrey raiser Newbies & FAQs 3 03-16-2010 02:35 PM
Where to refill rear windshield fluid tank? Retribution Impreza Forum 5 01-24-2009 06:25 PM
Small Rear Differential Fluid Leak - Please Advise on New Seal MattSTi Transmission (AT/MT) & Driveline 4 01-21-2008 10:58 PM
Rear Diff Fluid leak - 04 STi mavx5 Service & Maintenance 15 09-06-2007 01:40 AM
Is my rear LSD fluid leaking? WRC STi Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 06-14-2001 03:42 PM


All times are GMT -4. The time now is 11:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.