Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-28-2010, 12:23 AM   #1
subiee sTi
Scooby Newbie
 
Member#: 86944
Join Date: May 2005
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
04 Sti
Blue & Black

Unhappy 2 Problems with my car, Need help please!

First of all, the first problem I have is my check engine light that came on. I do know that it is from my o2 sensor since I have no cat, I think my o2 is burnt up, is there anyway I can make the check engine light go away without buying new o2 sensors? I've already bought a spacer so if I was going to buy a new o2, the light would not come on again.

The next problem is my clutch I think. When try to speed up and step on the gas pedal hard, it tends to rev up really fast but I'm not gaining any speed, also when I am in 6th gear and shift back into neutral, the car just dies out.. anyone know if that is a clutch problem?

By the way I have an 04 sti if there is a need to know.
* Registered users of the site do not see these ads.
subiee sTi is offline   Reply With Quote
Old 04-28-2010, 02:36 AM   #2
Want_To_Buy
Scooby Specialist
 
Member#: 238843
Join Date: Feb 2010
Chapter/Region: MAIC
Location: For Sale - Wanted Section
Vehicle:
1997 Honda
Accord

Default

List of mods? Also go to any auto parts store and get the Cel checked. Its free, don't forget to right down the Cel number. Report back after you got the number, no one can help you with out it!
Want_To_Buy is offline   Reply With Quote
Old 04-28-2010, 02:52 AM   #3
toconn
Scooby Newbie
 
Member#: 166656
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Connecticut / Massachusetts
Vehicle:
2002 WRX Wagon
Silver

Default

+1 on getting the CEL code. Do you know which O2 sensor is the problem? If it's the rear O2 sensor, you can defeat it via tuning. If it's the front, you'll want to replace it since it plays a role in determining your A/F ratios.

Your revving issue sounds like textbook clutch slip, start saving for a clutch job. The stalling issue has nothing to do with your clutch, go pull the codes and they may give some insight on what's causing that issue.
toconn is offline   Reply With Quote
Old 04-28-2010, 09:36 PM   #4
subiee sTi
Scooby Newbie
 
Member#: 86944
Join Date: May 2005
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
04 Sti
Blue & Black

Default

Quote:
Originally Posted by toconn View Post
+1 on getting the CEL code. Do you know which O2 sensor is the problem? If it's the rear O2 sensor, you can defeat it via tuning. If it's the front, you'll want to replace it since it plays a role in determining your A/F ratios.

Your revving issue sounds like textbook clutch slip, start saving for a clutch job. The stalling issue has nothing to do with your clutch, go pull the codes and they may give some insight on what's causing that issue.
Cool thx, yes I got the codes, it is my o2 sensor and I do need a new clutch. I need the front and rear o2 sensor, after replacing it, is there anyway of adding something to prevent the CEL light from coming back on?..because my exhaust is catless, so it will come back on eventually.
subiee sTi is offline   Reply With Quote
Old 04-28-2010, 11:00 PM   #5
toconn
Scooby Newbie
 
Member#: 166656
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Connecticut / Massachusetts
Vehicle:
2002 WRX Wagon
Silver

Default

Quote:
Originally Posted by subiee sTi View Post
Cool thx, yes I got the codes, it is my o2 sensor and I do need a new clutch. I need the front and rear o2 sensor, after replacing it, is there anyway of adding something to prevent the CEL light from coming back on?..because my exhaust is catless, so it will come back on eventually.
Your front O2 sensor (i.e. the important one) is upstream from the cats, so it doesn't matter that you have a catless downpipe. Simply replace it and it won't cause any codes. You can defeat the rear O2 sensor code via tuning (please tell me you're tuning your car with a catless DP), the spacer mod which you've stated you have, or I'm sure there's a resistor mod out there too to fool the ECU into thinking it's getting the proper readings...
toconn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I have 2 problems with my WRX plz help! Venom911 Service & Maintenance 3 02-28-2008 03:31 PM
Wrecked my car - need parts, please help!!! deziner MWSOC Private Classifieds 2 01-25-2007 03:54 PM
having problems with my 96...need help fast zer0321 Service & Maintenance 1 07-09-2006 09:28 PM
Problem with my car - help now! Kickz107 Bay Area Impreza Club Forum -- BAIC 26 11-25-2003 04:13 PM
*Help* Problem with my car Burnout South East Region Forum 13 02-14-2003 02:37 AM


All times are GMT -4. The time now is 09:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.