Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-04-2010, 02:56 AM   #1
The G.O.A.T.
Scooby Newbie
 
Member#: 149724
Join Date: May 2007
Chapter/Region: W. Canada
Location: Calgary Alberta, Canada
Vehicle:
1999 leggy gt 5speed
Blood red

Default How do I get rid of my cel's after header install???

Well I finally put my headers on (heat wrapped and hi temp painted with 9 coats) yesterday and was wondering how to get rid of my cel's.

I do have a AccessPort and was wondering if there is any way to permanently clear the codes? I currently do not have the o2 sensors plugged in but I am planing on getting them installed and modified soon in the stock mid pipe before and after the cat, but will that clear the code?

I need to have cruse as I am going to be driving about 7,000 mi in the next 3 weeks (road trip )
And it would really suck not having cruse for the trip so any answers would be most helpful.

Thanks
Nick
* Registered users of the site do not see these ads.
The G.O.A.T. is offline   Reply With Quote
Old 05-04-2010, 04:29 PM   #2
The G.O.A.T.
Scooby Newbie
 
Member#: 149724
Join Date: May 2007
Chapter/Region: W. Canada
Location: Calgary Alberta, Canada
Vehicle:
1999 leggy gt 5speed
Blood red

Default

The Codes are p0037 and p1139 is there any way to turn those off???
The G.O.A.T. is offline   Reply With Quote
Old 05-04-2010, 06:01 PM   #3
Dan707
Scooby Newbie
 
Member#: 213282
Join Date: Jun 2009
Default Front o2 sensor

Make sure you have the front o2 sensor install (driver side of exhaust/headers) otherwise you will keep getting the the cel's & gas millage will be very bad.

Before install the front o2 sensor reset your ecu first with your access port.

Just installed headers last week in my '05 STi & my front o2 sensor went bad after the installation so had to buy new one (not cheap)!!!

Good luck,
Dan
Dan707 is offline   Reply With Quote
Old 05-04-2010, 07:03 PM   #4
The G.O.A.T.
Scooby Newbie
 
Member#: 149724
Join Date: May 2007
Chapter/Region: W. Canada
Location: Calgary Alberta, Canada
Vehicle:
1999 leggy gt 5speed
Blood red

Default

So just the front? Or do I need both? And what do I do if I want to go catless?

Update

Saen from rallitek just called and explained everything. what service!!! FTW

Last edited by The G.O.A.T.; 05-04-2010 at 07:29 PM.
The G.O.A.T. is offline   Reply With Quote
Old 05-04-2010, 07:26 PM   #5
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

You cannot turn off these codes, they are for the front O2 sensor. This sensor is vital for proper engine function. You will need to have this sensor installed IMMEDIATELY in order for your car to run properly. Right now your ECU has no idea what your fueling is, which is very bad.

Travis
COBB Tuning
Cobb Tuning is online now   Reply With Quote
Old 05-05-2010, 07:33 AM   #6
Dan707
Scooby Newbie
 
Member#: 213282
Join Date: Jun 2009
Default

Take Travis advise,

I have both & now going to install my LC-1 wideband also after the downpipe and I'm already catless with a protune stg.2 map.

Believe me you have to install especially the front o2 sensor (A/F ratio Part number is 22641-AA211)in you exhaust/header manifold.

Dan
Dan707 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get rid of my cel's after header install??? The G.O.A.T. Normally Aspirated Powertrain 23 05-07-2010 03:54 PM
How do I get rid of my cel's permanatly with accessport The G.O.A.T. Engine Management & Tuning 4 05-05-2010 12:48 AM
How do I get rid of my Hickups?????? TheSilverFox Off-Topic 49 06-07-2007 09:03 AM
How do I get rid of my squishy feeling brakes? Homemade WRX Brakes, Steering & Suspension 17 10-24-2003 10:42 PM
How do I get rid of my front liscense plate holder? imprezive Interior & Exterior Modification 5 02-19-2002 01:33 AM


All times are GMT -4. The time now is 07:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.