Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-11-2010, 11:25 PM   #1
SkatmanWRX
Scooby Newbie
 
Member#: 245427
Join Date: Apr 2010
Location: Michigan
Vehicle:
2010 WRX
WR Blue

Default Got my AP for my 2010 wrx today....not happy.

i bought mine from cobb tuning for $600 and it looks like its already been used. my screen has scratches and the back is scratched. wtf? should i return it? i want to but ive been waiting to get it for a while and now i would have to wait 2 more weeks.. anyone else get a used AP for 600?
* Registered users of the site do not see these ads.
SkatmanWRX is offline   Reply With Quote
Old 05-12-2010, 12:03 AM   #2
twigg107
Scooby Specialist
 
Member#: 119718
Join Date: Jul 2006
Chapter/Region: NWIC
Location: Port Orchard, Wa
Vehicle:
2008 STI
DGM

Default

Did try calling them or email? I'd demand them express ship a new one so you dont have to wait 2 more weeks.
twigg107 is offline   Reply With Quote
Old 05-12-2010, 12:21 AM   #3
meccjoo
Scooby Specialist
 
Member#: 97522
Join Date: Oct 2005
Chapter/Region: SCIC
Location: LA
Default

when i got mine a while back, it did look a bit scuffed up but there werent any scratches or anything. i guess they are look a bit used?
meccjoo is offline   Reply With Quote
Old 05-12-2010, 12:26 AM   #4
SkatmanWRX
Scooby Newbie
 
Member#: 245427
Join Date: Apr 2010
Location: Michigan
Vehicle:
2010 WRX
WR Blue

Default

i was planing on calling tomorrow. but i just decided to plug it into my computer and the picture that came up was of a 08-10 STi. i specifically chose the one for a 10 WRX!! wtf?!?!?
SkatmanWRX is offline   Reply With Quote
Old 05-12-2010, 12:27 AM   #5
Spootypuff
NASIOC SUPER Supporter
n00b jesus
 
Member#: 200000
Join Date: May 2008
Chapter/Region: RMIC
Location: the mountains
Vehicle:
2012 Wrangler

Default

Don't get too upset. Mistakes happen. Cobb usually has excellent customer service so just give them a call in the morning, explain the situation, and I'm sure they will be more than willing to help.
Spootypuff is offline   Reply With Quote
Old 05-12-2010, 05:36 PM   #6
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

There is a very thin plastic coating on the screen, you can peel this off and it should remove the screen imperfections. If there are other cosmetic defects we are happy to replace your unit.

If you have not yet installed the AccessPORT on your car and it is in an uninstalled state, it may show the default screen for the WRX since the SUB-003 part is for STI, WRX, FXT and LGT. Once you plug it into your car it will identifiy the proper car and model.

Give us a call at 801-713-0035 and we can help you with a replacement unit or case.

Travis
COBB Tuning
Cobb Tuning is offline   Reply With Quote
Old 05-15-2010, 12:01 PM   #7
Blue_Rex
Scooby Specialist
 
Member#: 236954
Join Date: Jan 2010
Chapter/Region: MAIC
Location: VA
Vehicle:
2010 WRX Base
WRB

Default

Quote:
Originally Posted by Cobb Tuning View Post
There is a very thin plastic coating on the screen, you can peel this off and it should remove the screen imperfections. If there are other cosmetic defects we are happy to replace your unit.

If you have not yet installed the AccessPORT on your car and it is in an uninstalled state, it may show the default screen for the WRX since the SUB-003 part is for STI, WRX, FXT and LGT. Once you plug it into your car it will identifiy the proper car and model.

Give us a call at 801-713-0035 and we can help you with a replacement unit or case.

Travis
COBB Tuning
I have to hand it to you guys....when I received this thing, it was packaged so neat and tight that I was looking for the white Apple logo.

You guys just need to follow Nintendo and make one with an "XL" screen. You could also seriously cash in on custom-fit mounts or other accessories. If you made a mount that was molded in the side pillar, or some other snazy looking mount, I would totally buy!
________
Paxil death

Last edited by Blue_Rex; 08-23-2011 at 04:55 PM.
Blue_Rex is offline   Reply With Quote
Old 05-17-2010, 01:12 PM   #8
bpcrally
Scooby Newbie
 
Member#: 208408
Join Date: Apr 2009
Location: Ontario
Vehicle:
2004 WRX Wagon
PSM

Default

+1 on a proper mount
bpcrally is offline   Reply With Quote
Old 06-14-2010, 07:04 PM   #9
cianuro
Scooby Newbie
 
Member#: 235475
Join Date: Jan 2010
Chapter/Region: PRSIC
Location: Puerto Rico
Vehicle:
2008 WRX
Silver

Default

Quote:
Originally Posted by bpcrally View Post
+1 on a proper mount
+1 Here also... And combined with this would be great:



cianuro is offline   Reply With Quote
Old 06-18-2010, 01:49 PM   #10
iommichild
Scooby Newbie
 
Member#: 194990
Join Date: Nov 2008
Location: Eugene OR
Vehicle:
2008 OBS
Steel Silver/Spark Silver

Default

Or make one that fits in a DIN slot under an aftermarket headunit.
iommichild is offline   Reply With Quote
Old 06-18-2010, 06:50 PM   #11
fivestringslinger
Scooby Specialist
 
Member#: 200455
Join Date: Jan 2009
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2004 WRX Wagon, WRB
06 Triumph Speed Triple

Default

I wish I could find the picture of that one guy who had an 02-07 WRX and took his AP apart and installed the screen where the factory clock goes in the middle of the dash and relocated the buttons down to the center console or something. Freakin' awesome.
fivestringslinger is offline   Reply With Quote
Old 06-19-2010, 01:33 PM   #12
mikndee
Scooby Newbie
 
Member#: 169433
Join Date: Jan 2008
Chapter/Region: South East
Location: jacksonville nc
Vehicle:
2010 wrx
rally blue

Default

i just got my cobb ap from rallitek yesterday, installed today. i did notice some little scratches on the screen film but i dont really care. i hooked it up no problem after a little confusion with the install instructions(looking for green test mode connectors like an idiot). however it loaded no prob and the stage1 93oct map works perfect and theres a noticable difference. so far i am very pleased.
mikndee is offline   Reply With Quote
Old 06-20-2010, 04:46 PM   #13
pinkopanter
Scooby Newbie
 
Member#: 249903
Join Date: Jun 2010
Default

I got mine from COBB and installed with no problem. Stock STI 2010 with stage 1 93 oct, my car is like F15. Just ordered the Borla CBE, cant wait to get it and go to stage 2
pinkopanter is offline   Reply With Quote
Old 06-20-2010, 08:14 PM   #14
requience139
Scooby Newbie
 
Member#: 240240
Join Date: Mar 2010
Chapter/Region: NWIC
Location: Oak Harbor, WA
Vehicle:
2007 WRX
WRB

Default

if you got a new one, the scratches on the screen should not be there. i bought mine localy and the guy still had the screen protector, which made it look scratched, so i took it off, and BAM! it looks amazing. +10 for the proper mount. for now i have to settle with velcro,
requience139 is offline   Reply With Quote
Old 06-29-2010, 03:51 PM   #15
Suby Noob
Scooby Specialist
 
Member#: 60890
Join Date: Apr 2004
Chapter/Region: South East
Location: O-Town
Vehicle:
1994 Toyota Pick-Up
2009 DGM WRX Sedan

Default

Quote:
Originally Posted by iommichild View Post
Or make one that fits in a DIN slot under an aftermarket headunit.
This.
Suby Noob is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ordered my 2010 WRX today! Jewish Santa Mid Atlantic Impreza Club -- MAIC 25 02-28-2010 11:03 PM
2010 wrx would not go into gear whatsoever awdpower91 Factory 2.5L Turbo Powertrain 1 02-02-2010 09:32 PM
Picked up a Cobb AP for my '06 WRX today... trhee General Community 49 11-16-2005 11:53 PM
Just got my AP for STI yoojeankim Engine Management & Tuning 10 08-27-2005 11:25 PM
So I got a Ticket for my exhaust today.. thinking of Greddy evo2 now ... dirtysti General Community 52 01-11-2005 01:36 AM


All times are GMT -4. The time now is 05:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.