Welcome to the North American Subaru Impreza Owners Club Tuesday June 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-19-2010, 01:19 AM   #1
NWSTi-wa
Scooby Specialist
 
Member#: 245786
Join Date: May 2010
Chapter/Region: NWIC
Location: Wenatchee, WA
Default Engine troubles HELP!

So last friday I was driving my 04 sti over stevens pass and my check engine light came on and about 5 minutes after that my car lost power well at least the turbo. There was no boost but the engine itself still ran. I had no choice but to limp it back to my house but I was wondering what the deal is? There is no abnormal noise or smoke from the tailpipe or engine bay. The car did make a couple weird noises right before it went out but after that it made no weird noises at all. The check engine light is on and the cruise is on that's it. Also the wastegate is tight.

Any info would be great!
* Registered users of the site do not see these ads.

Last edited by NWSTi-wa; 05-19-2010 at 01:41 AM.
NWSTi-wa is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-19-2010, 02:06 AM   #2
skatevolcom06
Scooby Specialist
 
Member#: 199522
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Elko, NV
Vehicle:
2004 Impreza STi
PsM

Default

Check and see what your code is causing your check engine light to come on. That will tell you alot!

Also did you make sure all of your fluids are good?
skatevolcom06 is offline   Reply With Quote
Old 05-19-2010, 02:16 AM   #3
NWSTi-wa
Scooby Specialist
 
Member#: 245786
Join Date: May 2010
Chapter/Region: NWIC
Location: Wenatchee, WA
Default

I am getting it scanned tommorow. I had it scanned previously and the dealership said somthing about a oil pressure regulator valve? I cant quite remember but they said not too worry about it and to put some more oil in it and it will be good. it was a quart low. So I did and about a day later, it was a quart low again. BUT there were absolutely no leaks coming from the car. Nor was there any black/white smoke coming from the car. Then a day later everything went away, no check engine light or anything. car ran great. Then a week later this happend. And at that time all fluid levels were good.
NWSTi-wa is offline   Reply With Quote
Old 06-12-2010, 08:25 PM   #4
justchillax808
Scooby Newbie
 
Member#: 177287
Join Date: Apr 2008
Chapter/Region: HIIC
Location: Brugnera, Italy
Vehicle:
2006 STi
steel gray

Default

Do a compression test
justchillax808 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP 2006 engine troubles subywuby45 Service & Maintenance 5 02-21-2008 09:38 PM
Engine Trouble Help brianswagon Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 09-12-2006 01:40 PM
engine trouble, help legacydreamz Legacy Forum 6 04-08-2006 11:07 AM
need some subie help,engine troubles... Vidiotgamer Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 10-29-2003 04:30 PM
check engine light, wierd engine trouble? gipoliceman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 01-14-2003 09:04 PM


All times are GMT -4. The time now is 11:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.