Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-28-2012, 11:45 PM   #30326
PurpleDoors
Scooby Newbie
 
Member#: 225582
Join Date: Oct 2009
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2002 VF39'd EJ205
BRP RS Sedan

Default

Quote:
Originally Posted by DarkBlueBug View Post
Some real tidy bugs you guys have over there, thought I'd share mine and see what you make of it...
Beautiful. DBM/BRP is the best Subaru color ever.
* Registered users of the site do not see these ads.
PurpleDoors is offline   Reply With Quote
Old 10-29-2012, 02:43 AM   #30327
TRinityMtrSprts
Scooby Specialist
 
Member#: 43720
Join Date: Sep 2003
Chapter/Region: SCIC
Location: Redondo Beach
Vehicle:
2002 mbp WRX
97 Ford Ranger on Bags

Default

Quote:
Originally Posted by delarryous View Post
My wrx that a friend of mine took pictures of at a local meet
any other shots?
clean bug
TRinityMtrSprts is offline   Reply With Quote
Old 10-29-2012, 03:05 AM   #30328
butterflyx3
Scooby Specialist
 
Member#: 293345
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2003 WRX
WRB

Default



before and after
butterflyx3 is offline   Reply With Quote
Old 10-29-2012, 03:46 AM   #30329
DarkBlueBug
Scooby Newbie
 
Member#: 301445
Join Date: Nov 2011
Chapter/Region: International
Vehicle:
2001 WRX
Dark Blue Mica (95H)

Default

Quote:
Originally Posted by 1breel View Post
flex in the hubs might be your brake problem if still 5x100
Really, not heard of that before. It was the front drivers side giving me issues but after the ABS delete it seems to be the rear passenger side. Only happens when I'm stuck in normal/slow traffic and the pedal firms up, once I get a clear run the pedal returns to normal. I've changed to STI Brembos all round so I know the calipers are in good shape with new rear discs and pads all round. There doesn't appear to be any noticeable play in the hubs
DarkBlueBug is offline   Reply With Quote
Old 10-29-2012, 06:58 AM   #30330
AnthonyWang
Scooby Specialist
 
Member#: 292823
Join Date: Aug 2011
Chapter/Region: SCIC
Location: Gardena/Riverside
Default

nothing new yet, same ol' same ol'

Bugeye4Lyfe by Genghis Chon, on Flickr
AnthonyWang is offline   Reply With Quote
Old 10-29-2012, 08:07 AM   #30331
low-n-slow
Scooby Specialist
 
Member#: 313818
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: North West OH
Vehicle:
2002 wrx hybrid
WRB

Default

^I like the "yet" part of your post!
low-n-slow is offline   Reply With Quote
Old 10-29-2012, 09:34 AM   #30332
AutoPrue
Scooby Specialist
 
Member#: 115459
Join Date: May 2006
Chapter/Region: NESIC
Location: @atomic_bugeye
Default

Dude Jstova did you lose control of your car?...use the guns to put her down?
AutoPrue is offline   Reply With Quote
Old 10-29-2012, 10:36 AM   #30333
MihaiFlorescu
Scooby Newbie
 
Member#: 249278
Join Date: Jun 2010
Location: Bucharest, Romania
Vehicle:
2001 Wagon WRX

Default





MihaiFlorescu is offline   Reply With Quote
Old 10-29-2012, 10:39 AM   #30334
1breel
Scooby Specialist
 
Member#: 189314
Join Date: Sep 2008
Chapter/Region: South East
Location: in the ghetto ATL
Vehicle:
2002 GGSTi
01G

Default

Quote:
Originally Posted by DarkBlueBug View Post
Really, not heard of that before. It was the front drivers side giving me issues but after the ABS delete it seems to be the rear passenger side. Only happens when I'm stuck in normal/slow traffic and the pedal firms up, once I get a clear run the pedal returns to normal. I've changed to STI Brembos all round so I know the calipers are in good shape with new rear discs and pads all round. There doesn't appear to be any noticeable play in the hubs
sounds like an issue with the booster check valve, booster or proportion valve. check those in that order, usually something stupid simple like air in the lines or busted vacuum line
1breel is offline   Reply With Quote
Old 10-29-2012, 11:38 AM   #30335
VGambino414
Scooby Newbie
 
Member#: 251573
Join Date: Jul 2010
Chapter/Region: Tri-State
Vehicle:
2002 WRX
WRB

Default

babys hanging out for this storm tucked away in the backyard

VGambino414 is offline   Reply With Quote
Old 10-29-2012, 11:54 AM   #30336
03Rextacy
Scooby Specialist
 
Member#: 239497
Join Date: Feb 2010
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2003 Impreza WRX
WRB

Default

Quote:
Originally Posted by VGambino414
babys hanging out for this storm tucked away in the backyard
Mine too. Wrapped her in towels and blankets, car cover over those, and taped all over. Mainly an effort for small debris and hail. Hopefully she'll be alright.
03Rextacy is offline   Reply With Quote
Old 10-29-2012, 12:08 PM   #30337
DarkBlueBug
Scooby Newbie
 
Member#: 301445
Join Date: Nov 2011
Chapter/Region: International
Vehicle:
2001 WRX
Dark Blue Mica (95H)

Default

Quote:
Originally Posted by 1breel View Post
sounds like an issue with the booster check valve, booster or proportion valve. check those in that order, usually something stupid simple like air in the lines or busted vacuum line
That's more like my thoughts; the bias valve is new so I've got a replacement booster (servo) and master cylinder to try as the next stage. That'll all happen when I replace the braided lines to ensure one of the old ones hasn't collapsed
DarkBlueBug is offline   Reply With Quote
Old 10-29-2012, 01:16 PM   #30338
DarkBlueBug
Scooby Newbie
 
Member#: 301445
Join Date: Nov 2011
Chapter/Region: International
Vehicle:
2001 WRX
Dark Blue Mica (95H)

Default

I've had a couple of comments about the wing - it's a Kakumei replica of the S202 wing in carbon fibre - costs about 20% of the price of the original. Here's a pic of it from a gathering this weekend

DarkBlueBug is offline   Reply With Quote
Old 10-29-2012, 03:23 PM   #30339
AnthonyWang
Scooby Specialist
 
Member#: 292823
Join Date: Aug 2011
Chapter/Region: SCIC
Location: Gardena/Riverside
Default

Quote:
Originally Posted by low-n-slow View Post
^I like the "yet" part of your post!
AnthonyWang is offline   Reply With Quote
Old 10-29-2012, 04:19 PM   #30340
mac1124
Scooby Newbie
 
Member#: 286146
Join Date: Jun 2011
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2003 2.5 TS Wagon
Blue Ridge Pearl

Default

Quote:
Originally Posted by MihaiFlorescu View Post

Looks great!
mac1124 is offline   Reply With Quote
Old 10-29-2012, 04:26 PM   #30341
DarkBlueBug
Scooby Newbie
 
Member#: 301445
Join Date: Nov 2011
Chapter/Region: International
Vehicle:
2001 WRX
Dark Blue Mica (95H)

Default

Quote:
Originally Posted by PurpleDoors View Post

They are sweet rims, what are they and what's the spec - great colour BTW
DarkBlueBug is offline   Reply With Quote
Old 10-29-2012, 06:37 PM   #30342
xxBrun0xx
Scooby Newbie
 
Member#: 285940
Join Date: Jun 2011
Chapter/Region: NESIC
Location: Agawam, MA
Vehicle:
2008 STi
WRB

Default

My turn! Just got it and absolutely love it

xxBrun0xx is offline   Reply With Quote
Old 10-29-2012, 07:13 PM   #30343
FosterChild4
Scooby Newbie
 
Member#: 296133
Join Date: Sep 2011
Chapter/Region: AKIC
Location: Fairbanks, AK
Vehicle:
2002 Impreza WRX
WRB

Default


My winter setup
FosterChild4 is offline   Reply With Quote
Old 10-29-2012, 07:15 PM   #30344
Subie413
Scooby Newbie
 
Member#: 336042
Join Date: Oct 2012
Chapter/Region: NESIC
Location: springfield,mass
Vehicle:
2002 subaru
psm

Default

****ty cell pics


And new wheels
Subie413 is offline   Reply With Quote
Old 10-29-2012, 07:20 PM   #30345
franchisco7
Scooby Newbie
 
Member#: 286429
Join Date: Jun 2011
Chapter/Region: South East
Location: Jax, FL
Vehicle:
2002 Impreza WRX
SRP

Default

franchisco7 is offline   Reply With Quote
Old 10-29-2012, 07:31 PM   #30346
xxBrun0xx
Scooby Newbie
 
Member#: 285940
Join Date: Jun 2011
Chapter/Region: NESIC
Location: Agawam, MA
Vehicle:
2008 STi
WRB

Default

Quote:
Originally Posted by Subie413 View Post
****ty cell pics


And new wheels
How much did you lower this? Those tires have the same outer diameter as stock?
xxBrun0xx is offline   Reply With Quote
Old 10-29-2012, 08:10 PM   #30347
p.lowther02wrx
Scooby Newbie
 
Member#: 332358
Join Date: Sep 2012
Location: Billings MT
Vehicle:
2002 WRX
WRB

Default My Bugeye (In Progress)













p.lowther02wrx is offline   Reply With Quote
Old 10-29-2012, 08:33 PM   #30348
AutoPrue
Scooby Specialist
 
Member#: 115459
Join Date: May 2006
Chapter/Region: NESIC
Location: @atomic_bugeye
Default



I lost power sitting in the dark.
AutoPrue is offline   Reply With Quote
Old 10-29-2012, 08:46 PM   #30349
Yakattak
Scooby Newbie
 
Member#: 284332
Join Date: May 2011
Chapter/Region: NESIC
Vehicle:
2003 Impreza WRX
Platinum Silver Metallic

Default

Quote:
Originally Posted by AutoPrue View Post


I lost power sitting in the dark.
I still have it, so far.
Yakattak is offline   Reply With Quote
Old 10-29-2012, 08:51 PM   #30350
mac1124
Scooby Newbie
 
Member#: 286146
Join Date: Jun 2011
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2003 2.5 TS Wagon
Blue Ridge Pearl

Default

Quote:
Originally Posted by Subie413 View Post
What wheels are these?
mac1124 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
the Bugeye thread 5spdfrk Member's Car Gallery 18633 05-20-2010 12:18 PM
Where's the bugeye lip thread?! yankdanger Interior & Exterior Modification 0 04-06-2009 09:43 PM


All times are GMT -4. The time now is 08:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.