Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-20-2010, 10:42 PM   #1
xandy14x
Scooby Newbie
 
Member#: 231026
Join Date: Nov 2009
Location: Southwick,MA
Vehicle:
2002 Wrx Wagon
Silver

Default New Clutch need help!!

ok so i have a 2002 wrx wagon. i recently put a new clutch and flywheel on it. when i picked it up from the shop it was really easy to push in and let out alot sooner than before. i have driven about 300 miles on it and the pedals back to being stiff. i dont know if its just me used to the pedal now but. also every time i slow down from 2nd 3rd or 4th gear it sounds like the gears are grinding. like gear mesh. it sounds like they are vibrating together and i dont know why. i took it back and he said its normal but i dont think it is. i need some help about this thanks...
* Registered users of the site do not see these ads.
xandy14x is offline   Reply With Quote
Old 05-22-2010, 02:43 PM   #2
02 Scoob-TN
Scooby Newbie
 
Member#: 176010
Join Date: Mar 2008
Chapter/Region: South East
Location: Nash, TN
Vehicle:
2005 WRX sdn ver8'ed
Phat-Tuned RIP Bugeye

Lightbulb Could be a few things..

My guess would be the throwout bearing may be rattling a bit or a loose downpipe mount bolt or heat sheild bolt since its happening during decel. Ive done 2 clutch jobs on my 02 and the dumb thowout bearing clips never stay on right so most people dont use em and it causes the t/o bearing to make a lil noise. As long as your clutch is engaging fine, Id roll with it. The t/o bearing may wear out a lil early. The rattle always comes back. You could try the tsk kit that replaces the flawed stock setup.
02 Scoob-TN is offline   Reply With Quote
Old 05-22-2010, 03:32 PM   #3
xandy14x
Scooby Newbie
 
Member#: 231026
Join Date: Nov 2009
Location: Southwick,MA
Vehicle:
2002 Wrx Wagon
Silver

Default

alright thank you
xandy14x is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need new clutch, please HELP! KnightRiderWRX Transmission (AT/MT) & Driveline 3 07-21-2009 03:04 PM
02 WRX need new clutch, need advice wRx137 Transmission (AT/MT) & Driveline 11 01-09-2007 12:51 AM
Need A New Clutch :( Help Jasin_S Transmission (AT/MT) & Driveline 11 01-04-2007 05:03 PM
time for a new clutch!! need help deciding RedSun Factory 2.0L Turbo Powertrain 2 08-03-2004 03:28 PM
working on changing 02 wrx clutch need help!!!! compton Transmission (AT/MT) & Driveline 4 10-27-2003 09:15 AM


All times are GMT -4. The time now is 01:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.