Welcome to the North American Subaru Impreza Owners Club Sunday April 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 05-30-2010, 02:40 PM   #101
hillsboro
Scooby Specialist
 
Member#: 84823
Join Date: Apr 2005
Chapter/Region: NWIC
Location: PDX
Vehicle:
11 STI
05 Outback XT

Default

Quote:
Originally Posted by bwilliams373 View Post
Had a leaky headlight so I blacked em out
Was too dark when I finished to get an after shot




Really like the H&R springs but not the "saggy butt"
Ordered a set of longer rear tophat studs and 1/2" HDPE spacers
Taking my H&R's off. They look great. But I'm hitting my bump stops all the time. Might want to look into different ones. For what it's worth. Car looks sweet though.
* Registered users of the site do not see these ads.
hillsboro is offline  
Old 05-30-2010, 03:30 PM   #102
DrnknZag
Scooby Specialist
 
Member#: 138473
Join Date: Jan 2007
Chapter/Region: NWIC
Location: Filling your mom's PM inbox
Vehicle:
2007 WRXstealthwagon
6spd kindaflush

Default

AVIC D3 w/ Bluetooth installed yesterday!



Now I just need to get the nav to work correctly....
DrnknZag is offline  
Old 05-30-2010, 04:44 PM   #103
bwilliams373
Scooby Newbie
 
Member#: 210785
Join Date: May 2009
Chapter/Region: NWIC
Location: Portland Oregon
Default

Headlights on...



^^ Your struts may be blown if you keep hitting the bump stops, just a suggestion. I havnt had a problem with mine.
bwilliams373 is offline  
Old 05-30-2010, 04:45 PM   #104
Smoke
Scooby Guru
 
Member#: 172486
Join Date: Feb 2008
Chapter/Region: NWIC
Location: Cheney, WA
Vehicle:
95 V4 STi-RA swap
Stage 49.8

Default

Washed the car and used the Meguiar's Ultimate Quick Detailer. Great stuff.

Not even a minute later, I see lots of pollen on my car.

It's either dust at my house, or pollen at my school.
Smoke is offline  
Old 05-30-2010, 04:55 PM   #105
Black07STiGuy
Scooby Specialist
 
Member#: 155930
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Reno, NV
Vehicle:
2008 WRX Josh Tuned
VF39+JoshTune=330hp/350tq

Default

Quote:
Originally Posted by DrnknZag View Post
AVIC D3 w/ Bluetooth installed yesterday!



Now I just need to get the nav to work correctly....
Thats sick. My wife just dropped like 1400 on one for my car She says it does everything you can think of. Cant want to play with it when I get home from the sand box. 11 days and counting.
Black07STiGuy is offline  
Old 05-30-2010, 07:11 PM   #106
allonblack
Scooby Specialist
 
Member#: 163161
Join Date: Oct 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2012 S4
2011 Outback

Default

Quote:
Originally Posted by bwilliams373 View Post
Headlights on...



^^ Your struts may be blown if you keep hitting the bump stops, just a suggestion. I havnt had a problem with mine.
They look great.
allonblack is offline  
Old 05-30-2010, 10:12 PM   #107
jagr_200
Visiting NASIOC Timeout
 
Member#: 230710
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Whitefish MT/Federal Way WA
Vehicle:
2004 STi John Tuned!
04 AW Shwagon

Default

Quote:
Originally Posted by DrnknZag View Post
AVIC D3 w/ Bluetooth installed yesterday!

Now I just need to get the nav to work correctly....
Whats your issue with the Navi? It worked perfectly when I had it. It even got me to the tire shop haha. I do know if you don't have the antenna mounted right the little arrow is the wrong direction.


Cleaned my new goldies really well and washed and waxed the beast. Then it rained so I put her in the garage. Not as clean as I wanted but it will work for now.
jagr_200 is offline  
Old 05-31-2010, 02:06 AM   #108
DrnknZag
Scooby Specialist
 
Member#: 138473
Join Date: Jan 2007
Chapter/Region: NWIC
Location: Filling your mom's PM inbox
Vehicle:
2007 WRXstealthwagon
6spd kindaflush

Default

Quote:
Originally Posted by jagr_200 View Post
Whats your issue with the Navi? It worked perfectly when I had it. It even got me to the tire shop haha. I do know if you don't have the antenna mounted right the little arrow is the wrong direction.


Cleaned my new goldies really well and washed and waxed the beast. Then it rained so I put her in the garage. Not as clean as I wanted but it will work for now.
The arrow for the nav kep pointing toward the passanger side of the car, but after driving around for a day, it reorientated itself so it's all good now!
DrnknZag is offline  
Old 05-31-2010, 02:14 AM   #109
TrickNipple
moon moon
Moderator
 
Member#: 86213
Join Date: May 2005
Chapter/Region: NWIC
Location: Wild wild Northwest
Default

Quote:
Originally Posted by DrnknZag View Post
The arrow for the nav kep pointing toward the passanger side of the car, but after driving around for a day, it reorientated itself so it's all good now!
It was pointed like that because you were drifting through all of those turns Joe.
TrickNipple is offline  
Old 05-31-2010, 03:11 AM   #110
DrnknZag
Scooby Specialist
 
Member#: 138473
Join Date: Jan 2007
Chapter/Region: NWIC
Location: Filling your mom's PM inbox
Vehicle:
2007 WRXstealthwagon
6spd kindaflush

Default

Quote:
Originally Posted by LickNippert View Post
It was pointed like that because you were drifting through all of those turns Joe.
It's these damn RE070s in this damn rain!!!!!!!
DrnknZag is offline  
Old 05-31-2010, 08:46 AM   #111
ASU
Scooby Specialist
 
Member#: 164551
Join Date: Nov 2007
Chapter/Region: SWIC
Location: Baumholder, Deutschland
Vehicle:
2006 Brotastic STi
Land of beer and laws

Default

Put on Stoptech 6 piston BBK with Stoptech 14 inch rotars and stainless brake lines.
ASU is offline  
Old 05-31-2010, 10:52 AM   #112
old school
Scooby Specialist
 
Member#: 22647
Join Date: Aug 2002
Chapter/Region: NWIC
Location: Emerald City
Vehicle:
91 Leg SUS
015 XV SE

Default

I went out and looked at it again and tried to motivate myself to get busy working on it. Poor little brat just sitting there on jack stands waiting for that lift kit to be on it.
old school is offline  
Old 05-31-2010, 11:06 AM   #113
Super_HKS
Scooby Guru
 
Member#: 154434
Join Date: Jul 2007
Chapter/Region: NWIC
Location: USMC Land
Vehicle:
2009 WRX Hatch <@_@>
SWP

Default

Switched my Kartboy delrin shift knob back to the 09 wrx stock knob. Since installing the cobb short shifter the kartboy shifter has not worked too well for me. The stock knob is weighted pretty heavily so shifting with that is like butter.
Super_HKS is offline  
Old 05-31-2010, 11:23 AM   #114
Subaru Tripple 5
Scooby Specialist
 
Member#: 211600
Join Date: May 2009
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 Suzuki DRZ400
Supermoto

Default

drove it for the first time in 21 days, feels good.
Subaru Tripple 5 is offline  
Old 05-31-2010, 01:03 PM   #115
jagr_200
Visiting NASIOC Timeout
 
Member#: 230710
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Whitefish MT/Federal Way WA
Vehicle:
2004 STi John Tuned!
04 AW Shwagon

Default

Quote:
Originally Posted by DrnknZag View Post
The arrow for the nav kep pointing toward the passanger side of the car, but after driving around for a day, it reorientated itself so it's all good now!
Ya its got the 3D Hybrid learning system. Which is REALLY slow I guess.

Im starting my interior detail today. Needs lots of help haha.
jagr_200 is offline  
Old 05-31-2010, 02:31 PM   #116
daleyswanson
Scooby Specialist
 
Member#: 205604
Join Date: Mar 2009
Chapter/Region: NWIC
Location: Portland
Vehicle:
87J Robinson
R22

Default

i pulled my s00per cool purple tint off my windows. going to tommy's on thrusday and figured i'd save myself 50 bucks
daleyswanson is offline  
Old 05-31-2010, 09:32 PM   #117
vietrampage
Scooby Newbie
 
Member#: 187815
Join Date: Aug 2008
Chapter/Region: SCIC
Location: Long Beach
Vehicle:
2006 STi
OBP

Default

I got my lips painted and installed this weekend.




vietrampage is offline  
Old 05-31-2010, 11:33 PM   #118
12sechatch
Scooby Guru
 
Member#: 132458
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Kent, Wa
Vehicle:
Okie Dokie Fine

Default

Scic
12sechatch is offline  
Old 05-31-2010, 11:42 PM   #119
allonblack
Scooby Specialist
 
Member#: 163161
Join Date: Oct 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2012 S4
2011 Outback

Default

Quote:
Originally Posted by hillsboro View Post
Taking my H&R's off. They look great. But I'm hitting my bump stops all the time. Might want to look into different ones. For what it's worth. Car looks sweet though.
Quote:
Originally Posted by bwilliams373 View Post
^^ Your struts may be blown if you keep hitting the bump stops, just a suggestion. I havnt had a problem with mine.
Just want to quote this in case you missed it Ryan. Brett's right, your struts could be tits up if you're banging against your bump stops.
allonblack is offline  
Old 06-01-2010, 12:12 AM   #120
hillsboro
Scooby Specialist
 
Member#: 84823
Join Date: Apr 2005
Chapter/Region: NWIC
Location: PDX
Vehicle:
11 STI
05 Outback XT

Default

Quote:
Originally Posted by bwilliams373 View Post
Headlights on...



^^ Your struts may be blown if you keep hitting the bump stops, just a suggestion. I havnt had a problem with mine.
Hmmm. Maybe I'm not hitting the stops. The springs have only been on for a year or less. Don't think they are blown It is sure one hell of a rough ride. Over a pothole or something it just goes thud. I'm putting on some RCE yellow springs next week. Guess I'll find out if they are blown one way or another.

Last edited by hillsboro; 06-01-2010 at 12:26 AM.
hillsboro is offline  
Old 06-01-2010, 12:16 AM   #121
KamikazeGRB
Scooby Newbie
 
Member#: 216191
Join Date: Jul 2009
Chapter/Region: NWIC
Location: Port Orchard, WA
Vehicle:
2008 STi
Obsidian Black

Default

Just got done installing Endless Zeal Function coilovers on the STi. It sits a little bit higher than the Cobb springs, so I'll adjust the height another day. Also rides a little rough for the baby on max stiffness so i'll be changing that later also. Other than that it drives awesome. Can't wait to go back to Japan to pick up more goodies.
KamikazeGRB is offline  
Old 06-01-2010, 12:34 AM   #122
preacher#1
Top Scoob 022
 
Member#: 129894
Join Date: Oct 2006
Chapter/Region: SCIC
Location: Sonoma County CA
Vehicle:
FSTI '04 4EAT Sierra
Gold Metallic 20G-XT, EWG

Default

Quote:
Originally Posted by 12sechatch View Post
Scic
still a sick car...damn scic cant find their sub-forum.
preacher#1 is offline  
Old 06-01-2010, 01:41 AM   #123
CorbanDallas
Scooby Specialist
 
Member#: 232583
Join Date: Dec 2009
Chapter/Region: NWIC
Location: Renton, Wa
Vehicle:
2006 Wrx limited
Quack Attack member #1

Default

I trimmed my home depot lip down. Tomorrow I am flat blacking the new trunk lid.
CorbanDallas is offline  
Old 06-01-2010, 02:07 AM   #124
smileycvc
Scooby Specialist
 
Member#: 145748
Join Date: Apr 2007
Chapter/Region: NWIC
Location: Washington
Default

Got her dirty

smileycvc is offline  
Old 06-01-2010, 03:15 AM   #125
vladimir914
Scooby Newbie
 
Member#: 226644
Join Date: Oct 2009
Chapter/Region: NWIC
Location: vancouver,wa
Vehicle:
04 sti
blue

Default

nice car love the black color but probably a pain to clean every day lol

Last edited by vladimir914; 06-01-2010 at 12:48 PM.
vladimir914 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your Subie Today? Version 2 Smoke North West Impreza Club Forum -- NWIC 1978 05-21-2010 12:43 AM
What did you do to your Suby today? BREWPUBEAVER North West Impreza Club Forum -- NWIC 1197 11-01-2009 12:06 PM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 07:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.