Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-25-2010, 04:15 PM   #1
rpatte18
Scooby Newbie
 
Member#: 243227
Join Date: Apr 2010
Chapter/Region: South East
Vehicle:
2004 2.5rs
silver

Default engine help!

My 04 scube 2.5 RS's engine is knocking INCESSANTLY. I'm pretty sure it's not oil related because i change it religiously every 3k miles. Anyone have any suggestions on what the problem could be?
* Registered users of the site do not see these ads.
rpatte18 is offline   Reply With Quote
Old 05-25-2010, 05:32 PM   #2
mr_subaru_rs
Scooby Newbie
 
Member#: 142872
Join Date: Mar 2007
Chapter/Region: W. Canada
Location: Calgary
Vehicle:
1999 Impreza 2.5RS
Silverthorn

Default

is it metal on metal sounding? when you change the oil is there ANY metal particles in it? Subaru engines have some history with weak rod bearings....
mr_subaru_rs is offline   Reply With Quote
Old 05-25-2010, 06:36 PM   #3
rpatte18
Scooby Newbie
 
Member#: 243227
Join Date: Apr 2010
Chapter/Region: South East
Vehicle:
2004 2.5rs
silver

Default

i have never seen any kind of metal in the oil. the sound as far as i can tell is coming from the back of the engine. it's most obvious at just an idle, once i'm up to speed you can hardly tell. it's an automatic as well if that helps at all.
rpatte18 is offline   Reply With Quote
Old 05-25-2010, 07:01 PM   #4
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

Are you sure it'd not just the boxer motor making it's normal noise? Over the years the noise will get louder (a lot of ticking from the valves and other misc rattles). How many miles are on the car? Does it feel and drive the same?

Mike
GrimmSpeed is offline   Reply With Quote
Old 05-28-2010, 08:01 PM   #5
AlaskanProtege
Scooby Newbie
 
Member#: 217112
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Fairbanks Alaska
Vehicle:
1998 GC8 modified
black and orange

Default

The ej2.5sohc engine has big problems with piston slap. Specially around 40-60k on up. There was a short skirt piston design in thoes motors which is what is causeing the sound. Keep an eye on ur oil level. And pressure. My 02 rs has been slapping for bout 2 years. Still runs fine. It's a buru. Run it till it blows!!!
AlaskanProtege is offline   Reply With Quote
Old 05-30-2010, 03:09 PM   #6
rpatte18
Scooby Newbie
 
Member#: 243227
Join Date: Apr 2010
Chapter/Region: South East
Vehicle:
2004 2.5rs
silver

Default

it's still driving great... there's about 120 K on the car so the piston slappin's probably the deal. If that is the case should i be alarmed at all or just go with the flow of it all?
rpatte18 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lotus Engineering Helps Develop Ultra-Efficient Direct Injected Hotfire Engine AVANTI R5 Non-Subaru News & Rumors 27 03-20-2009 04:19 PM
Tranny housing is stuck to engine - Help! syborg_97 Service & Maintenance 2 03-12-2002 06:09 PM
Need Engine help Greg 99 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 04-30-2001 09:12 PM
Engine help!! Getting engine back on mounts!! SFsube Technical Forum Archive 1 09-13-2000 01:17 AM
Need Engine! Help! Chuck Technical Forum Archive 4 06-17-2000 01:23 AM


All times are GMT -4. The time now is 03:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.