Welcome to the North American Subaru Impreza Owners Club Saturday February 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-26-2010, 08:23 AM   #1
talvai
Scooby Specialist
 
Member#: 136358
Join Date: Jan 2007
Chapter/Region: NESIC
Location: Newington, CT
Vehicle:
2006 WRX Limited
6mt/5x114/vf43/S204

Default Cel P0410

06 wrx with sti swap, stage 2 protuned. I am getting a CEL P0410 Secondary Air Injection. I cant clear it, it will stay off for a couple days and then come back. Also not sure if its related but recently been having trouble starting the car as well. So this is what will happen.

In morning turn key hear all electricals, fuel pump, etc but not like the engine is cranking and car won't start. Do it again and again and again and eventually it will start. Once it starts sometimes the CEL will come on sometimes it won't. Regardless once car is on no problems period. Car runs fine and no CEL will come on while driving period. So I will get to work then during lunch/breaks I will go on to try to turn on car again to see if it has same issue and nope works peferct the first time, multiple times and no CEL.

So not sure if the 2 problems are related or where to start looking now.
* Registered users of the site do not see these ads.
talvai is offline   Reply With Quote
Old 05-30-2010, 12:40 PM   #2
MonsterSubie
Scooby Newbie
 
Member#: 246931
Join Date: May 2010
Chapter/Region: TXIC
Location: De Queen
Vehicle:
2006 Impreza WRX
OBP

Default

The 4 first hand causes of the p0410 cel are in order as follows:

1. Air duct system fault
2. Open or short circuit condition
3. Poor electrical connection
4. Secondary air pump faulty (aka smog pump)

hope this helps. Good luck.
MonsterSubie is online now   Reply With Quote
Old 09-12-2010, 01:29 AM   #3
teevik
Scooby Newbie
 
Member#: 257166
Join Date: Sep 2010
Chapter/Region: W. Canada
Location: Edmonton, Alberta
Vehicle:
2008 WRX
Rally Blue

Default

I had this happen to me recently, only happened when I went to start the car when it was cold. I was poking around under the hood and it turns out the air pump had somehow come unplugged, you might wanna check all the connections to it.
teevik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 06-05-2010 08:26 PM
HELP!! flashing cel tommy 02wrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 06-04-2010 02:38 PM
Cel P0410? LiDrummer Newbies & FAQs 3 01-23-2008 04:17 PM
P0410 CEL code LiDrummer Southern California Impreza Club Forum -- SCIC 5 04-08-2007 01:06 PM
CEL or no CEL? chuglobal Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 03-25-2002 04:23 PM


All times are GMT -4. The time now is 02:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.