Welcome to the North American Subaru Impreza Owners Club Thursday November 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-07-2010, 11:09 PM   #1
Cobrakai
Scooby Specialist
 
Member#: 176408
Join Date: Apr 2008
Chapter/Region: SCIC
Location: Forest With Lakes
Vehicle:
2006 Acura TSX
Black

Default Bad rings?? Help! Exhaust smell from Oil Filler Cap/Neck

I've done a few basic searches with bad rings/ringlands exhaust oil cap etc etc. and I couldn't find anything worth while. I read on a previous post that of course I cannot find again that stated any exhaust coming out of your oil filler cap while the engine is running is a very bad sign. Is this true? My car consumes 1/2 quart per 3500-4k miles, doesn't feel sluggish or slow, no problems at idle. I opened my oil cap today while at idle and it smells like exhaust but there is no smoke. Please, any information is appreciated.



Thanks,
Tony


PS did a compression test 6 months ago and it was 149 across all 4 cylinders.
* Registered users of the site do not see these ads.
Cobrakai is online now   Reply With Quote
Old 07-07-2010, 11:25 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by Cobrakai View Post
I've done a few basic searches with bad rings/ringlands exhaust oil cap etc etc. and I couldn't find anything worth while. I read on a previous post that of course I cannot find again that stated any exhaust coming out of your oil filler cap while the engine is running is a very bad sign. Is this true? My car consumes 1/2 quart per 3500-4k miles, doesn't feel sluggish or slow, no problems at idle. I opened my oil cap today while at idle and it smells like exhaust but there is no smoke. Please, any information is appreciated.



Thanks,
Tony


PS did a compression test 6 months ago and it was 149 across all 4 cylinders.

fergetaboutit....find something else to worry about

if it ate 1/2qt every 200 miles THEN ya got problems.....not now
Uncle Scotty is offline   Reply With Quote
Old 07-07-2010, 11:32 PM   #3
Cobrakai
Scooby Specialist
 
Member#: 176408
Join Date: Apr 2008
Chapter/Region: SCIC
Location: Forest With Lakes
Vehicle:
2006 Acura TSX
Black

Default

Quote:
Originally Posted by Uncle Scotty View Post
fergetaboutit....find something else to worry about

if it ate 1/2qt every 200 miles THEN ya got problems.....not now

Haha thank you, but is the exhaust smell/gases coming through the oil filler cap a bad sign? I'm a ritard when it comes to these things. Is this a small sign leading to a bigger problem down the road? Thank you for your previous response, I'm just looking for more information.
Cobrakai is online now   Reply With Quote
Old 07-07-2010, 11:56 PM   #4
Cobrakai
Scooby Specialist
 
Member#: 176408
Join Date: Apr 2008
Chapter/Region: SCIC
Location: Forest With Lakes
Vehicle:
2006 Acura TSX
Black

Default

The amount coming out of the neck/cap is comparable to an exhaust leak at the Downpipe to Catback mate.
Cobrakai is online now   Reply With Quote
Old 07-08-2010, 12:25 AM   #5
BlackFighter
Scooby Specialist
 
Member#: 193940
Join Date: Nov 2008
Location: Philly
Vehicle:
2004 WRX STI Black
RalliSpec Shortblock

Default

I mean thats a deff sign of a cracked ringland. I have heard of some ppl that had great comp all 4 cyl around, but when they started to build their block they found a ringland broken. Might be the same case.
BlackFighter is offline   Reply With Quote
Old 07-08-2010, 01:04 AM   #6
AspenSti06
Scooby Newbie
 
Member#: 209616
Join Date: Apr 2009
Chapter/Region: NWIC
Location: East Side
Vehicle:
2006 STi
"Frosty"

Default

do a leak down test.
AspenSti06 is offline   Reply With Quote
Old 07-08-2010, 01:21 AM   #7
Cobrakai
Scooby Specialist
 
Member#: 176408
Join Date: Apr 2008
Chapter/Region: SCIC
Location: Forest With Lakes
Vehicle:
2006 Acura TSX
Black

Default

Unfortunately I have 4 different people telling me it's okay and then some it's not okay haha. I'm taking it to a friends shop tomorrow for further inspection and possibly leak down test. Thanks for the info guys I really appreciate it.
Cobrakai is online now   Reply With Quote
Old 07-08-2010, 06:25 PM   #8
Cobrakai
Scooby Specialist
 
Member#: 176408
Join Date: Apr 2008
Chapter/Region: SCIC
Location: Forest With Lakes
Vehicle:
2006 Acura TSX
Black

Default

Update - took my car to a local shop and had a compression test done. However, initially all 4 cylinders were under 100. Turns out the shop's tester had a bad valve that wouldn't hold psi properly. Swapped the valve and retested, 150 in all 4. The perkele paranoia got the best of me! Thanks for the info and responses guys.





Tony
Cobrakai is online now   Reply With Quote
Old 07-08-2010, 06:31 PM   #9
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

Leak down test
Psychoreo is online now   Reply With Quote
Old 07-08-2010, 10:01 PM   #10
NESW20
Scooby Newbie
 
Member#: 97341
Join Date: Sep 2005
Location: Columbus, IN
Vehicle:
1991 MR2 turbo
red

Default

normal. don't worry about it.
NESW20 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
*HELP* Identify this goo under my oil filler cap vilespankmachine Service & Maintenance 7 04-21-2010 01:10 PM
07 STi Smoke from oil filler cap/neck wrxspecr1 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 65 08-19-2008 04:06 PM
Oil Filler cap air/oil separator wittmer25 Built Motor Discussion 1 01-27-2008 06:16 PM
NEW! SPT Products from Subaru - Intake, Oil Filler Cap, Battery Tie down....! SubaruGenuineParts NWIC Vendor Classifieds 9 06-21-2006 07:56 PM
WTB: Blue or Silver Oil Filler Cap gdog1982 Private 'Wanted' Classifieds 3 01-21-2004 12:14 AM


All times are GMT -4. The time now is 05:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.