Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-01-2010, 10:32 PM   #1
ALehall
Scooby Newbie
 
Member#: 158722
Join Date: Sep 2007
Wink Hand break light, healights and rad. fans are on. WRX 2005

Hello,

I am having some problems with my car. I recently had ABS light on and was trying to find black diagnostic connector to read the ABS code in my car but by the time I realized that 2005 models don't have one (only until 2004) I already disconnected many connectors under the dash on conductor side.
After I plugged everything on its place, I started the car and when I put the shifter on D "drive" (yes, I know it's automatic WRX!) I have hand break light coming on as well as radiator fans start working while engine is cold and if I turn the headlights (low beam) on they stay on while switch is off. Also when I put shifter back on P "parking" the components still keep working until I turn ignition off.

Does anyone know what the problem could be and if anyone knows if there is a way to read ABS codes on 2005 impreza w/o subaru monitor? All the fuse are good and I'm out of ideas what it could be...

Thank you for any help!
* Registered users of the site do not see these ads.
ALehall is offline   Reply With Quote
Old 06-01-2010, 11:53 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

unplug the green connectors


and stop with trying things you dont know what are
Uncle Scotty is offline   Reply With Quote
Old 06-01-2010, 11:59 PM   #3
ALehall
Scooby Newbie
 
Member#: 158722
Join Date: Sep 2007
Default

Green connectors are unplugged dude...
ALehall is offline   Reply With Quote
Old 06-02-2010, 12:21 AM   #4
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

then ya screwed the pooch somewhere
Uncle Scotty is offline   Reply With Quote
Old 06-05-2010, 10:16 PM   #5
yamarocket630
Scooby Specialist
 
Member#: 9436
Join Date: Aug 2001
Chapter/Region: MWSOC
Location: My member# is lower than yours
Vehicle:
05 Saab 9-5 Aero

Default

BRAKE!
yamarocket630 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rad fan comes on, alarm beeps and sometimes goes off White 2.5rs Electrical & Lighting 1 06-26-2010 02:53 PM
Ruogh idle when fans are on? sszyma Factory 2.5L Turbo Powertrain 3 06-14-2007 01:48 AM
Running rich at idle but only while fans are on..?? SubieStylez Factory 2.0L Turbo Powertrain 4 11-01-2006 08:56 PM
For those with New Legacies and cooling fan stuck on all the time: Leonardo Legacy Forum 0 12-08-2005 12:13 PM
How to install sti fog light covers, and sti front splitters on a wrx turbo04 North West Impreza Club Forum -- NWIC 2 08-26-2004 11:10 PM


All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.