Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Custom Fabrication, Welding & Tools

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-09-2010, 10:02 AM   #1
Izero
Scooby Specialist
 
Member#: 121332
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: Northern Jersey
Vehicle:
2004 STi
Platinum Silver Metallic

Default Has anyone ever welded an Invidia ELH?

I was wondering if anyone has ever welded the flange that bolts to the head back on to an Invidia ELH? And if you have what would be the general settings on a MIG welder?
* Registered users of the site do not see these ads.
Izero is offline   Reply With Quote
Old 11-09-2010, 02:06 PM   #2
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

This should be done with a tig using at the minimum a 308 filler rod. Mild steel MIG is not a good idea at all.
eg33GC is offline   Reply With Quote
Old 11-10-2010, 10:03 PM   #3
TIGWERKS
Scooby Newbie
 
Member#: 256615
Join Date: Sep 2010
Default

you can mig weld stainless
TIGWERKS is offline   Reply With Quote
Old 11-10-2010, 11:02 PM   #4
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

uh, obviously?

You don't want a fat bead where the repair welds would have to be done. And I doubt the op has or desires to buy a spool for SS, or put in different rollers and liner
eg33GC is offline   Reply With Quote
Old 11-11-2010, 12:16 PM   #5
Izero
Scooby Specialist
 
Member#: 121332
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: Northern Jersey
Vehicle:
2004 STi
Platinum Silver Metallic

Default

Quote:
Originally Posted by eg33GC View Post
uh, obviously?

You don't want a fat bead where the repair welds would have to be done. And I doubt the op has or desires to buy a spool for SS, or put in different rollers and liner
^^ yea I thought about it when I got home... I usually only weld Aluminum and I'll need a hotter (much more expensive) gas, and the spool of wire...... not gonna bother... I might just take it off and bring it to someone to get it welded....
Izero is offline   Reply With Quote
Old 11-11-2010, 02:13 PM   #6
GEE-OTTO
Scooby Specialist
 
Member#: 201277
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Arlington VA
Vehicle:
2009 Legacy GT
OBP

Default

If you are welding 304 SS I would get it TIG using 316 filler, it can be MIG with SS wire but if youre not setup for SS it can be a hastle
GEE-OTTO is offline   Reply With Quote
Old 11-12-2010, 10:16 AM   #7
Izero
Scooby Specialist
 
Member#: 121332
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: Northern Jersey
Vehicle:
2004 STi
Platinum Silver Metallic

Default

yea it will be a huge hassle with my current set up I'll prolly just pop-corn the crap out of the weld... :-/ *sigh* Stupid Invidia Header! ROAR!
Izero is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone ever OWNED an IS300 M/T? eastcoastGC8G Mid Atlantic Impreza Club -- MAIC 18 03-17-2010 12:37 PM
Has anyone ever used an ozone generator? (cig smell removal) JiveMasterT Off-Topic 25 08-20-2008 09:41 AM
Has anyone ever gotten an old Member Number? DrDRum Off-Topic 19 02-26-2007 08:47 PM
Has anyone ever had an intercooler pipe explode? smdandb2 Factory 2.0L Turbo Powertrain 7 10-24-2004 05:27 PM
Has anyone ever bent an 18" rim? essogas Tire & Wheel 7 11-29-2003 08:04 PM


All times are GMT -4. The time now is 09:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.