Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-02-2010, 02:45 PM   #1
stephentodd
Scooby Newbie
 
Member#: 210760
Join Date: May 2009
Default Problems with my wrx

I have a 07 wrx with a turboback exaust and bov and recently when I try to take off normally my car does not want to accelerate. The exaust gets loud but won't go then all the sudden it takes off fine. But if I take off fast from a stop there is no problem. I have a code for my air injection system valve stuck closed could that be the problem?
* Registered users of the site do not see these ads.
stephentodd is offline   Reply With Quote
Old 06-02-2010, 05:35 PM   #2
jerbull88
Scooby Newbie
 
Member#: 248089
Join Date: May 2010
Location: albany, ga
Vehicle:
2011 wrx premium
metallic grey

Default

what you have described is more or less your car choking down. most likely you are running rich. im gonna go way out in left field and say that you dont have a tune. am i right?
jerbull88 is offline   Reply With Quote
Old 06-02-2010, 06:00 PM   #3
trick3d
Scooby Specialist
 
Member#: 202146
Join Date: Feb 2009
Chapter/Region: SCIC
Location: My Island
Vehicle:
2010 evoru
GG

Default

Quote:
Originally Posted by jerbull88 View Post
what you have described is more or less your car choking down. most likely you are running rich. im gonna go way out in left field and say that you dont have a tune. am i right?
HahahAhah yeah my bet is no tune.
trick3d is offline   Reply With Quote
Old 06-02-2010, 06:21 PM   #4
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

Post up a little more info on the car! It sounds like you might have a TGV valve that's getting stuck closed so you might have to replace the motors or sensors or possibly look into having the TGV's ported/ deleted.

Mike
GrimmSpeed is offline   Reply With Quote
Old 06-02-2010, 08:53 PM   #5
stephentodd
Scooby Newbie
 
Member#: 210760
Join Date: May 2009
Default

My car is not tuned yet the nextthing I am gonna get is cobbs.. But when I first installed the exaust I never had a problem it jus started a couple weeks ago and that's when I saw the code for the air injection pump valve being bad...and I have been looking into the tgv deletes but I am not sure about them.
stephentodd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Big problem with my 07 sti swap into my 04 wrx...... Samurai_jim Subaru Conversions 17 01-08-2009 06:36 PM
PROBLEM WITH MY WRX STI - please help me bradsti Newbies & FAQs 33 03-28-2008 06:09 PM
I have 2 problems with my WRX plz help! Venom911 Service & Maintenance 3 02-28-2008 03:31 PM
Which Will Cause Problems with my WRX Sedan? Red Rexx Tire & Wheel 3 04-12-2005 08:58 PM
Having some problems with my WRX Subarubrim Factory 2.0L Turbo Powertrain 7 03-19-2005 10:36 PM


All times are GMT -4. The time now is 07:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.