Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Tri-State Area Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Tri-State Area Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-03-2010, 08:53 AM   #1
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default NEED help! 2.5RS in Central Jersey

I picked up a 2005 2.5rs that had a custom alarm system install botched. I have removed every splice I could find, but I still cannot get the car to turn over or the fuel pump to prime. Actually, nothing on the steering column is getting power except the parking lights switch and the horn. Door locks work, but only from the switch in the car, not from the keyless entry (possible immobilizer problem?), brake and hazard lights work. Thats it.

Ignition, headlights, wipers all have no power. The climate control does not have power as well.

I really need some help from someone who knows a bit about Subaru's. This might be something stupid like a relay I don't know about or something similar.

I am located in Rahway, NJ, if anyone could come by and take a look at the car, I would REALLY appreciate it!!! I have wiring diagrams for every component in the car.

Couple day old pic of the mess, thats a bit more cleaned up now:
* Registered users of the site do not see these ads.
pMak26 is offline   Reply With Quote
Old 06-03-2010, 09:03 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Yikes.
Have you checked the large main fuses in the panel under the hood? A blown main fuse will kill just about everything.
Mulder is offline   Reply With Quote
Old 06-03-2010, 11:28 AM   #3
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default

Yea, the main fuses under the hood all look good.
pMak26 is offline   Reply With Quote
Old 06-03-2010, 11:36 AM   #4
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

usually an alarm will tap into the ignition switch by interupting signals via an inline conneciton not just a splice.

Did you re connect the wires in the factory ignition switch harness that were cut to do this?
munkis is offline   Reply With Quote
Old 06-03-2010, 11:59 AM   #5
JohnST2k6k
Scooby Specialist
 
Member#: 178465
Join Date: Apr 2008
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2006 WRB STI
Precision Built and Tuned

Default

O M G.... lol
JohnST2k6k is offline   Reply With Quote
Old 06-03-2010, 02:36 PM   #6
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default

Quote:
Originally Posted by munkis View Post
usually an alarm will tap into the ignition switch by interupting signals via an inline conneciton not just a splice.

Did you re connect the wires in the factory ignition switch harness that were cut to do this?
I actually went to the junk yard and pulled the harness (5 wires on ignition, 4 at the connector, Blue wrap) that connects to the backside of the ignition to just replace all those wires since they were F-ed up.


Quote:
Originally Posted by JohnST2k6k View Post
O M G.... lol
yup!
pMak26 is offline   Reply With Quote
Old 06-04-2010, 10:49 AM   #7
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default

Okay, now I'm desperate.

Anyone want to come look at this thing?
pMak26 is offline   Reply With Quote
Old 06-04-2010, 12:24 PM   #8
EPskate
Scooby Specialist
 
Member#: 84800
Join Date: Apr 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
02 wrx rip / 05
sti

Default

get a tester and start tracing the electricity to see where the power is stopping. Definitely a pain in the ass but I can't think of anything else.
EPskate is offline   Reply With Quote
Old 06-04-2010, 04:06 PM   #9
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default

Yeah, my multimeter took a crap on me last week. I'll pick up a new one and trace back from the ignition relays.

Does anyone know what the relays to the right of this fuse box are?


Is there any one relay or one group of relays that would cause the starter, fuel pump, climate controls, headlights, turn signal, and wipers to all not function?
pMak26 is offline   Reply With Quote
Old 06-04-2010, 08:50 PM   #10
pMak26
Scooby Newbie
 
Member#: 248000
Join Date: May 2010
Vehicle:
05 2.5rs

Default

Or this:



Could someone take a look at their subie and figure out if anything attaches to either of these clips (the gray or the white one). I believe they're under the molding, which pops right off with a pull, and pops back in (plastic clips).
pMak26 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need a subaru mechanic in central jersey for head gasket repair . watchunglava Tri-State Area Forum 7 12-19-2009 02:15 PM
Need help with inspection in South Jersey NJHK Tri-State Area Forum 15 08-30-2009 04:11 PM
wrecked tranny need help- 2.5rs jakeachy Newbies & FAQs 2 11-14-2007 05:21 PM
FS 98 2.5rs in central cali-wrecked brissbin Private Vehicle 'For Sale' Classifieds 1 09-27-2006 10:49 PM
Anyone in Central Jersey free this weekend to help me get my center diff in kx02wr Tri-State Area Forum 6 11-04-2005 02:38 PM


All times are GMT -4. The time now is 08:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.